Feedback


Pimax with raspberry pi 3 (8)
Oculus game, no sound out of DAS (3)
SUPEN-1508: I can´t login in support page to continue with the technical support (15)
Black dots in each games which you may can notice (7)
[Replied]Pixel noise an flashing in new 8K (SUPEN-885) ( 2 ) (25)
Sort of...double vision? SOLVED (5)
[Solved] Some trick to activate the Pimax? (8)
Shipping advance orders before fulfilling kickstarter backer orders? (3)
Category for communication in german language (10)
SUPEN-1359 image issue with 5k+ (9)
Issue Starting Pimax 5k+: Screen does not turn on, LED Red (solid) ( 2 3 4 5 ) (82)
Headset does not work, PiTool shows "Disconnected: Diagnose(10935)" (14)
Changed Kickstarter email, how do I inform pimax of the change? (8)
Setting up with one base station ( 2 3 ) (43)
[Replied]Backer #441: Cracks on 5K+ (SUPEN-1432) (8)
Hello got my 5k+ from ebay and it is AWSOME! (2)
Kat io and pitool incompatibility with oculus games (7)
Issue with pimax 4k and new steamvr patch 1.2.7 (latest stable version - released 19/1/19) (6)
Pimax 5k+ elite dangerous (3)
Random Pimax 5K+ Shutdowns and Pixel Storm (8)
Large fov basically broken with parallel projection on from excessive blur. (rendering bug) (6)
A little bug with multiple screen (2)
Full tracking numbers in public spreadsheet while good intention is probably not good idea (7)
My replacement just arrived within 4 days after get tracking. Good news & Bad news (19)
Has anyone found more distortion in v1.0.1.95? (19)
PiTool needs a setting to Remember Your SS Value per Application - like SteamVR (7)
No Tracking -> Headset in Stand-By-Mode or Basestation not connected (9)
Lone echo don't start with my Pimax 5K :/ (1)
Backer #950 5k+ received but need help (12)
So I received my Pimax 5k+ with 3 issues ( 2 3 4 5 ) (94)