5k+ on AMD Radeon RX580

review

#1

My 5k+ works in general and performance with a Radeon RX580* on first impression looks good. That was on small FoV in Elite Dangerous with reduced settings. Performance wise it was not too bad when compared to my Rift setup. (*it’s a modded RX480, need to check other BIOS mod for better display compatibility)

Unfortunately there is not enough time at the moment to really test and optimize all options, I just did a short cruise without a fight to see what it could be like:

  • in ED the blacks are not good enough, I will have to try the fix recommended by @Yata_PL, in the PiTool planet scene the dark colors are way better
  • only in the hangar in ED when the ship turns there was stuttering. I will have to try to find optimal settings, not a deal breaker atm
  • I have no lighthouse so only 3DoF - in ED the Y rotation axis is off, slightly in front of me causing wrong movement, that is sort of a deal breaker
  • the edge distortion in PiTool even in normal FoV is too bad for me, moving the HMD slightly away and upright improves it a bit, but for a first try i had to use the small FoV non the less, face cushion customization will be needed I guess
  • the headphones give me crackling noise with my Sony headphones and iPhone ear plugs, probably caused by insufficient GND separation, have to look into that, it’s a deal breaker atm but might be fixed with the audio headstrap and matching audio plug (?)
  • in PiTool with the planet scene - while shaking the head fast - the rendering can’t hold up and brakes some frames, that isn’t the case with ED. Missing triple frame buffer there?
  • in PiTool with the planet scene - I noticed some whiteish pixel thingies on the left display only, hope this fixes itself over time.
  • Oculus Lucky’s Tale worked but not ED via Oculus, no matter what I tried. So I had to download the 7.5GB on Steam, that was kind a waste of time. I hope @Pimax-Support this gets fixed soon and we get a manual about what to do to start Elite Dangerous via the Oculus software stack
  • the HMD wasn’t found at times, re-plugging the USB did the trick, rebooting the HMD requires a restart of software too.

Too early for a verdict, I need to

  • get a fix for crackling headphone noise
  • get a V2 lighthouse asap
  • further try software optimization, aka need to find the time…

… will report as soon as I have relevant news


#2

Congrats on receiving your 5k+!

@Dallas.Hao please add to earlybackers.


#3

My interim verdict is that the Pimax5k+ has ruined my VR gaming experience for now.

One one side it is so much better resolution and FoV that it’s not any fun going back to an Oculus CV1.
On the other side the problems with the 3DoF tracking and usage experience are so big it isn’t really fun either. The audio crackling can’t be avoided with any headphones I have, that is a big meh too.
While the beta software works I’d rather wait for the next stable release to give a next try, trying to do things beyond VR that have been left undone…


#4

With Audio check out the variety of solutions