5k Plus - nothing detected by PiTool whatsoever


#1

I just got my 5k+ today in the UK but PiTool just doesn’t detect anything. Not the headset, not the base stations and not the controllers.

Headset has power and the front LED strip is alive. The power LED is currently red but was green earlier. It makes no difference though.

Here is what I did:

  1. Installed PITool (.90)
  2. Connected USB cable to PC
  3. Connected DP cable to my AMD card
  4. Connected AC cable to the dongle
  5. HMD turns on and Windows 10 adds Pimax as Bluetooth device
  6. PiTool detects nothing and says I should plugin the HDMI/DP cable

Weird symptom: When it is plugged in, there is mouse lag that occurs at 1 second intervals.

I’ve tried (1) uninstalled and re-installing PiTool (2) different orders of plugging in (3) different USB ports and versions (4) powering on and off via HMD button and via AC (5) firmly pushing the cable that goes into the HMD in case it’s loose.

Any ideas?


#2

Go to the ‘services’ tab in your task manager. Locate PiStarterService. Right mouse click on it: Stop it. Wait 10 sec. Start it. If not, do it again. Should work after 1-3 times.


#3

I have just tried that a few times but with no success. When it turns back on, the error goes back to telling me to plugin the DP cable.

Only interesting thing is stopping that service also stops the 1 second interval mouse lag.


#4

Hmm hadn’t read this. Not sure, but this probably indicates some serious error? @Pimax-Support


#6

The LED was green for most of my initial testing before posting this topic but then at some point it just stayed red.


#7

You are Running an Amd Vega Card. It’s a bit of dance to get detected. Until Amd can fix their driver with pimax it’s going to be a bit rough.

@Dallas.Hao has Amd given an idea when an update driver will be available?


#8

I’m running an AMD R9 390 but I assume your point still applies.

Thanks for letting me know. This isn’t such bad news for me as I’ve been planning to get an 1080 Ti.

Btw, why would a display driver issue also cause the base stations and controllers to not be detected?


#9

No actually the r9 390 should connect okay & noy have the mouse issue.

I will need to dig my r9 390 system out & test again.

What is your system specs? & gpu driver version?

I have on that system i5 6500 16g r9 390 8g (Gigsbyte) on Win10 pro

Not a lot of things ran well. But some okay.


#10

I’m using latest drivers 18.12.1.1 but also tested using slightly older drivers as I only updated today.

CPU: AMD Ryzen 7 1700
RAM: 8 gig
OS: Windows 10 Home (1803)


#11

Sorry, just to ask again… does it make sense for gfx card issue to also cause the base stations and controllers not to be identified PiTool? Nothing is being detected apart from USB.


#12

That I don’t know as I don’t have LHes.

I do find red usb ports often work better


#13

Hopefully it’s just a case of detection order - checks for USB, then checks for HDMI/DP and then moves on to base stations and controllers. That’s what I’m hoping because otherwise my HMD is probably broken.

Please can anyone with a 5k or 8k please unplug your video cable and tell me if that then causes the base stations and controllers to no longer show as detect in PITool?

@EarlyBackers


#14

Scary to see so many people cant get pimax to work right out of the box. My vive went on 123 no problem.


#15

Please contact our support team via servicedesk, they are handle this and will respond very quickly.

The servicedesk link : http://feedback.pimaxvr.com/


#16

If anyone would be willing to quickly try this for me, would be greatly appreciated.


#17

Any luck resolving this issue? I just got my Pimax 5k+ and I’m having the exact same problem. HMD turns on with solid red light and pitool says the HDMI/DP is disconnected. I have an Nvidia GTX 1080 with the latest drivers so it isn’t something to do with AMD graphics drivers on my end. Unlike you though I never had a green LED if that matters at all.


#18

Nope - I created a ticket at servicedesk as @Dallas.Hao suggested but 5 days later and no reply.

Interesting and worrying that you have the same issue with an 1080.


#19

Well I guess it is good to know I shouldn’t be looking forward to a prompt response.


#20

@Pimax-Support @Dallas.Hao @PM_Sean. The above gentlemen need some support help please. Please also add them to early backers.

@EarlyBackers might have some insights.


#21

Thanks for trying to get us help Heliosurge! I’m hopeful this is just a software issue that can be easily addressed in some way I haven’t thought of.