5k Plus screens are always blank

issue

#21

I have the same problem here, snow all over the screen, see my other thread.
Backer 753 here, hope it is not a bad batch.


#22

Backer 436 here, I just got my headset and tried it on two different PCs. The first was a 1070 MSI GS65 laptop, and I only get a blank screen besides an initial brief image after doing room setup. Like you SteamVR was connected and tracking worked.
On a desktop PC with a GTX 1080 I can’t even get the headset to be detected by PiTool, with Windows giving me a USB error.


#23

Windows is giving Usb error or Pitool diagnose?

Are you using motherboard usb ports? Preferably uab v3.x ports. I find the red ones often work best.

Which headset did you receive?


#24

I got a 5k+. I got an error from Windows and am using the red ports on the motherboard. I actually did get the headset to work on a third machine which is my weakest one with an AMD RX 580. I did notice that there is quite a difference in color/brightness between each eye though. (looks like it’s caused by some purple and white haze in the bottom of the right eye :frowning: )

@Dallas.Hao @Sean.Huang


#25

Added a couple of pimax team members regarding screen.

On your system that windows gave error in red usb ports.

Ensure Bios is up-to-date & install chipset drivers & other drivers from your MB website


#26

I will contact with my Tech support colleague for fix this headset issue for you.

Please follow these steps:

click the “Support” button on the banner for submit your issue
2.Give me your question number for teach support to contact with you via service desk
3.The issue will be solved soon


#27

Hi, I haven’t heard back from you since I shipped 5k+ nearly 3 weeks ago. I’ve sent multiple emails to Pimax support email since then. Am I getting a replacement headset anytime soon?


#28

Pleasw post your Supen (support ticket number) here.


#29

@Sean.Huang
@Alan.sun
@Doman.Chen
Please check this topic