60 Hz refresh rate?


@noro is a real video player buff. He could likely explain this better than I.


There is nothing which decides which refresh rate the headset will use as it will always use the native one (i.e. 90Hz, or if you use the new PiTool beta, you may try to change it to some other). In general, contrary to how the standard monitor panels (or flat TVs) works, the headset supports only one refresh rate and it is “baked” into it, while the monitors and TVs can propose the list of supported modes with different resolutions and the refresh rates to the source (PC) and it can then ask them to switch to particular mode and use it.

Obviously none of the proposed refresh rates by Pimax (90, 80, 72, 64) helps with 30 or 60 FPS videos as they do not fit so there will always be some frames displayed twice and thus producing “judder”.


First of all, let’s clear the question because it shows that you made a hasty mistake or got something wrong in general:
“Material”/footage is recorded win fps (frames-per-second)
and a display displays e.g. video at a certain Hz (frequency)
So saying, material is not recorded in Hz.

fps and Hz play together tough, think of it (very roughly) like a group of postmen carrying out packages.
The goal is that every worker is having the same amount of work to do for a healthy EVEN working environment :slight_smile:

The problem actually was well answered by neal, but let’s try another approach :slight_smile:

Setting an exact MULTIPLE match of fps/Hz ratio delivers an EVEN and good result:
3 MULTIPLE 24fps (framerate of video) EVEN 72Hz
2 MULTIPLE 30fps EVEN 60Hz

So with 60 fps for 90Hz you’ll have the problem
In this case, 30 frames need to be displayed additionally to the 60 frames in order to be displayed on 90Hz.
Instead of simply being a fitting multiple, those “fake” frames are either stretched or/and doubled to fit .

So instead of the work being distributed nicely among the workers, only a part of the postmen need to go twice to deliver all packages which leads to a bad uneven/odd working environment with bad flow:rofl:
And cutting the packages in half in order to distribute the work would be a bad idea either

Hope this helps more than it may confuse :sweat_smile:


@noro really good explanation ,even think my mother will understood this. (I do some mistakes because english is not my native language).
@risa2000 what you write make sense.
More knowledge lead in to more questions.

We agree that recorded material with 60 frames per s should be presented in either 60Hz or a multiple of this (requires more data)

I guess the framerate and resolution is negotiated in some way between the devices through the dp.

What is the problem by supporting the setting 60 frames in pimax ( is it only sw) ?


The framerate is set by the PiTools software. There’s likely to be some firmware in the headset too, but the setting is controlled by PiTools.

The problem is that 60 fps/Hz is not supported by Pimax. They added 64 instead, which makes absolutely no sense to me.

60 Hz is particularly important for the 8K headset, since it doesn’t support 90 Hz, which means that the most common video frame rate (30) will look juddery. A rate of 64 fps will look particularly bad for 60 fps video on all 3 headsets (5K+, 5K BE, and 8K), since that doesn’t match the native refresh of the headsets (90, 85, and 80 Hz).


I imagine it will be. Just atm there focusing on smart smoothing more for games. 72hz at least will be good for 24hz cinema for the time being.


I could image that there is a problem with the backlight stobing. The backlight ist turned on when the image is displayed and switched off afterwards. This is a low persistant display.
Could be that the desired brightness levels are not reached because the time between the frames is now longer (less light reaches the eyes) or the flickering is simply to much.

Personally i do see light flicker @64Hz mode (easy to dismiss in games where it is normally not very bright) but no flicker @72Hz. So 72Hz is the mode i use most.


If you want to watch 24p content, just use the 72hz mode.


Really weird that pimax do not support 60hz.
@neil_white_iii do you think the 80hz will look so much worse on 60 frames video content ?


I think the brightness issue could be solved by leaving the backlight on for a slightly longer duration, when displaying 72 or 60 Hz content.


That’s what I was refering to. Atm cinema 24fps is supported in the offered refresh mode. :beers::sunglasses::+1::sparkles:


Oculus & Og vive don’t directly support less refresh rate either.


@neal_white_iii do you think it will a significant difference to watch material with 60hz framrate in 80hz
compared to 90hz


Because 20 frames will be shown for twice as long as the others. Smooth motion will have image judder.


Ok but if you have 90 hz refresh rate as in vive and oculus you will show 30 frames extra i assume.
Will 20 frames less really be that worse


It’s not just 80 or 90 Hz. Any refresh rate that isn’t an exact multiple of the source material frame rate will have the problem.

In my earlier post, I said…

A rate of 64 fps will look particularly bad for 60 fps video on all 3 headsets (5K+, 5K BE, and 8K), since that doesn’t match the native refresh of the headsets (90, 85, and 80 Hz).


But then it maybe generates smearing because of the backlight beeing on too long. See, this fights the „non persistant“ approach. It could very well be that 64Hz is the lowest they could go without smearing and/or bright enough display. It could be the lowest sweetspot.


Then they should just omit 64 Hz. According to reports, it flickers badly and there is NO GOOD REASON to offer it. 60 Hz makes sense for videos; 64 Hz makes no sense at all.


@neal_white_iii I must ask you again about this issue.
Are you absolute sure that this will be visable ?
When will you see this and how will this defect look ?


Honestly…if you even never experienced this issue (that u obviously were never aware of before) on your monitor don’t worry about it anyways in VR either.
I am aware of the “every day” issue since ages in 2d and use reclock/svp to fix it. But I’m also very perceptible to that, lots of ppl do not notice it.