6dof gone after reinstall

issue

#1

SteamVR kept asking me to re run the room setup, so I reinstalled both steamVR and PiTool.

No more room setup error but now 6dof doesn’t work anymore, both lighthouses are detected, I ran the room setup in both PiTool and SteamVR but I neither have controllers in games nor 6dof for the headset.

Any idea?


#2

Which pitool? Latest?


#3

Yes 111 beta…


#4

Just a thought… Try running the Pitool and Steam as admin.
Are the installation locations default?


#5

Yes default locations and antivirus/firewall turned off during installation.

I ll try what you said then I ll proceed to re installation.


#6

Just run the Pimax diagnostic and fix whatever it says needs fixing, then restart the PiServiceLauncher service from the task manager every time you go to use your headset.

Since I ran the diagnostic, and have been restarting the PiServiceLauncher each time I go to use my headset (turn on lighthouses, turn on Pimax, restart PiServiceLauncher, launch SteamVR), everything has been working perfectly.

If those steps don’t solve your issue, then simply delete all folders from the %programdata%\pimax\runtime\config\lighthouse folder (copy paste this into your explorer taskbar and hit enter), then restart the PiServiceLauncher.


#7

I did run the diagnostic and nothing wrong was detected.

I used my headset for the first time in days and now everything is working fine.
I think rebooting my PC fixed the issue.

PS: I think restarting Pimax services in the task manager would have been enough.


#8

This more of a feedback to Pitool devs: I noticed that Pimax service does not like if HMD is turned on while base is off or out of sight. Service restart helps, but feels like a bug that needs fixing :slight_smile: