A new little brightness trick for the pimax 4k piplay 2.0x. No debug tool needed


#1

Alright, I may not be the most gifted or active user on this forum but I can say for once I got a little victory I think it is worth sharing!
TLDR: This simple hack is to lower the brightness of piplay ver 2.0x below the standard 0 level without the need of the Debug tool (I could not find it anywhere, let me know if it is still around, thanks)

Open the windows registry with regedit, go to [HKEY_CURRENT_USER\Software\PiPlay2] make 2 new Dwords named min_bright and max_bright and set the values as follow
“min_bright”=dword:00000000
“max_bright”=dword:00000005

Make a backup just in case a cat runs on your keyboard or something…

You now should be able to go down 1 notch past the standard 0 on the brightness Piplay slider! Really needed if you removed the shutter glasses. Please note that if you now go all the way up max on that slider you will get an error “brightness could not be set” Since it only supposed to go to 4 and not 5 I guess?! I am sure @sjefdeklerk has a more scientific explanation. No big deal. that is all, mission accomplished my eyes are saved!

Some more story details you can skip reading are following…
Sooo… I had some spare time to toy with the device this weekend and I decided to go balls deep and remove the filters/shutter glass. I know I am late to the party, just gave it a little extra time just in case someone of you underpaid beta tester got blind from the radiations, I mean blue light :smiley: (really nice post post by the way Removing the shutter glass)

Amazing result!! I did not brick the device and the movies looks even more amazing now!! Also that cluster of dead pixels in the center of my left eye view vanished. It was in fact a tiny spec of black pulverized foam from that crumbled and got in at some point during the 3+ weeks shipping to the other side of the world. (The very first thing I noticed last year opening the box was that fine black dust all around the device) Please Pimax pack the device in a plastic bag or change that cancer padding foam?! thanks!!
Also many thanks to CMM for helping me finally moving past Piplay 1.1.92 after 3 unsuccessful attempts last year. All I had to do was to delete left overs files from uninstalling the old piplay @ Steam\steamapps\common\SteamVR\drivers\pvr and uninstall and old k-lite pack (and not to disable the antivirus as suggested by the installer)

Only thing left to deal is OVER THE TOP BRIGHTNESS. The deep space in Elite and in my ue4 projects is no longer black, is GREY!!.
easy fix, lets open up the debug tool… ho wait… Where was it again? Pimax where did you put the debug tool in this release!!! OK nevermind looks like is GONE. Good job! Luckly I found this little file called bright.reg in the folder C:\Program Files\Pimax\PiPlay2\QtTest that gave me the idea of the above tweak that solved my Issues (after reading stuff from the Pros like sjefdeklerk). I can now play the new Elite dangerous patch in deep DARK space. Or not, the weekend is gone. Maybe next week :smiley:

no firmware was hurt in this experiment
R.I.P debug tool,you will be missed!


#2

Awesome discovery! :beers::sunglasses::+1::sparkles: