Additional testing with Elite Dangerous


#1

Hi all,

just letting you know that i was testing my ED out with some different graphics settings and was very impressed with the results.

I have been running piplay render at 2.0 and in game settings at VR ULTRA (with shadows and reflection turned low - but it is quite taxing on the card and i did get micro stutters in high graphics areas.

So i am testing using latest Piplay (so it uses Pimax render and not steamvr)

changed the piplay render slider all the way up to 3.0 (far right)
made sure that SteamVR supersampling is set to 1.0 (as piplay render replaces steamvr’s)
set the in game settings to VR LOW… (yes i know :slight_smile: )
then turned up:
Environment Quality to ULTRA
Terrain Quality to ULTRA
Materials to ULTRA
HMD Quality to 1.0 (not needed anymore because it seems to be done via the Piplay render)
Supersampling to 1.0 (not needed anymore because it seems to be done via the Piplay render)
JetCone Quality to ULTRA

Hardware on my RIG:

I7-4790 @ 3.60GHz
24GB ddr3 1600MHz
Aourus GTX 1080TI
Win10Enterprise
I noticed that even setting the game graphics to VR LOW did not have a major impact on the visual quality of the game as the render being set in Piplay at 3.0 seems to do this pretty well. I obviously turned up all the optional ‘key’ graphics for visual improvements around stations, planets, bases and asteroids just because the GFX card can handle it.

I would suggest those of you using the latest Pipay drivers save your graphics settings in case you want to revert back and then try this for yourself.
turn off the steamvr supersampling settings (if you haven’t done this yet), lower all of your in game graphics settings with VR LOW and then turn up the piplay render … do it in stages… i.e. 1.5 … then 2.0… then… 2.25 etc until you hit the sweet spot, then try turning up specific graphics settings in game to make the visuals pop. … like terrain and environment etc

regards

Eno.


Elite Dangerous
#2

I’ll have to try this out, if I can’t wait till the Kickstarter goodies arrive, and end up getting another 4K to keep me busy till then :slight_smile:


#3

one question @Enopho:
(maybe two) :grin:

  1. in the nVidia Control Panel do you have set to maximum performance the power management mode?
  2. do you use something like EVGA Precision or other overclocking software?
    I noticed that with a normal overclock and setting set to HIGH in Elite Dangerous I do not drop under 50 frames even in the stations.
    I use Oculus Rift… and i have supersampling at 1.3 or 1.4.
    I use also the Pimax but i’m waiting some improvement to Piplay.

#4

Hi there.

I have tried EVGA to overclock just to see what the cards are capable of but I turned them back down… Managed to get the card to clock at 2ghz and still run at 65deg

But for my ED settings currently, no there not overclock, but remember that piplay render slider is all I am using to set a good quality render (latest piplay beta)
Turn off steamvr supersampling
Turn off in game supersampling
Less strain on your GPU and no micro stuttering, and still has a great view!

Even better I would say that hmd quality set to 2.0 and supersampling at 1.5 in game!


#5

Hi guys

I asked Eno (i think its the same Eno anyway!!) on the frontier forums about this but i wanted to ask here as well

I am trying the latest piplay with elite and using the piplay supersample and wanted to know ask some questions

I have an older i5 3xxx quad core with 16gb ddr3 and a pny 1080 xlr8 gpu (not the ti)

I set steam ss to 1, piplay to 1.5 and elite ss to 1 with vr-low for edprofiler and if i press CTRL-f in the window that mirrors my hud i see yellow FPS numbers around 60fps, with occasional drops to 30 inside obsidian orbital station i get occasional stutter as well during the elevator operation cutscene in the station.

Is this normal or should i be seeing better?

If i play the game non VR on the same system i can maintain 100fps solid green on my 21:9 3440x1400 monitor

Would setting my monitor resolution to Lower help out my gpu when i am playing in VR? As it seems when i turn on the steam VR frame checker, elite seems to show max GPU usage when in game with the graph at about 30% for the CPU (I’m not exactly sure how to interpret that graph)

Note - i am using a pimax 4K BE headset, not the regular 4K

Thanks

~L


#6

Hi there, yes it’s the same Eno as on Frontier forums. Some of biggest GPU hits in the ED game are on reflections and shadows, and make sure hud quality is on low as the render should be scaled with the PiPlay slider to improve your visuals.

Make sure they are down and try again.

Eno


#7

Thanks Eno!! I did play about with the settings, but it seems that my frames are locked at 66-67 FPS no matter what. Even if I hit CTRL-F on the splash screens, they will dip down into the red at 57 - but they never go green.

If I use the monitor instead of VR, then I get it locked at 100FPS

I have a Viotek 34" 21:9 monitor recently purchased from Massdrop, that has freesync on it - verified that it’s working using the ufo-test website - nvidia control panel has the Hz set to 100Hz

I’ve no idea at this point why Elite caps out the FPS to 66-67


#8

Hi Loribee,

You will never get a HMD VR headset to match the FPS of a standard monitor. your BE model can go higher than 60fps but I dont think it can go as high as 90 in ED! and just so you know my 4k can only reach 60fps as the 4K standard one is capped at 60fps,

you should still have smooth gameplay with 55-60fps anyway… if you are getting micro stutters you may want to post all of your settings so i can test them a 1080 should give you buttery smooth visuals, so somthing is off.

Eno


#9

Hi Eno, thanks I read that the standard 4k one was capped @ 60, but I thought the 4k BE was a little bit better. I realize that it’s not going to hit the 100Hz of my Freesync display.

I will work on tweaking the settings, but for the most part its working great. I actually have seen some increase in clarity of text by using piplay to handle the SS etc (I’ve currently bumped that up to two and kept the in game at the lowest

I will also note that i see the SteamCompositor (??) pop in for a fraction of a second when i enter stuff like Holo-Me or Outfitting with a corresponding framedrop - but actually gameplay is pretty smooth and does not cause me any motion sickness issues

Settings

Piplay 2.0
SteamVR 1.0 (disabled)

ED Profiler

SS 0.50
No AA
Texture quality Med (High seems to be ok as well)
Shadow Quality Low
Amb Occ - Off
Env Qual High
FX Qual OFF
Reflections Low
Material High
HMD 1.00
Galaxy map Medium
Terrain Medium (work slider @ 75%)
Terrain LOD off
Terrain Material Med
Terr Sampler High
Jet Cones Med


#10

you definitly should upgrade your CPU for i7 3xxxk - Elite is very CPU demanding in VR. I had i5-2500k, now have 3770k and diffrence is like night and day…


#11

ok thanks Yata - i currently have a Intel i5-3570K CPU @ 3.40GHz, 3401 Mhz, 4 Core(s), 4 Logical Processor(s)

is it possible to swap out the CPU for an I7 4 core one in the same mobo? would you recommend doing that? would it be that much of an improvement?


#12

if i5 3xxx family is supported than i7 3770k as well… but to be 100% sure check your mobo specs at mobo producer web pages


#13

Hi - i read that the i7 3770k is not that much of a step up between the two - it’s probably better to upgrade wholesale to a newer gen cpu and ddr4 memory and newer motherboard

i have these on my amazon list as my next upgrade (which i might have to go to for the 8k headset)

ASUS TUF X299 MARK 2 LGA2066 DDR4 M.2 USB 3.1 X299 ATX Motherboard for Intel Core X-Series Processors
Corsair Hydro Series H100i v2 Extreme Performance Liquid CPU Cooler, Black
Intel Core i7-7800X Processor

i’ll probably hold off and dial stuff down in elite until then - that probably makes more sense


#14

I would go for Core i7 8700K and new mobo with 370 chipset for this procesor like this one https://www.asrock.com/MB/Intel/Z370%20Extreme4/index.asp
Probably new i7 8700k is right now the best option for gaming https://www.youtube.com/watch?v=KV2paNMRBTs


#15

Hi Loribee,

try these settings.

ED Profiler

SS 0.50
No AA
Texture quality High
Shadow Quality Low
Amb Occ - On
Env Qual Med
FX Qual Med
Reflections Low
Material Med
HMD 1.00
Galaxy map Low
Terrain Medium
Terrain LOD High
Terrain Material Med
Terr Sampler Med
Jet Cones High

set the Piplay to the highest it can go without stutter… if that is 2.0 then leave it be.

let me know how you go :slight_smile:


#16

hi - thanks Eno

I set Elite as you posted, and it’s doing ok for the most part, outside of stations i get really good butter smooth gameplay, but approaching and inside stations i get some little jitter and the frame stats change to look like this

outside of stations in supercruise the GPU and CPU is half of that with no red late-starts


#17

Can you try putting texture Qual to low, see if that makes a difference in stations

Eno


#18

texture qualify only consume video ram , not fps
please disable ambient oclusion - it should give you additional 5~7 fps
also render distance is very important , try to move slider at 1/2 or 2/3


#19

This seems to be the most comprehensive topic about Elite Dangerous. I took the plunge, what with the 6€ price on the current Steam sale. I also upgraded my drivers from 1.1.92 to the latest 2.0.5.

For some reason the 1920x1080 tickbox got enabled after I specifically turned it off after installation. ED started looking much better after that.

There is a strange thing happening with the game. I have a 1920x1080 native 27" Asus display. The game runs fine in 2D borderless in this resolution. As soon as I start it in VR mode, the game switches to a 1280x768 window, and will retain this resolution even when I restart it in 2D mode. Changing the resolution in-game back to 1920x1080 only changes the size of the window on the screen, I haven’t noticed any change of quality in the Pimax. Should there be a difference?

Also, how does one re-center the view? Apparently Pimax still haven’t implemented a global nor hardware key for that. If I take the HMD off, alt-tab to PiPlay to hit the “new” recenter button (as if an off-center cockpit wasn’t immersion-breaking enough), nothing happens in the game. If the in-game hotkey to do that is called “Headlook Mode>Reset Headlook”, it does not nothing on the Pimax HMD, whether I bind it to a key or a stick button. Any ideas?


#20

Hi Neofit,

OK so what you have to remember when using VR is this.

Changing the resolution in game when in VR will ONLY change the resolution on the mirror image on your monitor… it does not change the resolution on your HMD. the Pimax 4k will upscale the HMD’s video to 4k if you have unticked the 1920x1080p option in piplay. if you have ticked the 1920x1080 then the HMD will display that lower resolution. … changing the resolution in game will have no effect on the image on your HMD at all… it will merely resize the video on your monitor which is good for screen capture.

regarding the resetting of your orientation - this can be done with a key binding on your joystick or keyboard and that is great for minor adjustments, but the best way is to click on steamvr icon (top right of steam) and wait for the steamvr popup window, then click on its drop down arrow and choose DISPLAY MIRROR, when the mirror window opens, click on it and look straight ahead with the HMD pointing forwards and press Z key on your keyboard… that tells steam vr which way you are facing. then launch ED. (once this has been set you can close display mirror screen - but i do recommend doing this EVERY time you want to play ED and before it is started

If you want to set the HMD orientation when in game you need to set the key binding 1st in ED.

click options in game
click miscellaneous to expand it
the option reset HMD orientation (not reset headlook - reset headlook is if you are using a mouse to look around and want to get the mouse to look forwards, and has no effect on HMD vr.)
bind a keyboard key (i use pause) and in the right column i bind a joystick button [Joy 10]

then if i need to make a minor correction in game to my orientation i press the joy 10 button on my joystick while looking directly forward.

hope this helps

Eno