Additional testing with Elite Dangerous


#21

so i was getting annoyed with the pimax and Elite Dangerous… basically, even when playing in VR Ultra in game settings the graphics on the in game characters joysticks kept glitching… (blurry mess). this is with Piplay 3.0 and VR Ultra settings enabled., other issues were even with shadows on ULTRA when approaching stations or bases on planets the shadows seem to be flickering completely ruining the immersion. talking of planets… in VR Ultra approaching a dark side of a planet is damn near impossible to see where you are going… its just plain black! but on the monitor it auto brightness and gets lighter as you approach… just not in the HMD.

so i did some testing…

about 4 hours of Elite Dangerous in VR tonight, and i have come to the conclusion if you use piplay at 3.0, (using a GTX1080ti) and set the ingame resolution to 1920x1080 (pimax is on the higher resolution) and then use graphics settings as ULTRA (not VR ULTRA) the graphics look better… for instance: the in game joystick does not turn into a blurry mess - all the time i was in game this never happened! the shadows approaching stations are crisp and do not flicker, the shadows on planets are crisp even on medium to ultra shadows! and the planet surfaces now auto brighten when you approach the dark side of the planet! all that and no fps loss?!

so now i am wondering … why the hell would you use VR ULTRA settings in ED if the normal ULTRA settings seem to give better visuals and the fps does not drop ? in the HMD the view seems to be just as good as the VR ULTRA graphics settings and i can see no difference except the obvious improvements when using just ULTRA settings?

can i ask other Elite Dangerous players to try just using ULTRA in game settings (if your PC can run it) of the equivalent i.e. VR MEDIUM… use MEDIUM instead. can you tell me if the shadows… brightness near dark planets… stations etc look better or if its just placebo?

cheers

Eno


#22

I have been playing ED lately with MSI GTX1080ti Gaming X, because I finally have working solution for Pimax lens “features”. And now that Pimax lenses are not a consern, I’ve been trying to max out graphics settings - and honestly I have no idea how you are able to pull off Piplay setting of 3.0.

I started to believe that I have something wrong with my setup/drivers. If I set Piplay 3.0 even the VR LOW setting in ED is too much. The image just is not smooth. As a benchmark move ship’s launch platform in station up to launch position. If the wall warning markings are not smooth while platform is moving up, I consider graphics setting too high for my PC.

I noticed that SteamVR timings chart show “Late Start” for CPU timings when ED is running. Do you see that with your setup. My CPU is i7 6700K and no change, if I OC. Steam performance tool for VR shows everything is fine -> highest score with no frame drops.

Currently I am settling to Piplay setting 1.75. I wil try how high I can go - just that Project Cars 2 is equally important to me and I would like to find setting that fit both purpose.


#23

ok…

not sure what memory you have in your pc but the rest of your machine is similar to mine, but you have a better cpu.

I have a i7 4790
Win 10 Enterprise 64bit
24GB DDR3
Aourous GTX 1080ti 11GB
SSD for OS
2TB 7200 WD Black for games and data

now things to know.

nvidia drivers… DO NOT use the latest drivers… they cause micro stutters! use 384.94-desktop-win10-64bit-international-whql (assuming you have win10 64bit they are older drivers from July last year but are the best ones for Pimax… no micro stutters and super smooth!!

next i am using piplay 3.0, although the ghosting is slightly worse in this version than the latest 2.x driver… its up to you, but as i like to test the drivers i always go for the latest… for me the speed is no different.

Put Piplay on 3.0 (trust me) :slight_smile: and as you have a 1080ti, also set the resolution to the highest in piplay… dont bother with 1080. these are my settings

Now into SteamVR settings. As piplay have their own rendered… you need to turn off ALL of the steamvr performance settings
Launch SteamVR and click drop down then settings. Then click on Performance. make sure ONLY Allow asynchronous reprojection is enabled

Next goto Developer tab and set it like this

Supersampling to the lowest setting 0.6
Enable Always on Reprojection
Check for Steam - ticked

Now in game settings…
Personally i was using VR Ultra, as you can tell from my post above, but i have found that just using ULTRA graphics settings is actually better… i get better FPS, no lag, no shadow artifacts, and the planets dark side light up a bit when i approach which really helps.

another thing to do if the game is too dark for you is to switch to pimax video mode and modify the nvidia control panel on the pimax screen to better represent the colours/brightness you want.

From what you describe… i suspect that the Nvidia driver is the main cause of your performance problems… it is the same performance issues i was having before i reverted to the older driver… after that… i have ZERO stutters or performance issues in any area of the game including high graphics areas like stations, planets, suns, rings etc.

good luck and maybe i will see you in game :slight_smile: you will find me in game ‘CMDR Enopho’

Eno


#24

Really appreciate the detailed information. I’ll give it a try.

There is something in these settings that I do not quite understand yet. Seems that the piplay multiplier is 3.0 and same time steamVR supersampling is set to multiplier 0.6. You can call me simple, but how does this differ from setting piplay multiplier to 1.75 (3.0*0.6=1.8)?


#25

Sure…

PiPlay versions upto 1.1.92 uses steamvr’s compositor to set the render quality… All piplay versions after that pimax decided to stop using steamvr compositor and made their own.

This means that no matter what setting you use in steamvr it will not impact the render quality in game.

But… Adding additional supersampling in steam will add additional stress on your GPU… So you can pretty much turn it off in steamvr as piplay controls the render quality

Eno


#26

Eno,

When the 8K actually sees the light of day, do you know of a backer running AMD Vega that could duplicate your efforts to try and develop an optimal group of settings? I ask because what I see here is amazing, but since I am ruynning a Vega 56 OC I am not sure how far I can push it safely.

Thanks in advance


#27

Hi @Hessfire

I think the Vega 56 OC is a 8GB AMD card - if im not mistaken?? similar to a Nvidia GTX 1060ti.

I am more of an Nvidia fan, and the Nvidia version of that card can run ED on HIGH settings without too much bother… although you cant use the nvidia control panel to ‘tweak’ your brightness/contrast and gamma settings the rest is pretty straight forward.

as a starting point, I would post in the 4k forums asking the AMD community what is the best AMD driver to use for Pimax 4k - dont always assume latest is greatest! that was my downfall, and i tested 7 or so nvidia drivers before i found the one that was optimal for pimax.

next … forget about steamvr settings! turn everything down to minimum and let piplay do the work.

finally… in Elite Dangerous, DO NOT USE the graphics default VR LOW, VR MEDIUM, VR HIGH, VR ULTRA. I have found that just using LOW, MEDIUM, HIGH and ULTRA actually give you better FPS and a more immersive experience visually even inside the HMD (4k version anyway - i will assume its the same in the 8k… never tried it).

in your case the primary thing to do is find your AMD optimal driver… someone here may have already found it… so ask them on the forums :slight_smile:

also glad you like my posts… as ED is one of my main games i am constantly tweaking to find improvements and will post them here when i find them. I have also just received my new GoPro which can record at 4k at 60fps. .i will be doing a few through the lens videos once i can work out how to mount it in the headset and keep it focused. there are a few members here who have asked me to do them… so i need to try to sort them out.

Eno


Off Topic: Supersampling In-App vs Outside-App
#28

@Enopho
Thanks for the quick reply. I already have my system specs posted up on another thread here, this machine is a BEAST! I built it specifically for Playing ED (both on a 4k monitor ans with Pimax 8k). With the way it is put together (100% M2 PCIe SSD storage, no overclocking, 64Gb Ram, etc.) I currently wait for NOTHING. Add in that - as she sits, I play ED at 3840*2160 Ultra - and I am fairly buzzing with anticipation with pushing the envelope to play ED in VR.

You are right that the Vega 56 in my build is 8Gb, and it is 8Gb of HBM2 memory - with 64Gb more of system Ram behind it. I have been sticking to the newer drivers as the Vega Line is still young enough that optimization is ongoing, but will gladly work with people here to find a configuration for ED that provides an optimal experience for those of us living on the AMD side of the house.

The future is looking very bright indeed…


#29

I’m struggling with consistent performance in Elite Dangerous. I have a 1080ti and set piplay image quality to 3 and settings inside ED to ultra (not vrultra) and made sure all SS outside and inside ED is set to 1. Everything looked great and 60 fps and drops no lower than 50. Next time I start up the game FPS is at low 20’s and I can barely get it up to 30 even if I set everything to low and piplay to 1. Multiple restarts and still not able to improve quality or fps.

When this happens I usually go back to tweaking the settings without any significant difference until suddenly I’ll be able to set everything to max again and all is good.

I’m so confused as I don’t see any obvious reason why this happens. As far as I can see there shouldn’t be any background processes affecting this. Stranger still when the FPS and quality in ED is good I normally have multiple programs running in the background.

Any ideas?


#30

i would be looking for anything outside in backgroud processes that are using your processing power.

things like, windows updates, antivirus updates or scanning, windows search indexing, steam is updating games, things like that.

personally, if you do get it running smooth and the next time you start your pc it is not running smooth, then something else outside of game is affecting it.

assuming your in win10.
check if windows updates are updating… click start> then the cog for settings>then windows update> see if there are updates happening.
next open your antivirus and see if its doing an on boot scan or is applying updates
next open task manager (right click task bar and choose task manager) click DETAILS in the top tab, personally… i disable my Search completely. if you want to just look for SearchUI and SearchIndexer.exe and right click it and set to disabled. these search features basically index your file locations for dynamic searching
When launching steam check your steam downloads and see if anything is currently downloading, also if you have other gaming portals… like Origin, Uplay etc check them too in case they are also downloading.

I also know that the latest nvidia drivers cause micro stutters in games, so let me know what nvidia drivers your on and what piplay version your using.

let me know if that helps.

Eno


#31

Thanks very much for your answer. I’ve previously been monitoring processes without seeing any significant use anywhere else.

I double checked again today though, still seeing sub 20 FPS at ultra settings and below 55 with everything at low in ED. All SS is set to 1. Again I couldn’t see any other processes using significant resources and I also tried killing all tasks which weren’t critical, including antivirus. This made no difference whatsoever. Also no updates or downloads going on while checking performance in ED.

I’m using the latest Nvidia drivers, which I also was using a few days ago when ED ran smooth at 60 fps. I’m using piplay 3.0.0.71.

Out of curiosity have you by chance tried the demo showtime in piplay? What fps do you get there with image setting 1 and 3, most notably at the Unreal logo? I get 60 at setting 1 while I’ll only get 10-15fps at 3.

I’m going to investigate a bit more and post if anything changes.


#32

That is very weird… can you post me your full PC specs please? also have you changed anything in steamvr settings? if you can screenshot them as well. I also had some issues using Piplay 3 and the latest nvidia drivers, so i now use the latest version of 2.x (just before 3.0 was released) and i use nvidia drivers that are older… 384.94-desktop-win10-64bit-international-whql (assuming you have win10 64bit they are older drivers from July last year but are the best ones for Pimax… no micro stutters and super smooth!!)

My pc specs are above in the Mar 26 post.

here is a video of me actually using the 4k and recording in 4k as well… in all the high graphics areas of ED using VR Ultra graphics… https://www.youtube.com/watch?v=BlX4bNDIIFs

to be fair i actually find the ULTRA settings in ED to be even smoother, so i don’t think frontier have ironed out the VR Ultra settings properly but in that video the frame rate was steady at 60 all the time.

regarding the multiple programs… i can still get 60fps even with these open programs.

DXTory - for video capture
Voice Attack - for Voice Control
Google Chrome - with 3 pages open (Discord, ED Database, Google)
Sometimes i have Teamspeak open as well.

with recording i record in 1080p at 60fps if using the pimax, although i have been known to record 4k at 60 and it still does not drop.

when setting your display graphics in ED, change the resolution to 1920x1080 (windowed) not full screen or borderless


#33

Sorry for slow reply. Specs are as followed:

I changed piplay back to 2.0.7.54.

I can only get reasonable steady fps 50-60 now with settings on ultra (not vrultra) and all SS set to 1 or 100%. In piplay setting the slider to 2 heavily impacts fps.

At the moment the best I seem to be getting away with is Ultra settings in ED with hmd 1.25 inside ED. DOn’t get me wrong, this still looks pretty good I just expected to get a bit more out of the 1080ti.


#34

I can only post one picture per post so here are steam settings:

Sliders in video and program are set to 100% and manual.


#35

What Nvidia drivers are you using? Read my post above and try the Nvidia drivers I mentioned, they work better with the pimax

Eno


#36

I’m using the newest drivers. I’ll try and roll back to earlier ones and see if that makes a difference.


#37

I know for a fact that it does… The newer ones seem to have a micro stutter effect and my fps drops because of it.

Let me know how you go.

Eno


#38

Tried using 384.94 nvidia drivers without any improvement. Exact same fps with exact same settings. Fully removed drivers before install.

Getting exactly the same fps as with the newest driver. With SS in steam at 150% and settings in ED on ultra seems to be the best I can get. 45 fps inside station hangar, higher everywhere else.


#39

above you said that you are using SS in steamvr on 1.0 - the last post says you are using 1.5? can you please set steamvr to the lowest (i think its 0.6?) and then increase piplays render slider to 3.0, tell me if that works.

dont forget that any version of piplay higher than 2.0 does not use steamvrs compositor so adding anything to it just increases GPU resources but does not add to game rendering.


#40

I was messing with the new Kraite mkii ship yesterday since the latest patch, I turned off my 4k and went to 3 screens and ran in ultra with vertical sync on and everythning on high/ultra settings whichever was the highest and in open space was tipping 220fps, in stations and at haz res sites was topping 170-190fps. Even planet side I am getting 150-180fps!

I am going to have to find a way of working out what the 4k is really doing (fps) when in ED game. Anyone ran any fps benchmarks specifically in ED. I just want to be sure that the 60fps never dips when in vr? Thanks Eno