Additional testing with Elite Dangerous


#41

Awesome… Go Go For Elite

Thanks eno


#42

Hello again!

Thanks for your input so far Enopho. Anyway after some time away (and improving PC thermals) I’ve been able to jump back into ED VR for some more testing. So far I’ve found some fairly good settings that seem to work for me. I won’t go too much into details on settings ingame but all terrain and shadow settings and sliders are at ultra/max while some other things have been turned off. SS and HMI are both set to 1.0.

I just changed from piplay version 2.X.X to the latest 3.X.X. I’m also using the latest nvidia drivers. Personally I don’t have and issue/don’t notice the ghosting and microstutters. Don’t get me wrong, there is ghosting but not to the point that it bothers me. I did however notice that with the latest piplay, ED/piplay do seem to be able to utilize my GPU more. I’m seeing usage up to 95% compared to rarely past 70% before. I have less FPS issues/drops now even with higher settings.

Piplay slider is set to 3. Now comes the interesting part. In steam VR settings (regular version, no BETA) I’ve set the sliders to 20% in programs tab and 160%-170%SS under video tab. This seems to be the sweet spot for me at which I’m also at a constant 58-60FPS, even with OVRdrop running.

When both sliders are set to minimum, 20%, the quality inside ED is terrible. Eventhough Piplay has its own rendering, steam compositor definitely has an impact on quality aswell. At least for me.

Obviously I’m stacking SS here but it seems like the 1080Ti can handle way more than Piplay slider at 3 and steamVR at minimum. An even higher quality might be attainable if piplay could be set to higher than 3.

The main difference I see with higher versus lower SS settings is jagged edges. I’ve taken some pictures through the lenses where you just about can see the difference. Needless to say pictures through the lenses aren’t optimal so don’t look too much at the overall quality, it looks better than in the pictures. The examples are with steamVR set to 400% and 100%. Obviously at 400% FPS is terrible, 30FPS, but this is merely to illustrate.


#43

I’ll be playing with settings a bit more to see if I can squeeze out a bit more. For now 160%-170% steamVR SS together with piplay slider 3 gives me the best quality while staying at 60FPS.


#44

i do love to tinker!! :slight_smile: i may have to try the latest piplay again and see how that goes.

thanks for the info,the images you provided look good… so its worth a test. will have a go in the next few days, just helping someone else out with ED at the moment via private chat.

Eno


#45

Omg I want so bad to go back to my FAS ship, haven’t played ED for quite long lol

Guys not sure If you have posted it before, I hope to not ask it twice, what settings are you using in the Nvidia control panel for VR in Elite? I’m more interested in " texture quality - High quality vs Quality(default)" and also in all the texture filtering optimizations (clamp, allowed, trilinear filtering, sample optimization etc ). I have a gtx 1080ti, and I’ve noticed in Elite using High quality (filters are auto-disabled) all the jaggies disappear, is way more clear but lose the 60fps rock solid while on planets, it drops 2 to 4/5 fps. I know is not much but it’s noticeable.
For VR games in general is better to leave the overall texture quality to Quality (default) ?
Thank you a lot, byezzz


#46

Not all togheter guys! I can’t read all that replies in time! lol! Kidding… By the way, I’m back to Elite and founda bad surprise: the game stuttering like hell with 2.X drivers and last Nvidia drivers. I tried using same settings as Callicantzaro but fps and visual quality werent good. I had to push up the HDM quality option to at least 1.5 (piplay slider on 3). I have a Strix 1080ti and i7 2600 4.2Ghz, 16GB ram cl7 and SSDs.
Before the SteamVR update on auto-supersampling everything were fine. I tried so many video settings I’ve got bored and put the old one piplay driver 1.1.92. The increase of quality is too much, game is perfect, super smooth and using 2K support in Piplay, Steam Video slider to 150% and Steam Elite profile at 100%…but horrible drift…
Is there any change to do a remake of 1.1.92 driver with the giro calibration or a mod? I bet this will make a lot Pimax users happy and we could wait without trouble any new real fix for IPD, ghosting etc… I prefere accuracy(focus, visuals) and smoothness (no drift/stutter) compared to high resolutions or multi-Platform integration(as Oculus). That driver is made 200% real for Steam. Last drivers, to me, aren’t good as the oldest ones using Steam render. Focus on lenses is also different in the 1.1.92 I can see a lot more clarity far from center leaving IPD at default. If anyone could provide me a link where to download the 3X I’ll thank you (auto update failed) and I can do another test, but I’me sure nothing is like 1.1.92 in visual quality. Please If can add the giro calibration in the old one this will be a huge step in the good way for your supporters/customers.
Take care you all, byezzz


#47

My setting in ED have not changed much from the settings above apart from i play in ULTRA quality in ED Game settings and not VR ULTRA, as i feel the VR ULTRA is not quite as stable as the ULTRA settings, sometimes the controls at your hands go low res and the same on planet surfaces when in VR ULTRA, but do not do this when in ULTRA.

the piplay i use is 3.0.0.85 right now as i had some bad experiences using the latest pitools.

For ED in steamvr i use 100% SS. and i am using the latest nvidia drivers.

for my nvidia control panel the only settings i change are
Power mgmt mode : Max Performance
Vertical sync : fast
Virtual reality pre rendered frames : 3

the rest is standard.

Eno


#48

Thanks for sharing Eno. Not sure if worth to go to 3.x or to wait for other important fix. Piplay 1.1.92 is really good, just the drift…:unamused: Maybe I’ll have a try in the week end. Download links for 3.x versions? thank you

Zan


#49

no problem - happy to help

Eno


#50

I’v tried with 3.0.0.71 and compositor were stuck, Idid the update to 3.0.0.85 and managed to make it work.
I have now piplay render 3, Steamvr Video auto (26%) and Elite profile render at 50%.
In game settings are almost all maxed except shadow(medium) and AO-DOF (off). I’m having most time 60 fps and a little micro-stutter. I think 1.1.92 still more smooth at 2K.
I’ll stick a bit with this last one.
Do you know what IPD I have to set having 66.7 real one? thank you
byez


#51

my RL IPD is 68.3 and i set the pimax 4k to 59.2, so i suspect yours will be lower than that… cant be more precise tho.


#52

I’ve set IPD 64.0 as it seems more comfy. I’ve noticed as you lower the IPD you will see the black borders in the center of the eyes cause visual will focus more on the space (plastic) between lenses.
Still blurry watching around the center of the lenses


#53

Hi guys, I’ve done other tests, and now I’m using 3.0.0.85 Piplay. The SteamVR FPS software helped on getting rid of the micro stutter tweaking rendering on piplay and steam, so game is 60 fps almost everywhere. I just wonder how you get more fps using 3x slider render on piplay…I’m using 1.5x render piplay, 100% Video setting and 30% Elite Dangerous profile. Settings ingame are almost everything Ultra with a gtx 1080Ti. I get 58/60Fps on land and stations, during combat, nomatter how many ships, everything is fine.
I would like to ask to Eno if you can see differences between ULTRA and VR ULTRA? could be these options making game slow and stuck at 58/60fps? I would like to use Piplay 3x but fps drops to 40-50 causing stuttering.
I’ve tried the brightness 4 tweak on Elite. While everything shines I think is too much hurting eyes cause of bleeding whites. Blacks are also on the grey side. Brightness 3 is more relaxing and your eyes will thank you for that.
Thank you guys, still waiting an improvement in ghosting :stuck_out_tongue: don’t forget us!

PS. after some tries IPD setting now is good at 61.6 (real is 66.7)


#54

Hi Zan,

I did notice a difference between in game Ultra and VR Ultra, and in fact VR ultra game some issues with rendering the hands and controllers when looking down when moving into high graphical areas, seems to struggle holding that resolution and so drops the quality to very very low! But using Ultra I do not get that drop.
It has been reported as a bug with Frontier but no fix as of yet, and to be honest I suspect that quality in textures might be because game sees that HMD is running at 60fps, and assumes that if a Vive or Oculus that it is under performing and reduces the textures. This obviously is not the case on the pimax 4k so using the Ultra fixes that for me.

When I am home tonight I will share my full settings for you.
Nvidia drivers, piplay drivers, steamvr settings and in game settings.

Eno


#55

@Zan

As promised here are my settings playing Elite Dangerous on the Pimax 4k.

Nvidia drivers:
image

PC Spec: i dont have a super fast processor, as the 4k is not as demanding as the 5k+ or 8k
image
image
running on a ASUSTeK COMPUTER INC. Z97M-PLUS Rev X.0x Motherboard

Piplay:

piplay is installed on an 860EVO SSD drive

SteamVR
image
image

In Game Settings



As i use game quality as ULTRA, and nothing in the game graphics options have been changed - if it did it would show as CUSTOM rather than ULTRA

I made a very basic video of the game running this evening with these settings, only a few mins long so you see it in ultra gameplay, sorry about the Mic sounds… was sitting too close to the hotas!
uploading it to youtube right now. will post the link here:

Hope you get yours working well??

Eno


#56

@Enopho

…so thankful Eno! awesome help here, you did too much lol, thank you!
I’ll try today as me back to home. I just wanted to ask some things I’ve noticed in your SteamVR and game settings:

SteamVR

  • Weren’t those settings: Async Repro and Always On Repro to “off” cause Pimax own render?
  • Advanced supersample filtering enable/disable the slider in the Video–> SS option? I had always that enable and set manually to 100% as suggested in some previous posts

Game settings:

  • Have you turned FOV slider to the lowest manually or it’s made by ULTRA setting profile? I have mine set to default, does it improve visuals and VR immersion reducing it?
  • Gamma value is tuned or default in your screenshots?

Last (maybe important question). I have also a 1080p TV hooked to my GPU with hdmi. Pc is hooked with 1080p DVI monitor. As I power on Pimax 4K , displays go to extend mode also if my TV is off/stand by. It’s better to unplug my TV so I have only one screen and Pimax working on my GPU? Could this cause also micro stuttering?

Thank you again Eno, I’ll save this post in my bookmarks, this meant much to me so can enjoy Elite at best!

PS: Do you have eyes strain using lvl 4 brigthness?
(In game I’m CMDR Zanzetsu, yesterday I’ve bought a Krait mk2 and A rated it (no engineers) and I love it so much! Can’t wait to test your settings today and see it more clear, I’ll let you know!)

Have a good day all of you

Zan


#57
  • Weren’t those settings: Async Repro and Always On Repro to “off” cause Pimax own render?
    From what we know from Pimax, and we are talking 4k here not 5k+ and 8k no matter what you have in steam according to them, it has no effect in the piplay 2.0x and above versions. i have it on there as i also have a oculus as well and my son uses that sometimes.

  • Advanced supersample filtering enable/disable the slider in the Video–> SS option? I had always that enable and set manually to 100% as suggested in some previous posts
    that particular slider in that Steamvr option is for ALL Programs. if thats what you want then its fine, but it you use the slider in applications, then you can set it on an application level rather that 1 size fits all.

Something to note though… when setting the application slider the resolution shown in Steam when on 100% is this: - see the highlighted resolution
image

but when it is set to all applications to 100% the resolution looks like this:
image
so using the application slider it is trying to push out 2x the resolution !! that would cause issues!

  • Have you turned FOV slider to the lowest manually or it’s made by ULTRA setting profile? I have mine set to default, does it improve visuals and VR immersion reducing it?
    I believe that the FOV slider is ONLY for monitors, and won’t affect HMD’s so lowering it will free up a bit of resources.

  • Gamma value is tuned or default in your screenshots?
    Honestly i can’t remember, i did a lot of tweaking to get the game running the way i liked it, in fact the HUD brightness is set to the lowest setting! and the gamma is somewhere in the middle, but the piplay brightness on 4 then brings all the colours our better for me.

  • I have also a 1080p TV hooked to my GPU with hdmi. Pc is hooked with 1080p DVI monitor…
    so your TV which is connected with HDMI (which can send data and audio) is connected and displaying the game? and your monitor is also connected with a DVI-A? and displaying the game? i’m guessing (1080p at 60htz) yes they would impact on performance. If you can do it, switch the monitor to a DP port (does not use GPU channel) and unplug the TV HDMI when in VR for IO cable types and what they do, have a look here : https://www.gamingscan.com/hdmi-vs-displayport-vs-dvi-vs-vga/

Eno


#58

Thanks gain Eno

I play on my gaming monitor Benq RL2455hm using DVI-D (Dual link to DVI-D GPU port). TV is most of time in stand-by mode, end when on, is not using HDMI but normal TV channels. Since Pimax 4K is sharing the HDMI channel, could be possible to have a performance hit…I’ve never tought about it lol. I’ll try to find a DP to HDMI since my TV doesn’t have DP ports.

So if I uncheck “Advanced supersample filtering” the “Video” slider will not work, is it correct?

Thank you again, waiting to test it!

Zan


#59

if you mean, unticking the application resolution ‘Manual Overide’ option in VIDEO when in steamvr settings then yes… unticking it will disable it for all applications. you can then use the ‘Applications’ tab in steamvr and set the SS slider ‘per application’


#60

just spotted this in your last comment, that monitor is a 144hz gaming monitor, but your 4K maxes out at 60hz, so in Elite Dangerous in the in game settings set the REFRESH RATE LIMIT to 60hz when using the HMD as well. I have mine off, as i use 3x24inch monitors (infinity) and they are capped at 60hz. so i don’t need to set my limit.

if you waiting for the 8k or 5k+ then when they arrive change the in game hz limit to those headsets max refresh… 90hz for the 5k+ and 80hz for the 8k

Eno