Aerofly FS2 not showing up in 5k+ HMD

suggestions

#1

Hi All,
New to the forum and not that tech savvy! I have a 5k+ HMD running on a Ryzen 7 1800, with an ASUS 1080ti and 32GB DDR4 Ram. Aerofly FS2 will not show up in the headset no matter what I do. I’m currently uninstalling and re downloading FS2 to see if that will sort things out (it’s taking a while with 30+GB in total inc DLC!). I load the programme from steam, starting it via steam VR option (I have a rift, so the option to start in oculus VR mode is there too, but I tried that out of interest and that does nothing useful either). I can hear the aircraft sounds through the DAS headset connected to the Pimax, and the FS2 home/options screen is on the monitor (all VR enabled) but nothing in the HMD. Has anybody else come across this problem/have any solutions?
Sorry for the ramble, just trying to put across as much info as possible.


#2

Welcome to the forum.

I found @glassy99 had this problem. From reading up he fixed it by switching to Vulkan render.


#3

Thanks Helio, I’ll give that a go and report back.


#4

Many thanks for your suggestion Helio. The app did show up in the headset using the Vulken render but it was a bit like ‘land of the giants’ with me being one of the tiny folk in the cockpit looking up at enormous rudder pedals and a ginormous flight dashboard about 3 stories above me (very clear dials at about a metre wide tho :+1::smiley: lol). Guess I’m missing something obvious. Once again thanks for your help, really appreciated, will fiddle some more and see if I can sort it.


#5

Your welcome. But @glassy99 deserves the credit. Hopefully he gets this poke as he would likely be able to help you further with settings. :beers::sunglasses::+1::sparkles:


#6

Hmm… I didn’t have that issue with the scaling. Maybe you can look into the graphics settings and see if there is anything related to world scale? I kind of remember there is.


#7

Many thanks for responding to Helio’s previous post (and to Helios for posting it!). Yes, I’m sure there must be something I can do in the settings somewhere. I will have another go tonight and if I find the solution I will post back here. Thanks again (both of you) :slightly_smiling_face: @Heliosurge


#8

Well I finally managed to get some time last night to have another look at this and you were right, world scaling was an issue and for some reason was set too low in the graphics settings! You have to use the Vulkan render, and I had to keep booting and rebooting the various bits of software (PiTools, SteamVR, FS2 in Steam itself) turning on and off parallel projections … but eventually, four glasses of wine and three quarters of a lamb tika madras later (well it was Saturday night :stuck_out_tongue:) IT WORKED!! So much appreciation to you and Helio for taking the time to help. Thanks guys @Heliosurge