Another 8k Headset "Not Tracked" Thread



I would just like to report that this issue has now been resolved
and my headset is tracking.

Thanks to @Sean.Huang and a Teamviewer session.



Great! :grinning: Any feedback on what you think they did that helped resolve your problem?


and how did he fix it? what was the cause?


That is great that a remote session managed to fix it after seemingly trying everything. Nice one @Sean.Huang, things like that are reassuring.

As others have said, what fixed it? That would be very helpful to others that end up in the same situation so Sean does not have to waste time repeating himself.



You are welcome!

Not tracking is due to incomplete calibration, but this is only for individual cases which never happen before your case.

We have added some solutions to avoid recurrence.

For other not tracking case, if it happen, you could try to delete the files in the pitool folder of runtime\config\lighthouse, then restart the Piservicelauncher in task manager to recover the tracking.


Just for my understanding, wouldn’t that give the same result as deleting the config file and then reboot pc (which automatically restarts the services) ?


reboot pc -> noob method
restart service -> geek method



Exactly what I’d think. However @sweviver claims that rebooting didn’t work, but restarting services did. Just trying to understand why, because it makes no sense.

Hopefully @Sean.Huang can explain.


There is a config file?
Is that different to deleting files in \config\lighthouse\

Edit: Restarting the computer could force windows to terminate a service that is stuck which may leave it in a strange or suspended state whereas restarting a service would allow it to clean up properly without a timeout limit.


Yeah the files in that dir.

But if the service is stuck, it would also terminate incorrectly from the task manager.


The config files are located under the folder C:\Users\ * user *\AppData\Local\Pimax\runtime\config\lighthouse


Haha exactly :joy:
And of course I started with the noob method!


Yes if stuck, but if time limited then not necessarily. When it gets a system event that the machine is shutting down it has tiny window to cleanup and stop the service before windows will just kill the process if it takes too long. But if it receives a manual service restart it can run through whatever it runs through e.g. committing changes to a config, closing file locks and then restart without worry of being terminated in the middle of that.

Also, code can be different depending the system event for a sleep / kill / terminate / restart etc. Maybe this has been updated now so a shutdown/restarting event runs the same code that a service restarts does.


It would be nice if @Sean.Huang could explain. Once we understand it we can help others here on the forum better, with similar problems.


@sjefdeklerk or someone, maybe make a small app or command to stop the service, delete the folder, start the service, to “fix” the tracking problem :thinking::wink:


Ran into this same issue (well, multiple ones, really). What I’ve figured out that isn’t well documented is that the first thing to note when running a new Pimax with Vive lighthouses and controllers is when starting the PiTool app is that you’re going to want to hit the “Pair Controller” button first thing, despite the fact that it’s the bottom button. Turn on a controller and that will pair it and probably switch at least one of the basestation icons to being “Ready”. After you’ve paired both controllers if one of the base stations does not say “Ready” you won’t be able to progress in “Room Setup”, you’ll get the “not tracking” error so prominently mentioned in this thread. I found the fix for this to be to move the headset closer to and away from each of the trackers until it switches to “Ready”. Then you should be good to go.

I will note that I did do the directory deletion mentioned above but most likely that wasn’t needed in this case, at a guess.



Latest Pitool .95 have fixed this tracking issue, and you do not need to delete the folder and …


@Sean.Huang Support requested (SUPEN-805)

EDIT: I came home from work today and the problem magically solved itself. I hadn’t even rebooted the PC.

Unfortunately, I’m having the “not tracked” problem with .95 and our 5K+ BE. I have one new Lighthouse running about 2m directly in front of my driver’s seat. I’ve tried every solution I can find in this forum without success. I sent you an email. I believe a TeamViewer session may be necessary to resolve.

Thanks and best regards,
Todd Bettenhausen
SimXperience Racing Simulators