Assetto Corsa Optimization Thread

fix-guide

#1

Hello Fellow Simracers,

I’m hoping we can use this thread as a baseline for tuning AC for the 5k+ (and 8k). In my limited testing last night on Spa with a full GT3 grid, I observed the following:

Setup: 9900k @5ghz. 2080ti, 16gb CL16 3600mhz with manually tweaked timings. SSD.

Initial feedback:

  • No lighthouses. Using built in tracking
  • PiTools at 1
  • Steam SS @ 130%
  • Rate set to 72hz
  • Disabling ALL PiTools features gave me the best performance and it hovered around 72fps but with some drops into the 60’s during a lot of action but it was not stuttering or jarring. The gameplay remained smooth
  • Enabling ALL tools gave me 30fps with a lot of drift and shimmering

Over the next day or so I’ll share my video settings so they can be referenced. I plan to do more 1 by 1 feature testing over the next few days to determine if any of the PiTools features actually provide a boost in this game or if we’re better off disabling it all.

Please feel free to share your feedback. My goal is to update the main post with a “master recommendations guide” based one everyone’s testing and feedback.


#2

I don’t have lightboxes but there seems to be a fair amount of drift in the headset when sitting down and driving to where I sometimes have to recenter once a lap.

Is there a “best practices” for calibration without external sensors?


#3

I have a 7700k at 4.9ghz, 1080TI. I am generally going for med FOV and Pitool at 1, steam SS at 75%. In game I am running SOL and Shaders, so that is a big performance hit but is essential for AC these days. I have a few things turned off in shaders such as the dynamic mirrors, deformable tires etc. I run 4xAA or 2X AA dependent on car and track combination and PP detail is low on all settings. Track detail max, shadows reasonably high, reflextions one face + second lowest detail in mirrors. Generally hovering between 70-90 depending on car and track, Smoothing is off as I don’t like reality bending around my mirrors and pillars. I actually find the Pimax pretty tolerable even when it sits at around 70FPS.


#4

Thanks for that input. Yes, I find the drop in FPS on the Pimax quite tolerable compared to the Rift and Odyssey+

Agreed on the smoothing. It produces strange effects at the edges. Are you running “hidden mask” option? Have you tried to see if that impacts anything?

Also, what brightness setting in the PiTools are you using for best image quality?


#5

I generally have found that with SOL and racing at night i need the lenses further off my eyes to be comfortable otherwise they feel ‘hazy’ but in terms of brightness i generally just go with medium. I haven’t had much issue with AC but have just left hidden mask on. RF2 with parallel projections is a bit hard to get frames there but do prefer it over AC so play it more.


#6

Hey Robert can you post the settings now? I have almost the same specs as you (CPU 8700k at 3.7 mghz) and steamvr SS at 100% but still get not great performance. What did you disable in pitools?


#7

Hi, I disabled Parallel Projection, set fov to normal, enabled hidden mask and disabled FFR. 72hz. Pitools 1.0 and steam ss @ 130%

I can take a screen shot of content manager settings if you think that will help.


#8

Short update: I started running large fov as of last night with the same settings. I can’t notice any drop in performance and there’s a notable jump.

If anything I’d say the large fov is unrealistic as you’d not have that much peripheral vision with a race helmet on for those who have done tracking. But this isn’t real life so I’ll be running the large FOV form here on!

Anyone here playing ACC? I can’t even get it to launch. I select “Start in steamVR” it flashes a screen and then just disappears. Anyone else having this issue?


#9

Thanks for the post. Good to hear from someone running and enjoying large fov with a racing sim.


#10

Hi OP. Have you noticed or found a way of solving the aliasing of white lines, fences, shadows etc in the mid/far view distance? It’s quite distracting and the in game MSAA doesn’t seem to help. I’m running 1.0 in pitool and 100% steamVR. Supersampling doesn’t seem to help all that much and is too demanding when racing at night. I use the ShaderMod and Sol.


#11

MSAA isn’t “real” antialiasing and has never met my AA expectations.

I know little about AC, but Elite Dangerous has huge issues due to “deferred rendering” which precludes using real AA. Based on my experimentation, ED really needs 4x SS (16 rendered pixels -> 1 screen pixel) to look good. That yields a single-digit framerate on my 2D monitor with my overclocked RTX 2080.

Anyway, I don’t think there’s much that can be done. Try to ignore it for now and in 5+ years, GPUs will be powerful enough to handle large SS values and the problem will be solved.


#12

Try bumping up the Pitool rendering. I was trying to adjust SteamVR SS/in game SS in PC2(should apply here?), and didn’t notice a drastic change until I put Pitool to 1.5.


#13

Ok thanks - I use SMAA in Elite Dangerous and this for me makes the image much more natural with less shimmering of hard edged objects in the mid/far distance. It doesn’t seem Assetto Corsa has this option and the SMAA or CMAA injector via the shadermod doesnt seem to work in VR - or at least I cant see any visual difference.[

Cheers as well g-coded, I will try the below tonight and hopefully that’ll help!


#14

I don’t seem to have that issue. I’m running 4x AA with PiRender @ 1.0 and SteamSS @ 130% with the large fov and 72hz. World details are maximum. I can screenshot the rest of my settings tomorrow if you’d like to copy them. System = 9900k@5ghz and 2080ti

I don’t run shader mod and sol. I found it be inconsistent in performance so i can’t comment if your issues are specific to that.

Maybe disable all such mods and see if the issues are still present. I found the picture quality on the Pimax running AC to be amazing.


#15

Yes please if you could screenshot your settings when you get chance that’d be much appreciated. Ill try a clean install of AC and see if it clears up.

Thanks!


#16

https://imgur.com/QyyEZDY

Here you go!


#17

Cheers Rob, looks like I’ve got similar settings from what I can make out. I think I’ve solved my problem this evening now, I changed the following in my Nvidia control panel: Texture filtering quality: High Quality, Negative LOD bias: Clamp and MFAA: on. Not sure which of these made the biggest improvement but shimmering is all but gone in AC and it looks much cleaner. It’s helped reduce shimmering in Project cars 2 and on the buildings in DCS too. Very pleased as the shimmering was quite garish and distracting! I also clean installed steamVR but don’t think that changed anything.


#18

I’ve always run Texture filtering on high quality. I’ll try out the LOD bias and MFAA and report back any changes I notice.

Any particular tracks that highlight the shimmering more than others?


#19

I tried the negative LOD bias and setting it to -1 in content manager but it’s giving me a ton of eye strain. I don’t know why that would be the case. Any suggestions?


#20

Hi Rob, yeah I noticed this as well this weekend. Setting it to 0 is best for visuals and eye strain. This setting at -1 was making the aliasing and shimmering much worse for me.

I’m happy now the image is much cleaner and more natural. After a bit more testing at the weekend I found the things that made the most difference in the end to significantly lessen shimmering and give a more natural look were: MFAA=ON (seemed to help with text and HUD) Texture Filtering Quality=High Quality in the Nvidia Control Panel and setting Negative LOD Bias=0 in Assetto Corsa content manager.

I think if negative LOD bias is used the distant textures are too detailed and this massively worsens the shimmering effect without any TAA. This may increase eye strain too but not sure.