Bad graphics while playing Dirt 2.0

issue

#1

Need some help here…

In game I can’t read anything ( in both cinema mode and VR mode ), can’t read the lap times, information tooltips like release handbrake and other texts and it also feels like my graphics are all on medium while they are mostly on ultra and on high.

Other game I have no issues, Beat Saber and Slightly Heroes both look great for example

My SteamVR Settings:

  1. Dirt 2.0 Application Resolution: I put this at 100%
  2. General Application Resolution: This was at 68%, I put it on 100% which Improved my graphics a bit
  3. It says my headset is running at 80hz, but how can I check this? Also I’ve read that people are playing at 90hz? how?

Should I disable anti-aliasing or lower any other settings ingame? Increase the resolution for dirt 2.0 or the general resolution? I really have no clue… I don’t think it’s my Interpupillary Distance?


#2

I had the same issue. I needed to change some settings and the menu text was unreadable.

My solution was to run the game in non-VR mode. Unfortunately, there’s no game option to do that. You can disable oculus support in a config file, but that’s ignored for SteamVR HMDs. After spending a couple of hours looking for a solution, I found one on my own:

Uninstall SteamVR, then run the game and change the settings.

Note that uninstalling SteamVR will apparently uninstall all of your VR apps. That’s what the warning message said. I’m not sure it actually did uninstall any other apps. After you’re done changing settings, reinstall SteamVR. What a PITA!

Also, running fpsVR will cause Dirt Rally 2 to crash on startup, so remember to turn it off before starting the game.


#3

Can you post your system specs & which Pimax headset you received?


#4

You can create a backup of your Steam Library folder. But unlikely it will delete your vr games but can’t say for sure.

I have backed up(copied game dir) & used this to avoid having to download & install on another pc.


#5

Steam pops up a warning saying that your VR games will be deleted. I’m not sure, but it didn’t look like it actually did.

It’s not a big issue for me; I have a fat pipe to the internet, so downloads generally aren’t an issue, except for a few massive games, like Dirt Rally 2. Even then, the limit is due to the Steam servers and not my connection.


#6

X:\Users\YourUserName\Documents\My Games\DiRT Rally 2.0\hardwaresettings

Edit/Save hardware_settings_config.xml w/ Text Editor.

Find:

<vr enabled="true" eyeDistanceMultiplier="1.000000" lockedOrientation="false">

Change true to false


#7

Thanks for the great tip! :+1:


#8

I have installed games on an external drive to use between pcs. Generally when steam starts it audits your steam library folder & adds games.


#9

If you launch the game without Steamvr running in theory as with other gamea should give option to run normal.

With Steamvr running on Desktop steam Launcher for example Everspace can choose 3 options to launch.

Normal
VR Steam Headset
VR Oculus Headset


#10

No, it starts SteamVR. I tried various things like stopping the Pimax service and turning the HMD off, but that only triggered various startup error popups and the game never started up.

It was aggravating, since the only reason I was doing this in the first place is because the menu text was too small to read.


#11

That’s weird but guess the game setup.


#12

Yeah, if you can play in VR, it assumes that you’d never want play on a flat screen. I found a fair number of complaints about it.

I think the tiny letters might be due to the wide FOV. I’ll try Small instead of Normal. It might be more legible on a 5K (or better still an 8KX).


#13

I was able to make the tiny letters a bit more legible. I reduced the FOV to Small and had PiTool quality at 2, SteamVR on auto, and app at 150%. The resulting res was 3068x2992. The game was quite playable on my 2080, but it seemed like the framerate was only around 60 fps. FpsVR causes the game to crash, so I can’t determine the actual framerate.

Unfortunately, leaning forward doesn’t make the text any larger (it’s some sort of overlay). There are zoom buttons, but again, it doesn’t enlarge the text. In Elite D, leaning forward is helpful, I wish that was an option with DR2.

As for the hot headset issue, I cranked the A/C before I started playing, which did help. I don’t think I could play for more than 30 min or so, because the headset still gets too warm for comfort.

On the plus side, the graphics quality while driving in the rain is impressive. It’s a pretty game, with a few serious flaws (small text and poor gamepad support). I actually own a steering wheel, pedals, and a gear shift, but I don’t really have place to set them up in my office. I’ll probably go back to playing Assetto Corsa, which has far superior gamepad setup (tilt to turn, not a thumbstick).


#14

Thanks for the replies guys, I’ll test these options today :slight_smile:

Pimax 8K with 1080ti btw

neal, how do you get to 3068x2992? at 128% I get 3068x3152 and at 150% I get 3324x3412 that’s with unticked adjusted resolution in video settings on steamVR


#15

I’m not entirely sure; I just read the numbers in SteamVR Settings.

The difference might be because I’m using Low FOV, have Parallel Projections enabled, or perhaps due to my Vertical Offset (in PiTool), which is currently +5 and +8. (I’ve been tweaking it, because apparently my eyes don’t line up.) It’s weird, because now I notice it in real life and it never bothered me before. The +values might be due to my adjustment of the HMD to be slightly tilted upwards, to avoid pressure on my nose and cheeks.


#16

My eyes don’t seem to align when I look to the left or to the right and I notice no difference between 60mm and 68mm ipd so it’s hard to adjust xD

As for Dirt 2.0, the text seems to be some kind of overlay with no way of sharpening it…
The pitool render quality at 2 boosts my resolution to 6000 per eye ( just doubles the values in steamVR ) sso I need to adjust either that or the steamVR value and not both )


#17

Probably entirely unrelated, but I know that in Skyrim you have a .ini setting that determines the bitmap texture size that 2D UIs (Flash stuff - Scaleform, I guess - everybody seem to bog down their games with that muck…) are rendered to (pretty much mandatory IMHO - the default is very unattractively blocky).


#18

Can you not disable Steam Client Service, in windows Services ?


#19

8K maximum refresh rate is 80Hz. Among Pimax users, only 5K users can play at 90Hz.


#20

Good to know, thanks :slight_smile: