Beat Saber Update 3/14/2019 Parallel Projections still required to be enabled

review
events

#1

The odd single-eye particle graphics glitch without parallel projections enabled still exists. In fact, it’s WORSE than before! Just FYI. Def going to wait to buy that new DLC (may never buy it) if they can’t fix issues.


#2

Have you tried @brian91292’s mod it fixed some Beatsaber issues on pimax.


#3

The mod works, but it makes the game look like the lights were turned off. I reverted back to normal immediately.


#4

Looks like Pimax has some work to do.

Maybe @yanfeng might know of a fix or something.


#5

The mod currently doesn’t work, I’m looking into fixing it but as @cazman321 mentioned the issue has only gotten worse. I still don’t think it’s an issue on Pimax’s end, though.


split this topic #6

6 posts were split to a new topic: Pimax Ease of Use


#9

So the beat saber update also broke the ‘mod saber’ hack, allowing to download and play custom songs, which I loved!

Anyone know if there’s a fix for this??


#10

Of course it did, the whole song list UI changed. Wait a few days and the mods will be updated.


#11

By the way @TheSwanCollective, custom songs are back now. You can get the updated song loader from the modsaber installer now.

The ingame downloader has not been updated yet.


#12

@brian91292 Awesome news! Thanks!


#13

Current status of mods updated to run in version 0.13.0:


#14

All of the necessary mods are updated and confirmed running in Beat Saber 0.13.0

@TheSwanCollective


#15

So I’ve managed to get Beat Saber into a playable state without parallel projections again, if anyone wants to try out the mod you can download it here.

This requires the harmony library.

Instructions:

If you own a Pimax headset, you might have noticed the recent update applied a broken glow to literally every piece of text and every image in the game. This plugin sets a non-glowing shader to every image/text object in the game a split second after the scene changes to address this.

I would recommend disabling mirrors in the settings menu as they are broken as well, or just use a custom platform without reflections.


#16

I have the same issue with glow effects on lights, it is different on both eyes.
Your plugin PimaxUnfucker works for me.

I am still getting weird ghosting behind the cubes, do you have any idea how to fix that?
I have a 1080Ti Ryzen 1600X, i really don’t understand why i have so many framedrops and weird stuff…


#17

What’s the latest on this? I’ve not used the PimaxUnfucker.dll since the installation note clearly says to set the HMD FOV to Normal and I’ve gotten used to Large, so that won’t do. Game has been update to 13.2 since then, wonder if it still requires Parallel Projection to fix the issue?

Seeing the thread by @VTS here, I’m beginning to suspect that PP is the reason for the occasional hit misses.


#18

@cocorickoo
The ghosting might be due to the mirror effect on the default platform, try disabling mirrors in the games settings menu.

@Yongkykun
I’ve done some more tweaking to the mod and it’s mostly all fixed, just the offset lighting issue still. I have been playing on large FOV now as well and it seems fine.

Download it/view the source here:

Edit: And yes, parallel projections will of course cause a big performance hit as it’s basically correcting an issue in the game its self at the cost of extra performance. A native fix (mod, or fix from the developer) will always be better if it allows you to play without the parallel projections hack.


#19

@brian91292 wish I saw your post much earlier. Just finished my saber session and I did try turning off PP, v.13.2 certainly still have the same issue. I’ll give your fix a try tomorrow. Thanks for the hard work mate! I know you worked and are working on many mods for the community, many thanks for that!

One thing I noticed when I turned off PP is that as well as some lights, some of the smoke effects also got rendered in the left eye but not on the right causing the jarring effect.


#20

Hi @brian91292 Brian, I’ve tested the latest PimaxUneffer, though the mod does work (meaning the light and fog issue is non existent with PP off), I encountered a few problems that are strange:

  1. Supposedly, with PP off, I should get a bit of performance gain, but the reverse is true. Normally I can play at 70-80 fps with PP on, but with PP off and this mod installed I get 40-50fps even after I turned off the MSAA. The performance actually dipped to 15 fps and less when playing a level. I didn’t change the resolution and SS settings since I wanted to test out the settings a bit so the fps readout I get is using the same SS and resolution settings.
  2. Some of the UI elements are off, I suppose that is intentional? But it can be jarring and takes a bit to get used to LOL. In some custom platforms, the effects are wonky, but here’s the thing, when I had a look at the PimaxUneffer setting, it says Lights ON/OFF but switching to either doesn’t change anything to me, though I haven’t tried playing a level after changing the setting, is that something I can expect to see when playing a level?

I did update my SteamVR before trying, so could that be what’s causing the issue I encountered? Specifically the poor performance.

Thank you.


#21

Not sure what to suggest, it works fine for me and I’m not getting any performance hit with it (playing on large fov with PiTool quality set to 1.25, in-game render scale set to 1.5, and set to 90hz refresh rate). I’m not really planning to update this mod again unless something breaks even more- mainly because the devs are very aware of the issue and they are probably just considering it to be low priority, which is why they haven’t formally addressed it yet (and I’m tired of trying to fix a problem that the game devs should really just fix themselves).

Sorry about that, but the mod is open source so anyone can make additions/changes to it as they see fit.


#22

I’m not sure myself and I also suspect that it’s my build that is the root cause. Wouldn’t even be surprised if one of the mods I installed caused the conflict. Thanks all the same though for your work!

Oh and I sure hope the dev will sort the PP fiasco out in the next update.