Beat Saber Update 3/14/2019 Parallel Projections still required to be enabled



Not sure how that could be possible… there hasn’t been an update in almost a month and it most definitely wasn’t fixed then- not sure how it could be fixed now?

Edit: Nope, appears to be just as broken as it always was:


That was exactly what bothered me. But it turned out that my headset was most likely running with PP on, even if the PiTool and the blue chevron indicated PP off. I checked the HMD recommended render target res in the log and it corresponded to the PP on :frowning:.


Yeah, Beat Games is asking for a free headset from Pimax so they can fix the issue (LOL). It’s actually kind of pathetic considering how much money they’ve prob made from Beat Saber…

So I guess we’re just sitting in limbo until they either buy a Pimax headset or are sent one for free.

Keep in mind I was in contact with the devs in private a long, long time ago letting them know about this problem and offering to test; and they have just totally brushed it off until a semi-popular streamer brought it up to them on social media. Of course, after the streamer brought up the issue the excuse is that they can’t test it (even though I’ve been here available to test and they know this).


That is true, but I guess they are used to getting free goodies from the other vendors as well (even without asking) :slight_smile:. On the other hand, if they ordered it as a regular Joe, they may as well receive it in several months, considering the current logistic challenges Pimax is facing, so I guess asking for a freebie was better overall.

I offered them lending them mine and even showing them all the tricks we figured out so far, so it is really up to them.


They seem to like to make excuses or just seem lazy. I asked for 3rd person camera built-in soon after launch. They said to just use LIV (which killed my performance) and I told them so. Of course mods were eventually created, but I was thinking they should do it anyway since PSVR would be coming… and now Quest. No one likes watching a shaking first person camera. I think I saw they’re finally working on third person. Heh.


The main issue with camera smoothing and/or a third person camera is that it requires the game to render the scene from yet another perspective, which can cause a rather large performance hit. I highly doubt we’ll ever see these options featured on PSVR or the Quest for this reason.


I’m sure they could figure something out. It’s not a huge priority but it should be a feature eventually. They don’t need to keep the same graphics, but if they want to keep them it makes sense it won’t perform as well. I could see a simple low poly 3rd person view that still looks cool. Would rather see a PP fix first though :stuck_out_tongue:


Streamers use the custom avatars mod that works with Vive trackers as well. Not sure if that is what you mean.


Isn’t LIV supposed to do exactly that - i.e. render the game from the 3rd person PoV? I would imagine that if you just skip the green screen stuff it should do exactly what you need, no?


Should be doable using OBS, but to watch as a spectator, now that’s a challenge…


It’s an extra app that killed my performance. Like i said not all platforms(psvr/quest) can use LIV. I don’t want to juggle with a bunch of apps. You can use a mod now that works way better, which is what i use. It’s just not built in to the game


I use that now. Before there were an mod whatsoever the only possible app to use was LIV and that didn’t work well for me. My point is the devs basically shooed me away and said use LIV instead of considering their own implementation


Beat Saber 1.0.0 is released and I tried turning off the Parallel Projection in-game and I see no artifact. Either the toggle doesn’t work in-game or the dev have fixed the PP issue. Performance is much better imo compared to earlier versions.


You have to restart SteamVR and then the game for PP change to be applied.


Excellent news! I will test shortly also.


It is not possible to change Parallel Projections on-the-fly. SteamVR has to be restarted. The issue does not seem to be fixed. They did add some bloom settings to turn off, but that doesn’t do anything to fix the issue either.


Thanks for confirming @cazman321. Such a shame though. All that effort put into spamming their email didn’t get us anything LOL…


Pretty sure the devs have been busy working on getting the game ready for the quest release. They are definitely aware of the issue and I’m sure they’re going to fix it eventually; maybe now that the quest release happened they will get some time to look into the Pimax issue.


Well, v.1.10.00’s out and it still requires PP. Looks pretty clear the dev don’t listen to Pimax users. I reckon it’s up to Pimax to get this done. But trying to get Pimax to listen to us has the same rate of success as praying to a random deity at this point.