Beginners setup guide to get the most out of your pimax image


#1

SINCE WRITING THIS PIMAX RELEASE 1.2.93 BETA, SO I AM DELETING SOME INFO AND RE-WRITING BASED ON MY EXPERIENCE WITH THIS.

Beginner guide to the Pimax and getting the best picture
quality. This will help you solves common issues and use perhaps unknown to you methods to improve image quality.

PIPLAY

Once you get you pimax plugged in, dload and install piplay
1.2.93, don’t bother with newer version unless you really have too.

Now run piplay.

IF PIPLAY STARTS THE PIMAX IN VIDEO OR EXTENDED MODE, Navigate to the bottom right of your taskbar in windows, right click on the pimax logo, right click on mode select, and then left click
on pimax, it should now discover the pimax in pimax mode which is what you need to play games. If it doesn’t make sure you have disabled any type of onboard graphics in your bios, even if you are not using
onboard it still needs to be disabled. This is very important or it either won’t
detect at all or will be stuck in extended mode.

In piplay settings…

change IPD to your preference once you find it.

FOV

Next, boot up you game of choice and play it, first thing
you will probably notice if your headset is anything like mine, is the
incredibly tiny FOV, to eliminate this, you need to add another cm of foam at
least, that won’t crush when you wear the headset, under the stock sponge. This
will remove the borders. Pimax put the screen to far from the lenses I think,
so you can see the edge like a pair of black curtains obstructing your view. I
used packing foam cut to size that is kind of like polystyrene but doesn’t
crumble or break, but others have used other types. Point is, you need to pull
the screen further away from your face somehow if you see these borders. You
may be lucky and not get them.

If you pulled the screen further from face your IPD may also
need to be lowered to account for this.

BRIGHTNESS

You can click the increase brightness in piplay or use the below commands in the debug option.
For High level1 type 10033011

For High level 2 type 10033036

To go back to default type 10033000

Next image quality. The only version of piplay that has a
decent image quality in my opinion previously was 1.1.92, all others they degraded the image
to improve performance which in my opinion was pointless. However now with the release of 1.2.93 you can set the supersampling slider in piplay to 1.2 and get a great image AND great performance. I use a gtx1070.

COLOURS

Next colours, to turn up the colours you need to first unplug
any extra monitors other than your default and reboot your pc, if you don’t you
may have issues. .

Now set the pimax to video mode ( may be called extend in
some versions), then right click on your desktop and go to nvidia or AMD control
panel. Find the display and click on it, then click change desktop colours in
Nvidia control panel under “display” or equiv in AMD. Change vibrancy to your preference,
I prefer 65 - 70%, then change back to pimax mode, the settings will stick and it
will look a lot better.

ELIMINATE GYRO DRIF
1.2.93 also contain an option called Magnetim calibration (They mean magnetism)
Run this, then tilt the headset up, then down, then rotate it left, then right, then repeat all over again until a message displays calibrate complete on the screen. Now run a game and you should have little to no headset drift.

The instructions are badly wroded by pimax in english but the above is what they mean, at first was moving it up down left right instead of tilting up down and rotating left right and this did not work it just made things worse. You could always put it on your head and look up, down, left, right too which should work.

FIRMWARE
As far as firmware goes, mine crashed when i recieved it updating and appeared
to brick the headset before I had even used it, but I managed to re flash using
the firmware update tool which is on the pimax forum. I have not dared do it
since and use firmware 1.0.0.248. Link to a pimax guide here…

If you ever update piplay and see the light on the top of the HMD flashing different colors or flickering, leave it alone until it finishes and don’t run anything! This will help avoid issues.

My firmware is now on 1.0.0.265

Dave


Eliminate gyro drift pretty much completley
Image sharp on the sides but blurry in the center
How do i adjust the brightness of the screen in piplay (pimax 4k)
#2

Thanks for that, just ordered one, will come in handy


#3

Good guide, will save a lot of time to new people. I have yet to find a reason to step away from 1.1.92.

I do not really agree about increasing the padding to increase fov. It is quite the opposite! as you pull the lens away from your eyes you can see a smaller and smaller portion of whatever is on the display.

you can check it using the unity app in this lovely reddit post. that is also useful to test the Ipd. Closing one eye at the time the center should not move.

That said, custom tailoring the padding is still really important to make the device fit best on your face. I have big nose and added some extra padding under my eyes for extra support. Now my nose barely touches the hmd.

I also ripped off some dark T-shirt and made a few DIY washable cotton mask mainly for igene porpuses, since my sister told me she teared up watching some movie in there… Eyes infections no thanks!


#4

Hi,for me and others the closer you have the headset to your face the smaller the fov is, totaly unusable unless it is pulled off the face by a minimum of 1cm due to huge black borders at either side, its like looking through curtains or someone else said a barrel. Pull it away and they dissapear, but this does increase binocular effect.

If yours is the opposite then yours has been built differently, others have the same problem as me, some do not. At some point recently they must have changed screen distance from lenses during manufacture, ipd is irrelevant as it’s digital only not physical so neither the lenses or screen moves, i have tried every ipd from highest to lowest it makes zero difference to were the edge of the screen is or how big the borders are, and it is the edge of the screen and beyond i and others can see as far as i can make out.

The vive which i owned was the opposite as you say, the closer i got the bigger the fov.

I already made apost on here along with pictures and a poll to see how many others had the issue. You are one of the lucky ones.

Orig post about this with images is here


#5

Wow, just saw the pictures of your device! I would maybe try to carefully open it up cose those panels are clearly in the wrong position! contact support first tho. Good luck and thank you again for the guide.


#6

The pimax only has 1 panel, not 2, it’s a single screen only that runs in split screen and is dead center so can’t possibly be in the wrong place. It can only be closer or further from the lenses than yours, but if so then that’s just a change in design as it is not adjustable.

The picture was taken by putting the camera right up to the lense facing toward the sides slightly. Everything in the pimax is fixed from the lenses to the screen, nothing can be adjusted physicaly at all unfortunatley except the strap, unlike the vive which has 2 screens that move in and out using a nob for ipd, and a distance adjuster.

I did contact support and their answer was we are aware of the borders but “fixed it in a software update”, please “roll back to 1.1.92” and try it…which is a direct contradiction, if it was updated and fixed why roll back…

Anyway it’s perfect with more padding so that’s what i and others are doing.

Dave


#7

UPDATE: Version 2.3.08 is now released, the option are pretty self-explanatory, it has magnetism calibration, good performance etc, only thing you need to change are colors as detailed above, and also i find that if you turn gamma up to 1.2 it looks a LOT better, brighter and with more detail. You can turn brightness in the piplay menu up and down also, but gamma makes a big difference. Also, i have decided I prefer 75% color vibrancy now.

Dave


#8

Can you explain how magnetism calibration works? i keep failing, i must do something wrong?

I put hdm on my head and look upand down then center and then left and right then center and up and down and repeat…


#9

I don’t put it on my head i do it while holding it in my hands, and try not to do it quickly, but putting it on your head should do the same thing, so if that doesn’t work I can’t explain it and it may be faulty. Some people open steamvr’s display mirror, face forward and then press Z which can work for some, i find that method a bit hit and miss.

also make sure the pimax is fully facing the ceiling and floor, and full to the left and right. This is why i do it in my hands, hard on the neck otherwise. I have no idea if this is needed it’s just how i do it.

Dave


#10

k thx for advice ill try later again.


#11

I am also repeat the calibration failure like the same way too.
VR headsets using to north will slightly alleviate the drift.
My tablet’s compass application is doing the same movement.
I think, Perhaps, 4K headsets use the same high performance magnetic gyro sensor as smartphone.
There are many devices that generate electromagnetic around my PC, and 4K headset drifts a lot. Similar cases have been reported in CV1 too.
However, since the my tablet installed the filtering application of the magnetic gyro sensor, the drift has been reduced.
I think that is shows the possibility of improvement of drift of 4K-headsets.
When testing the 4k headset, I think Pimax4K will be able to detect drift if there is equipment that generates electromagnetic around it.
If PiPlay has filtering function of magnetic gyro, the set of 4k headset and NoloVR It is likely to become VR device of CV1 or higher.

I expect it.
I pray that my poor English will be understood.


#12

Hello guys, I’ve tried to change gamma and color vibrance in the Nvidia panel but nothing works…what could it be?
Any chance to have a better image to set IPD correctly? Every number seems the right one until I set 65-68 with double images, but after some hours of use I have eye strain and it’s not good for health. My real IPD is 66.7, now I’m using 62.4 (piplay 2.0.4) and it feels more confortable but I think I’ll never get the correct one using Pimax green cross. Please in the next update we need better support in the IPD settings, thank you


#13

Yeah hopefully they can add a 2 color cross… Ir maybe some txt in a greybox to simulate Bigscreen beta text.


#14

Hmm… Your IPD is 65-68? Which is it?.. If it’s 68 try setting it to 57 if it’s 65 try 54.

Let me know it that’s better.

Eno


#15

I’ve tried with Elite Dangerous, my best vr game now. I’ve fixed it in the best way after a lot tries and while in game looking at my pilot feets in my asp-explorer LOL (that was so helpful cause of the wide glass focusing the background too). I noticed using 62.4 I had not focus if not looking in the perfect center of lenses(reading missions for example). So I switched IPD all back from 55.0 to 60.0 and focus was really wrong ad black borders more pronounced. After 60-61.0 focus were better but still felt a bit hurt after some minutes but the strange think, the more I added to IPD and focus was more large and able to read more text around the center of lenses. Now the happy thing, I’ve noticed while looking the pilot’s feets (while in any base), they are just in the middle of the image and a little below the focus center, one left and one right. The right foot was blurred to my eyes so IPD 62.4 was wrong. I’ve upped it going by 0.1 till reached 64.4 where each foot was crystal clear (remeber if want to try it to look feets down without moving head but only eyes). I tried to go far from 64.4 but image started to blur again. So this is it. My IPD is 66.7 and using 64.4 I have perfect focus, the immersion now is awesome, feel relaxed and text are readable without any effort. I hope this can help anyone while finding the right IPD. I mentioned the ASP Explorer cause while looking the pilot’s feets u can focus also in the background beyond glass looking the stage checking if can focus it too. But I think it works in every ship! I hope I haven’t to do this on each Piplay update :smiley: Now I’m just happy as it is! Thank you guys


#16

In Nvidia control panel make sure you select “Adjust desktop color settings” and NOT “Video color”. Once finished click apply at the bottom and it will work, at least it should. Only desktop color settings count, video is just for watching videos via a windows video player and won’t affect gaming etc on the pimax.

Dave


#17

I did on desktop colors, but nothing change after I switch to pimax mode. Not sure why :frowning:


#18

Mine no longer stick either, i noticed in Project cars 2 the image was dull and washed out, re did my video settings and its still like this. It used to work and I am not sure at which point it stopped working, but it has. I’m using latest Nvidea drivers and pimax 2.0.7 beta. Color vibrance seems to stick but nothing else…

@Pimax-Support Please pimax, add a gamma adjust function to piplay, as well as brightness.

Dave


#19

Hi, we will note that and submit it to our engineers. We will update you if any progress.


#20

Any update on the gamma and brightness adjust functions? I tried the Nvidia control panel thing but it doesn’t change anything on pimax mode (it does on video mode, but it doesn’t stick once I change to pimax mode).

@Pimax-Support @xunshu @Sean.Huang