Best quality settings for STEAMVR ive found

suggestions

#1

So, i have RTX2080ti+Pimax8k and playing games like Elite, ETS2,P.Cars2 etc (simulators)
Ive found settings where i have best picture and acceptable FPS.

Pitool SS - 2.0
SteamVR - 25% (its 0.5 downsampling)
check out steamvr options:

  "allowSupersampleFiltering": true,
  "allowAsyncReprojection" : false,
  "allowInterleavedReprojection" : false,
  "enableDistortion" : false,
  "maxRecommendedResolution" : 4432,  <-this is half of Pitool SS 2.0 resolution (if u use 1.75 its must be lower)
  "motionSmoothing" : false,
  "preferredRefreshRate" : 80,
  "supersampleManualOverride" : true,
  "supersampleScale" : 0.25  <- its VERY important. NOT 24 or 26. EXACTLY 0.25. U can set it only via config file edit.

Try it out. Elite looks fine with these settings. And other games too. 2080ti give me 60+ fps.
If u have slower gfx card, i recommend use 1.75 or 1.5 pitool instead (but DONT touch 0.25 steamVR SS)


8K X vs HP Reverb - Just a teaser :)
#2

Hmm interesting, thanks a lot for this. Will give it a try tomorrow!
So basically you mean we should run PiTool render quality on 1.5 (or higher), SteamVR 25% and “maxRecommendedResolution” : 4432 ? Sounds like you let SteamVR downsample the image again due to the 4432 limit? Or am I confused now again? :slight_smile:


#3

Game rendering image with 4432 resolution.
SteamVR upsample it to 8864 (exactly x2), filter it. Then 8864 res image going to Pimax drivers, where it processed with maximum quality (parallel and lens corrections)


#4

Problem is when you upsample x1.9 or x2.1 for example, you will have MUCH blurrier picture. When u upsample EXACTLY x2 u have clear picture and much less artefacts.


#5

Very very interesting! I have noticed in the past that some certain resolution/ss combinations (despite being lower) can produce a more sharp image, but I never understood how the numbers were calculated. This actually got me thinking…hmm…I dont think I have time to sleep tonight haha. Gotta try this! :slight_smile:


#6

if u use Pitool SS 1.5 or 1.75 - limit will be lower also. It must be HALF of Pitool resolution.
4432 it for PitoolSS 2.0 (and for 8k only. 5k have different resolution maybe)

If u have very slow gfx card u can try x3. But its must be EXACTLY 1/3 of resolution. 8864 cant be divided by 3


#7

Now Im even more confused, and curious at the same time :slight_smile:


#8

just look at resolution with steamss=100%. And divide it by 2.

steamss 100% show u resolution which going to Pimax driver. Unfortunately u cant play with so high resolutions even on 2080ti. So better if u divide it by 2 :slight_smile:


#9

This,the factor in scaling in SteamVR of the original PiTool Render target by a factor of 2. Be it up or down will give best image results so SteamVR percentage settings or 25% - 50% - 100% - 200% - 400% are the best to use in my experience.

Interesting though you are manually telling default.vrsettings to use an absolute value in “maxRecommendedResolution” which corresponds to what you are trying to use in game. I thought the setting was more just the upper limit to impose on the render pipeline which was initially 4096.

Why I have been changing it myself to 8192 or 122880 for testing purposes to see how much SS can be applied and the effect on performance with my 8K.

I also do not use any in game or Nvidia Control Panel AA. :+1:


#10

So what is the config file name and where exactly is it located?


#11

Same question, can you explain how to force 25% ss and not 24 or 26? Options slider doesn’t allows to do it and i can’t find the right config to alter it.


#12

I’ve tried a lot of values. My best setting in contractors for example is

pitool:1
steamSS: 50%
appSS: 100%.


#13

I run mine at
“supersampleScale”: 1.0,

which would be SteamVR 100% I assume.

The figure is found in your SteamApps/SteamVR folder just do a search on defaults and the file should pop up.

Mine was at
C:\Steam\steamapps\common\SteamVR\resources\settings

Fairly sure that is the one although recently renamed but then I am building up software on a a new system but I did move my Steam folder across to the new drive and re-installed Steam.


#14

Me too. The config file I found has some but not all those settings.


#15

Thanks…


#16

Lower like what value for 1.75? Or 1.5?


#17

Ok, a few points.

The file location that SteamVR recommends for altering the default vrsettings is located in

C:\Users\Username\AppData\Local\openvr

It is also called default. There’s one for consistency.

  1. Tried the settings as listed at the top, with a couple exemptions like reprojection as I didn’t find any entry for it in the default file found under SteamVR/resources/settings/

With PiTool 2 and the entry to have SS at 25% I found the image smooth and decent frames but soft and lacking crisp detail.
Also I couldn’t get Il2 to launch with FFR on at those settings.

I returned the SS value to 1.0 in the default file and then tried again with these settings.
PiTool 2, FFR Aggressive and SteamVR 50% (Video only and App stays constant at 100% in SteamVR).
Il2 worked, frames were 20% slower but better detail.

Also, at the frames of under 60fps, I recommend leaving motion smoothing on and that is probably why lower frames, 40’s and up, don’t give me issues.

I personally have been working with PiTool 1.25 or 1.5 with FFR Aggressive and SteamVR 100%

Running PiTool at a lower setting of say 1 or 0.75 but with SteamVR at 200% is also another option for people to try. Maybe not as crisp image as higher PiTool with 100% but still good.

Add a Crows foot, a Frogs tongue, Bark of a Gum Tree and other weird ingredients and you will be happy with your VR settings. :grin::joy:


#18

config file: c:\Program Files (x86)\Steam\config\steamvr.vrsettings

HOW ITS WORK:

When u set PitoolSS.
-Pitool say to driver - hey, i want picture in THIS resolution (8864 in my case with SS 2.0)
-Driver says - ok then. hey, steamvr, give me picture in resolution 8864!
-Steamvr says - Ohh… game send me much lower resolutions… but ok. Wait a sec. I upscale it for you.
-Driver says. - ok, im waiting.
-SteamVr says to game - I have settings 25%, which is mean x4 less pixels, which is mean x2 lower resolution. So i need 4432 resolution from you!
-Game says - ok…ok… I render… render… ren… der… Look. Its here.
-Steamvr says - nice. I’ll take it. Now i need scale it for pitool driver. (because he want 8864 resollution from me!)
-Driver says - hey, steamvr. Are u here? Still waiting. Ah… its here. Thx a lot for picture. I’ll correct it, and scale for HMD.

What this mean:
Pitool need fixed resolution (depend of Pitool SS, FOV, and PP setting). No matter what you doing with SteamVR. Pitool driver ALWAYS accept only his own resolution.
if u set SteamVR less than 100% - its will be upscaled for pitool driver.
if u set SteamVR more than 100% - it will be downscaled for driver.
if u set SteamVR equal 100% - its will be not scaled. And game will render in same resolution as pitool want.

I hope its help :slight_smile:


#19

After an extensive afternoon of working and testing, I find your settings, although reasonable just not doing it for me.

I understand your reasoning behind it but for me - I only want SteamVR as a pass through and not imposing any SS settings of its’s own.

Try using PiTool Render 1.25, Normal FOV, FFR Aggressive with SteamVR at 100% both App and Vid.

The biggest take away from your settings though was the new crappy filter SteamVR has introduced which has had many VR users on the Il2 forums in a fit wondering why Il2 had turned to a blurry mess.

“allowSupersampleFiltering” : false,

Adding lines to your steamvr file in
C:\Users\Username\AppData\Local\openvr

will also overide what SteamVR’s default file does and also not get overwritten by any steam updates.

I for me clarity is important and now I can again spot contacts at distance be them in the air or on the ground.:+1:

Also using
“maxRecommendedResolution” : 12288,
Not that I need it that high but future proof for you know, when they release the much talked about RTX4080ti.:stuck_out_tongue_closed_eyes:


#20

Sorry to ask, even if its obvious, i am not 100% sure.
Does your statement not mean that the best Quality will be always achrieved with Pitool SS 1.0 and SteamVR SS 100%?
And you only setup SteamVR SS 25% and Pitool 2.0 to save some render ressources, and to get not a blurred image?
Or did i missed something?