Classic games, Doom, Quake 2 etc in VR


#1

Maybe you people have found this already, but I thought I’d share it.

https://vrwiki.wikispaces.com/VR+mods

Many of the mods on that site work well with Pimax, especially Doom, Doom 3, and Quake 2. I have tried and failed to get Duke Nukem and Jedi Academy working but have yet to try the latest beta. Dolphin VR is absolutely stunning. I played Eternal Darkness in VR and it works really beautifully well, but the zooming camera is pretty nauseating.
Richard Burns Rally is great too.

If anyone knows of any other old classics that have been given new life, please let me know.

Edit: This is great too. Just managed to get Wipeout Pure working in VR. (with the Revive Injector)

Edit 2: Resident Evil 4 on Dolphin is also pretty amazing, once you get rid of the black lines (game Properties> Hide Objects)


#2

Great link, but I haven’t been able to run Q2VR with the pimax, which mode do yo use to run it, and is any other software involved?


#3

I used 1.2.40 beta, switched to extended mode, set the pimax as primary display in nvidia control panel, and switched the display to the pimax using Win+P.

It is helpful if you have the shortcut visible on your desktop. You have to close one eye, and use your desktop through pimax.

Then on booting quake 2 up I may have had to type vr_enable in the console. Then it just worked. I tried revive etc but I don’t think it made any difference, can’t get steamvr mode to work on Q2.

I just upgraded to 1.2.53 and it kills extended mode, unfortunately, no Q2 from 1.2.5 onwards.


#4

go into steamvr, and settings, select disable direct mode, and you will get extended mode back.

enable direct mode to reenable steamvr.


#5

Doesn’t work for me. It just restarts back in direct mode. Any ideas?


#6

Yeah man,

go

C:\Pimax\Plugin

(or where ever your pimax is)

go into extend-runtime or extend win10 runtime

and try the different piservers in there

(you can run these without piplay, you will maybe need to restart pc)


#7

Also for me, i have just noticed, that if the new beta is loaded and i do not have steamvr running, my pimax is in extended mode.

not noticed that before. SO if i pick it up the pimax display is there, and it is seen as an extended monitor.


#8

Just tried and it worked once before crashing. Had to go back to the normal one. It’s cool though, maybe the new local button will do the same thing.

Cheers though.


#9

Thanks buddy! I managed to play last night, but didnt make the giroscopes work, were you able to look around with the pimax in Q2?


#10

Yeah, gyros worked fine. Have you checked the virtual reality, advanced dk2 options? I assume Q2 thinks we are running DK2s.

But yeah for me after minimal messing, it just worked.

What pimax driver are you using? I think I read older versions don’t have tracking in extended mode, maybe that is it?


#11

Gave Quake 2 VR a go using 1.1.92 in Extended mode & also tried PPSSPP VR w/ 10x internal rendering res.

Wipeout Pure & Gran Turismo was good stuff but Gran Turismo had no usable cockpit view on my side.


#12

Doom, Duke3d, Quake 1 and 2 etc now work perfectly on newest versions and the revive injector.

And I just managed to get Unreal Gold working in vorpx (cheating, I know), with the unofficial patch, changing the exe name to Haloce.

It should look great with a bit of tinkering.