Converter for DisplayPort plug?


#1

I bought a laptop to run the Pimax 5k, but I neglected to check the available ports before buying. Turns out that the laptop only has an HDMI out and USB 3.0 ports. Naturally, I waited too long to return the laptop, so I’m stuck with it.

I’m curious if there’s a way to use a gender-bender or something to convert the DisplayPort to HDMI? Or are the two technologies incompatible? I also have a feeling that the USB 3.0 won’t drive the headset correctly. So I’m probably screwed here, but I’m hoping there’s some way that I can jury-rig the unit to work on the laptop.

Can someone give me good news?


#2

@SweViver might know. Can you post laptop brand & model?


#3

Unfortunately, it looks like HDMI->DisplayPort adapters doesnt work so well in most cases with Pimax headesets. Its seems to be the same story for other headsets with higher resolutions such as HP Reverb, Index etc.

As far as I understand it, the HDMI is not capable of transmitting the required high amount bandwidth to the headset.

Personally Im using a laptop with mini-DisplayPort only, and using a mini-DP to DP adapter which works good.

So in your case, Im afraid the only option would be to replace your laptop :confused:

(By the way, USB 3.0 is enough, no worries. Im using the blue 3.0 port on the laptop and it works with all 3 Pimax headsets).

/Martin


#4

Do you have USB-C port?
If it’s an RTX laptop maybe you have virtual link?


#5

It’s an ASUS GA502DU-BR7N6.

It does have a USB-C port, but only the HDMI for video out. It doesn’t have any blue USB ports that I can see, so yeah, I think I’m screwed here. At least it’s an upgrade over my old laptop. :slight_smile:


#6

Okay from what I read your Usb-C supports DP 1.4 so you might be able to use a Usb-c to DP adapter just sure to check that it is DP 1.4. Asking asus support might be an idea; bit think some users here have used Usb-c Dp adapters.

I can’t say in Hdmi but it says your laptop has hdmi 2.0b.


#7

Hrm…I wonder if this would work:

I’m getting excited about this again! Thanks for the help folks!


#8

Okay, I’ve tried both the above Cable Matters converter as well as:

And both…sort of…work. The visor gets recognized and I get the lovely space image that we see upon loading of the unit. I can scan around and there’s no latency or any stutter at all.

And then it cuts off. And the visor is no longer connected. And then it connects again. And then some random time later, it disconnects again; usually within 30 seconds. Lather, rinse, repeat.

So at this point, I’m not sure why it’s disconnecting. I don’t imagine it’s the video card getting too hot, as the system’s barely taxed and it’s barely been running when the disconnects happen. Could there be some other setting within Windows or the PiTool that could be affecting it?


#9

I can’t see what DP it supports. But does say 4k@60hz. I think you need to ensure DP1.4 but don’t quote me.


#10

The Cable Matters one states 1.4 compatibility, so I’m afraid that’s not it. :frowning:


#11

Limiting to 60hz on 4k might be causing the loss of connection. Might need a different adapter. I believe someone had posted one said to be working.

Is this a laptop or desktop? If laptop might need an adapter with external power.


#12

It’s a laptop. I was looking on Amazon for a powered one, but couldn’t find anything. I’ll check again. If you can dig up the one you’re thinking of, I’d appreciate it.