Creed has double image. Beatsaber blurs


#1

I’m running the 5K BE edition, but I think I had these issues when I had tried the 5K Plus.

Creed boxing loads with a double image. I’ve tried the released version and now the 121 beta and enabling parallel projections. I’ve also experimented with various other settings.

Beat Saber works, but the lightsaber and other moving images blur. Is this normal? I also have to reduce render quality to 0.75 even though I’m running in normal view and have a 2080TI card and very high-end CPU and RAM.

Other apps also have issues. When I change settings, when do I need to reboot the service? Reboot the HMD? I’ve been doing both lately, but that is time consuming when testing.

Do games need to be launched from the Pimax tool? I think I’ve tried that too, but was not sure if its necessary.


#2

Double image sounds like parallel projections and You only have to restart SteamVR when toggling it.

Blur could sound like low framerate. Check in SteamVR settings that Your global supersampling setting is auto (You should get around 50% with a 2080 Ti and PP enabled I think if You’re using HMD Quality 1.25 like I do) and You have no application supersampling set on top of the global setting (=100%).

A good tool to keep track of settings is fpsVR.

You should restart SteamVR when changing:

  • Compatible with Parallel Projections
  • Compatible with Vive Only Game
  • HMD Quality
  • Hidden Mask (I always leave this on)

Changing FOV (starting from large), Fixed Foveated Rendering and Smart Smoothing can be done without restarting SteamVR.

Changing refresh rate reboots the HMD and crashes SteamVR.

I only restart the service/reboot the PC if PiTool can’t find the headset.

You need to launch Oculus games from PiTool, but not SteamVR games. They can be started from Steam or PiTool.


#3

Thanks for all the info! Unfortunately, Creed still shows double with parallel projections on (or off). Also tried all the other pimax graphic settings turned on like foveated and hidden mask but no luck. Not sure if this is because the Pimax BE uses slower panels? Or it’s something else?

Not sure what setting you mean by “Compatible with Vive only game”. Where is that? What’s it for?

My global super sampling under auto (ie, custom turned off) calculates at 122%. Setting changes in Pimax don’t seem to affect what SteamVR calculates its SS to be, which is what you seem to imply. However, 122% kills many games. I’ve tried cutting this back to as little as 50% and upping the 1.25 HMD (or also trying 1.0 or 0.75). That improves performance but I still get the ghosting/blurring sabers in Beat Saber. FPS seems to average about 74-75 out of a possible 82hz generally if I keep super-sampling within reason. I even tried small view and 1.0 (and 0.75) for the pimax render quality. Below 1.0 I noticed text gets fuzzy.

Thanks for the fpsVR suggestion. I like it better than OpenVR so far. It seems to show that I’m staying comfortably under 100% on GPU, memory, CPU, etc. I can’t see any reason I’d be losing any frames.

FYI: At 50% SS and 1.25 rendering, Raw Data looks like pixelated crap. With a higher SS, this game works great for me. It’s various other apps that have issues.

If you or anyone else has suggestions, I’m all ears!


#4

It’s an option only available in latest beta (.129).

It presents the headset as a Vive instead of a Pimax for games that check that (I only know about Doom 3 BFG Fully Possessed).


#5

v129 doesn’t fix anything either, sadly. In fact, frame rates dropped super low until I disabled everything and lowered SS to 50%, still low, then set HMD rendering to 0.75 and that makes it work. I still get lightsaber blur, but it seems to be slightly less than in the past.


#6

You could try reinstalling Your Nvidia drivers wiping Your Nvidia settings (“clean install” or even better DDU + “clean install”).

You might have an old leftover if You’ve ever tweaked in Nvidia Settings?


#7

oculus store version works great


#8

Oculus store version of which game? What settings are you using?


#9

Creed

I run Piplay 1.5 fov Normal Smooth On 72Hz PP On

I can’t speak to Beatsaber. As a Rock drummer from the 60s, it does nothing for me :smile:


#10

The .132 of pitool has eliminated the double vision problem. When I try running with render at 1.0, 72 hz, PP On, and smoothing on or off, it can’t seem to break about 41 FPS. Visually, it looks okay, but swinging my arms is sluggish.

(The beatsaber issue is solved. The game settings had the graphical default set far too high, plus that game doesn’t like Smoothing to be on).

Does your Creed still work well? Still scratching my head on why mine doesn’t. I turned SS down to 50% but that doesn’t help either. Skyrim and Beatsaber run great.


#11

I am running the Oculus version of Creed. May be a little more optimized?