Default.vrsettings "maxRecommendedResolution" SteamVR

pimax-8k
suggestions
issue

#21

Is there a way for pimax to automatically change this? Only people on this forum really know about this, there are probably a ton of pimax users that arent aware they are not getting their full resolution.


#22

Pretty sure they already did earlier by supplying their own vrsettings file with the PiTool install and that is what no longer works.

EDIT: It’s located here and contains the settings that are overridden for Pimax headsets compared to the standard SteamVR supplied default.vrsettings (as far as I understand):

C:\Program Files\Pimax\SteamVRSupport\drivers\aapvr\resources\settings\default.vrsettings

Contents:

{
‚Äústeamvr‚ÄĚ : {
‚ÄúenableDistortion‚ÄĚ : false,
‚ÄúsupersampleManualOverride‚ÄĚ : true,
‚ÄúsupersampleScale‚ÄĚ : 1.0,
‚Äúbackground‚ÄĚ : ‚Äú#FF000000‚ÄĚ,
‚ÄúmaxRecommendedResolution‚ÄĚ: 8192
},
‚Äúpower‚ÄĚ: {
‚ÄúautoLaunchSteamVROnButtonPress‚ÄĚ: false,
‚ÄúpauseCompositorOnStandby‚ÄĚ: false,
‚ÄúpowerOffOnExit‚ÄĚ: false
}
}


#23

Sometimes SteamVR updates also overwrite the file reverting the value back to 4096.

I just made a shortcut to the file on my desktop.


#24

Uh…why should SteamVR care to access and modify a file generated by PiTool for Pimax exclusive configuration purposes ? O_o


#25

i think you are talking about the ‚Äúold method‚ÄĚ where a file was modified that explicitly stated in the header it should not
there are to ‚Äúdefined‚ÄĚ locations where user or vendors can change setting that will be present after updates of steam vr
‚ÄúC:\Program Files (x86)\Steam\config\steamvr.vrsettings‚ÄĚ
and the vendor specific settings file that come with the steam vr plugin of the hmd like
C:\Program Files\Pimax\SteamVRSupport\drivers\aapvr\resources\settings\default.vrsettings


#26

My steam folder is not on C: drive it is on My seventh drive L:, and steam dose and will change Default.vrsettings as I have just had to change it back to 8192.


#27

no, you dont have to change it back because its already in your
%where ever you installed pitools%\Pimax\SteamVRSupport\drivers\aapvr\resources\settings\default.vrsettings
and that file is used by steam vr in addition to
%where ever you installed steam%\Steam\steamapps\common\SteamVR\resources\settings\default.vrsettings
and
%where ever you installed steam%\Steam\config\steamvr.vrsettings


#28

But if I don’t change it back My graphics are crap.


#29

the setting was introduced with pitool v111
did you try to insert it in
%where ever you installed steam%\Steam\config\steamvr.vrsettings
“…
‚Äústeamvr‚ÄĚ : {
‚Äúbackground‚ÄĚ : ‚Äú#FF000000‚ÄĚ,
‚ÄúlastVersionNotice‚ÄĚ : ‚Äú1.6.10‚ÄĚ,
‚ÄúlastVersionNoticeDate‚ÄĚ : ‚Äú1564674570‚ÄĚ,
‚ÄúsupersampleScale‚ÄĚ : 0.39999997615814209
}
‚Ķ‚ÄĚ
edit like this:
“…
‚Äústeamvr‚ÄĚ : {
‚Äúbackground‚ÄĚ : ‚Äú#FF000000‚ÄĚ,
‚ÄúlastVersionNotice‚ÄĚ : ‚Äú1.6.10‚ÄĚ,
‚ÄúlastVersionNoticeDate‚ÄĚ : ‚Äú1564674570‚ÄĚ,
‚ÄúmaxRecommendedResolution‚ÄĚ: 8192,
‚ÄúsupersampleScale‚ÄĚ : 0.39999997615814209
}
‚Ķ‚ÄĚ
at least this should work (if you have already changed the resource file then revert it before testing, values present in the resource file will be removed from steamvr.vrsettings when they are the same as in the resource (default) file


#30

Thanks I will give it a go, though my config file looks totally different from that, but can see were to insert the line.