Difficulty setting up. Unable to have pimax 4k recognized by Piplay / Steamvr


#1

Hello,
I have just received a Pimax / aukey 4k and I am having difficulty setting up the device. I have read a couple treads on this similar topic but am still unable to solve this issue on my own.

My current system specs are: I5, GTX 970 4GB, 8GB RAM, Windows 10 64bit

When first starting the software, there is no option or drop down menu where I can select pimax mode, or extended mode. Piplay version 3.0.0.71 is unable to detect device, under the settings icon, -> devices, it states “device disconnected” The red icon, next to the settings icon, on the top left of the Piplay software states that my USB and HDMI/DP are connected, with the tracking device, controller 1 , controller 2, and BS1 as all disconnected I have tried different older versions of Piplay with no change.
Additionally steamvr states that my device is disconnected when I try to set up the Room setup.

I have tried uninstalling and reinstalling both Piplay and SteamVr with the same result and disconnecting and reconnecting the cables. I am able to see a blue light when I turn on the device, and windows 10 recognizes that there is a device connected, but I am not able to get the light green.
Since my monitor only has HDMI ports, I connected my monitor to my motherboard’s HDMI slot as my GTX 970 only has 1 HDMI slot, and I connected the Pimax HDMI cable to my GTX 970 card, would that be an issue?

When looking into the headset, I see my desktop background without any type of tracking and nothing more.

if you need any more details please let me know.
Any help will be greatly appreciated.


#2

Hi @yetdooksi

welcome to Pimax forums :slight_smile:

I think your nearly there reading your posts.

1st issue : the Pimax must be plugged into the dedicated GTX 970 cards HDMI port and plugging it into the motherbaords HDMI port will not work.
Depending on which GTX 970 you have will depend on what other video output ports you have, you may need to purchase a video adapter for your monitor… ie Display port to HDMI of DVI to HDMI. this adapter should be used with your monitor connection and not the pimax.

2nd issue: you mentioned that when looking in the pimax screen you are seeing a projection of your desktop… this means that your PC is seeing it as another screen (this can be verified by checking windows display adapter properties and it will show pimax as a secondary screen.
this mode is so you can watch movies, but it also means that steamvr which is for games will not see the HMD. for steam to even try to see it as a VR device the piplay options need to be changed to PIMAX mode - so change it from VIDEO to PIMAX and it will restart itself and should switch to PIMAX VR Display and should disappear from the windows display adapter screen in windows settings - obviously this will ONLY work if the pimax is connected to the HDMI on your 970 card.

3rd issue: there will be no controller connections if you dont have any controllers to connect with. seems obvious enough i think :slight_smile: but if you do have VR Controllers let us know what they are and the clever people in the community will help you connect them up.

good luck and post if you have any questions.

Eno


#3

Once you have an adapter to plug your monitor into your 970, you also need to disable rhe onboard mother board graphics. You might also need to disable the intel graphics in windows device manager (the bios disable though should take care of it, i have a skylake i5)

Helio


#4

Thanks for the reply!

My Pimax is connected to my GTX 970 with my monitor connected to my motherboard. So if I can connect my monitor to my GTX 970 as opposed to my motherboard with an adapter, it will help with the installation of Piplay?
Since my pimax is not recognized by Piplay, I don’t think i am able to change my settings from video to Pimax to even watch movies. When I select to watch a movie on my computer, Piplay states that “pimax device is not connected”. I am pretty sure that this device is dependent on Piplay to play movies, but is there another software I can test out that will recognize pimax that will allow me to play movies to get me started?


#5

This is due to the onboard graphics interferes with piplay. Once your onboard gpu is disabled & your monitor connected via an adapter piplay should see the headset without issue.

Also bumped your user level up by 1.

At present the version of piplay before 3 works better.


#6

Hello again,

basically what Helio is saying is the on board gpu is basically a low power gpu. Pimax requires a proper dedicated gpu to run. if the motherboards gpu is enabled in the bios Piplay will see it and will refuse to run as it will fail its minimal requirement test. So disable the internal gpu so the only gpu active is the dedicated 970. then piplay will be happy :slight_smile:

if your monitor is working on the motherboard hdmi slot then the Igpu is active and Piplay will not work

hope this makes sense ?


#7

Crystal Clear explanation!

I will try that and report back.


#8

@yetdooksi

Hello, did you get a chance to test this ?

Thanks !


#9

Are you having an issue as well? Or are you just curious of the outcome?

Eno


#10

Yeah I am having an issue as well.

Light is blue on the headset, but Piplay says the HDMI and USB are disconnected.
I can only see the desktop in the headset ( as if it was an extended display )

Contacted support, they used teamviewer to try to solve it but it wouldn’t work.
I asked for a replacement cable 3 weeks ago and I still did not get an answer.

@Pimax-Support @PM_Sean @xunshu


#11

ahh i see, so Pimax support have already run a teamviewer session?

i expect they have covered the usual…

if you have a IGPU it is disabled in the BIOS and in Device Manager.
HDMI is not plugged into the on board slot and is connected to the dedicated GPU?
KLITE is not installed? and has been removed prior to installing PIPLAY?

Just some of the usual things that can cause it?


#12

I have an Asus ROG Laptop, it has no IGPU.
I have just tried uninstalling KLITE and PIPLAY. Restart and then just intalled PIPLAY. Still no luck.
But Thank you for the suggestion.

The headset had been working for 4 months until it stopped being detected.
It’s frustrating…