Dirt Rally Crashes on Start

issue

#1

So it gets to the splash screen, into the window, and then it crashes on the screen that lists the sponsors.

Anyone else with this problem or have a fix?

This was working fine a few days ago, and yesterday it decided to not want to work.


#2

pitool , firmware ? …


#3

Pitool 103
Firmware 191


#4

imho this firmware is faulty…
i have to lower my gfx card OC and powerplan , otherwhise crashing in some games, no issue with pitool .95 or .91


#5

Most other games you have to turn down the fov and pitool setting. You could try turning them down all the way, small and .5, just to see if it starts. Then if it works start high and decrease it till it starts. I know it sucks, thats why they need to put profile saves.


#6

I’m using 72Hz mode, 140 FOV… works well for me…90hz worked too though. hmm. I launch the game from Steam not Pitool. I may have had issues launching from pitool, I forgot. I also use an older version of Revive because I’ve heard issues with newer ones.


#7

Why hello everyone, I have discovered the problem… which turned out to be… drum roll please…

Ge-force Experience FPS Counter.

No, you read it correctly, the frame counter was what was causing it to stop. Load it up with it active (as I have for the past year), it crashes (which is even weirder since I KNOW I had it working with it on before).

Regardless, as soon as it was deactivated, loads right up. I saw a post from like 4 years ago on their forums where someone had a similar problem with Fraps, and deactivating it worked, and I thought to myself “There’s absolutely no way that this would fix it, right?” Tried it anyway and it’s working great again…

Apparently Nvidia basically just implemented Fraps straight up, as far as I can assume, resulting in the same problem… from 4 years ago…


#8

Went through a few races and yeah, just fine.