Dirt Rally Settings 5k+

vr-academy
suggestions

#1

Hi guys, so pretty much THE reason I backed the Pimax hmd was to play dirt rally in VR without a nasty SDE. Now that my headset has arrived I have spent most of the day getting it to work in Dirt Rally (steam version).

System wise, I am running a 980ti GPU at 1500mhz with an i7 5820k at 4400mhz and 16gb of 2666mhz ram. I know the GPU has a dp1.2 and is below minimum spec, but so far seems to run quite a few VR games perfectly which I wasn’t expecting tbh, including project cars 2. Currently I have no touch controllers or base stations as I am waiting on Pimax, so for now I’m using only inbuilt tracking of the Pimax for driving and flight Sims.

For dirt rally I have used Revive 1.6.3 and Steam VR (none beta AFAIK). I fire up pitool V1.0.1.103 beta, disable frame smoothing, enable parallel projection, set 90hz and normal FOV at 1.0 resulution scaling. In steamVR I use 75% resolution scaling. When I fire up dirt rally it will run on very low settings at 90fps. The strange thing is that there is weird and noticeable input lag regarding tracking I think and it’s very off-putting and makes the game pretty unplayable. I have also tried with frame smoothing and it holds fixed at 45fps as I believe it should but feels worse than without smoothing.

I tried Project Cars 2 and don’t experience this same input lag at all and intact the game is much more enjoyable even at lower FPS such as 65-70.

Does anyone know what might be causing dirt rally to feel so strange? I hope I can get it working better.

The strange thing is, when not in VR and just gaming on my monitor, Project Cars 2 is far more resource heavy than Dirt rally. For instance dirt rally maxed out will play at 100-120fps on my Z35p monitor while to reach that sort of FPS in project cars I need to run at medium settings.

Please Let me know if anyone has had some experience optimising settings for Dirt Rally on the Pimax. @SweViver I know you have had success with this game on the Pimax so if you have any pointers it’d be greatly appreciated.

Thanks,

Andy.

!!!UPDATE!!!

Thankyou all for your help. Now since posting my original request I have found what I believe to be the optimum settings for both graphical fidelity and acceptable frame rate on a 1080Ti. It just looks stunning in VR and thanks to Pitools implementation of brain warp on the latest release, the frame rates are reasonable enough. One point I found out when racing at night, especially in wales in the rain, if the in game auto exposure is causing a washed out appearance due to the headlights, simply cycle through the cameras (must include external) before you begin the stage and it will reset the auto exposure to an acceptable level even when in cockpit view! If you can only cycles through internal cameras, make sure “external cameras allowed” is on in game preferences.

All my settings are as below:

Use latest version of Revive & patch + follow usual instructions.

Use this version of SteamVR: https://github.com/LibreVR/Revive/issues/1121

Pitool Settings:
“Render Quality” = 1.0
“Brightness” = Normal
“Hidden Area Mask” = Check
“Turn on Smart Smoothing” = Check (Very important!)
“Compatible with parallel projections” = Check
“Field of View” = Normal
“Refresh Rate” = 72Hz

SteamVR Settings:
“Application Resolution” = 100%

Nvidia Control Panel Settings:
Set all AA to off, except FXAA
Under “Adjust desktop size” tab, select “No Scaling” and apply
“VR prerendered frames” = Application preference

In Game Settings:


Dirt Rally running at 4 fps......help
#2

Apparently going to Steam 1.1.3 works, however, mine works without that on the newest Steam Non-beta (I patched DiRT through Revive and run it through steam, not Pitool). I’m using the beta Pitool, but maybe the next version coming soon (the 18th apparently) will fix things. I’m using 72Hz mode, high brightness, parallel projections, 140 FOV, NO smart smoothing, and I can actually play with low shadows, ground cover, and crowd on ANY stage, including Germany, which I was never able to do before, and I’m on a 1080Ti. 72Hz mode is awesome for a game like this. Also, I’m using Pitool 1.0, and I make the SteamVR resolution per eye at least 3000 horizontal pixels, and below 3100.

Here’s a link to it a link to dl that version: https://github.com/LibreVR/Revive/issues/1121


#3

That’s mate this sounds like it could be the problem I’m having. I will be sure to try this when I’m home tonight and post up the result.


#4

How do you go back to a previous steamvr version…?


#5

Someone linked the files in google drive in the link I provided. Then I guess make sure you don’t have steamvr auto update. Never tried it myself.


#6

ahh where is the link?


#7

The 8th comment in the link explains how to do it. https://github.com/LibreVR/Revive/issues/1121 6


#8

ahh thanksss…


#9

How to launch the SteamVR Version of Dirt Rally from the PiTool??? How to play it with the Pimax 5K+?


#10

@REDxFROG I don’t have luck using PiTool. I use Revive (https://github.com/LibreVR/Revive/releases) and launch from Steam. Make sure “Use Desktop Game Theater while SteamVR is active” is unchecked when you Right-Click DiRT Rally in Steam Libarary --> Properties. When you hit Play in Steam, the game will say “This does not Support VR…” but just click OK anyway. You will launch into a gray sphere with flat menu, then when you start a race you’ll be “in” the car.


#11

Thanks. I had to read a lot in the forums.

I have downloaded Oculus Software and Revive and it works now. But it’s very laggy, I have just tested it a few minutes ago. (and paralell projection also needs to be activated which wasn’t)

Looked unplayable to me.
I dont want to mess around with SteamVR just to get it working without the lag. Damn


#12

@REDxFROG I have my SteamVR Resolution at around 3100 Horizontal. 140 FOV. Smart Smoothing OFF, it was laggy for me to keep it on. Also I’m using 72Hz mode. You’d have to lower SS for 90HZ probably. Make sure to keep Ground cover and Crowd on Low or Off, Shader detail Low, Shadows Low. If you keep seeing issues turn off Ground Cover, Crowd, and Shadows and see if that helps. Sometimes you’ll have to balance things to make it look good/run well. Mirrors off would help too. Anisotropic filtering can stay ultra, seems to help me. I’d lower almost everything else a little bit too like Car Detail, Objects. Also, make sure the Game window is clicked/on top/focused. It will be super laggy if not.


#13

Well for some reason I can’t get the tracking to work right.
I have set everything to lowest possible detail but it’s the same lag with 30fps as with 90fps.
It seems like ReVive itself is laggy. Because that sphere is always lagging behind.


#14

Here’s a fix that helped people, but at this point, it may be worth to wait for the new Pitool version to see if it fixes the issues before messing with Steam. I personally didn’t need to do this fix.


#15

Thanks again @cazman321 I have only just got round to trying the older steamVR and this solved my problem perfectly and it’s an easy quick fix. Now dirt rally works fine with no tracking lag and I have to say it’s an amazing experience even on my 980ti which seems to manage fine on low graphics at 1x resolution in pitool and steamVR. Fingers crossed the new pitool can make it work with the new steam VR but tbh I think itt might be a revive/steamVR problem.


#16

I am running a 2080 Ti and I couldn’t believe how much lag I was getting on the Pimax compared to my Vive or Vive Pro. I was able to get this working smoothly finally after going back to the old steam version. Very annoying but it seems to be working now. Hopefully this is fixed at some point as I would prefer to be on the latest version of SteamVR.

One other thing does anyone know how to get the graphics in Dirt Rally to look better? With the clarity of the Pimax I really notice that the game itself is not rendering Ultra levels in some regards like track details, etc. If I play on the monitor you can see the changes when you go from Low to Ultra but in VR there is no difference between Low or Ultra on certain things like track detail.


#17

There is apparently a bug in the nVidia driver. Assuming you are using an nVidia card, bring up the nVidia Control Panel, switch to the Adjust desktop size and position page, and set the scaling mode to No Scaling. Several people have reported that this fixed their issue with low res details.


#18

Thanks for the tip, Ill try that this weekend to see if it provides an improvement!

Does anyone know if there is a way of running Dirt Rally without Parallel Projection enabled and still maintain the correct view in VR? Just thinking the extra performance would really help, although I have upgraded to a 1080ti which does help a bit.


#19

Just tried playing this with steamvr beta 1.3.6 and pitool 109 and revive 1.6.3. First I thought games are suppose to work without revive. Anyway this game gives me tracking issues. I get grey screen and when I does work chromatic is terrible and only 3dof

Edit just dropped back to stable steamvr and it seems tracking maybe a little bit better but still 3dof and chromatic

Edit. Seems we still have to drop back to old steamvr mentioned above. Chromatic is still there


#20

Does this work with Pitool 111 beta. I did everything else described including the old SVR version and game still crashes back to Steam after the warning?