Do you need Pimax support regarding your SUPEN ticket? I might help you!

support

#41

SUPEN 2842, still waiting for a reply for the last 3 weeks. Pls help!


#42

Im taking care of this, I will message you in a moment, thanks for your patience guys :slight_smile:


#43

We will sort out everything tomorrow morning @Jpmmuc and @PMXskciVR. Sorry for keeping you waiting!


#44

Thanks a lot SweViver


#45

Hello, I’m in need of assistance

My PiTool software updated today and subsequently updated my 8k firmware.
when the progress bar reached 100%, it didn’t progress any further and my headset flashed green, red, blue LED’s

Server issue when I tried to raise a support ticket,

Any ideas?


#46

The firmware updated did not succeed and the r/g/b flash means that the headset is in a special mode, waiting to be flashed. There’s another flash tool that you can use.

Here’s a link… Sjefdeklerk's Pimax Flasher (4k/5k/8k)


#47

Sometimes a reboot fixes this issue as when PiTool starts it just does the firmware again.

Otherwise, use the flashing tool as @neal_white_iii suggests.


#48

Hey @Berno!
Have you tried using the DFU.exe file in folder C:\Program Files\Pimax\Runtime
Just start it, select the file “C:\Program Files\Pimax\Runtime\dfudriver\p2.dfu”
and then click Download firmware. Make sure yoru Pimax is connected before you do this.

Let me know how it goes!


#49

@Martin - Great to see you here and all you are doing for Pimax and it’s early adopters! A while back you did an intro video on the Pimax XR and at that time you said you were planning to also do a full XR review but I never saw that released. Are you still going to do it and if so when? It would be greatly appreciated! In the meantime can you let me know if today you needed to choose between a 5K+, an XR, and an 8K which one would you choose if you were planning on using it for a wide variety of content (both VR games and simulation including both brighter and darker content)? Thanks for your input!


#50

Hi SweViver, DrWilken, Nearl_white_iii (many thanks for your help so far)

To get round the problem as a short term fix I re-installed my original Pitool software before the update started (version ending 119) luckily enough, the headset worked as normal. Having said that, I still have the same problem in the Pitool software once updated automatically tries to install newer firmware. I must have tried this process 10+ times and each fails every time.

I assume if using the flasher tool, this already comes with the latest firmware and I update this before the software?


#52

The firmware comes with PiTool so updating PiTool updates the firmware if there is any new firmware.


#53

Sorry guys for my late response in here, been dealing mainly with DMs and other threads, so I missed out these posts that you made.

@Jerry999 . Yes the full review is in the works of course, but its been a bit halted for a few reasons lately. I promise to get it done soon! As for your second question, the 5K+ is still my favorite headset, but thats probably because Im doing more simulators rather than dark games or movies in VR. It all depends what you play the most. For the wides variety of content, I would definitely go for the 5K+ because of the better SDE and RGB pixel matrix giving slightly better clarity overall :slight_smile:

@Berno I would recommend you to install the latest PiTool 132 or the last Beta 129 and manually apply the Firmware. Its very easy:

  1. Have your Pimax running and active, open up the file called “Dfu.exe” located in the folder “C:\Program Files\Pimax\Runtime”.

  2. Inside of the application, browse to the latest firmware file included in the latest PiTool version. The firmware file is called p2.dfu and its located in “C:\Program Files\Pimax\Runtime\dfudriver”.

  3. Now click “download”. It takes a few seconds until its donw, and it will restart all services afterwards and your Pimax will work as normal again.


#54

Thank-you, Martin, for getting back to me - I look forward to your full review of the XR!


#55

SweViver, I just got a reply saying they will get back to me another 2 weeks passed, still no news, no reply! Pls help.


#56

Hey @PMXskciVR This doesnt sound good. Let me have a look again, and check with Derek!

Thanks


#57

@SweViver Hey could you look into ticket 16,021.
After I sent in my RMA unit it has been complete silence for over a week, and I know they received it at their warehouse on the 21st of June.


#58

@XabbuSwe sure! I will leave a note for Derek now, and we will look at this together first thing tomorrow morning, when the Asia support is up and running, its almost night-time over there now :wink:


#59

Sorry guys, I was busy yesterday finishing up some other assigned tasks during the whole day, so I didnt have time to reply to messages. I will catch up all messages regarding tickets today!


#60

So for over a month now I’ve been trying to RMA my 5k and after an initial response the ticket was closed without notification so I then opened a new ticket over a week ago and still nothing from pimax. @SweViver ive also pm’d you could you please take a look at this?

Old system ticket number 5164

New system ticket numbers 16559 and 16173


#61

Don’t worry, you are not alone. My RMA 5k arrived to Pimax 17 days ago and not a single message from them so far (supen 4927, ticket 16201 & 16221).
Martin tried to help, and I really appreciate it, but unfortunately no one has contacted me after his intervention.
The lack of communication is the biggest problem. If some one from Pimax sent me a message they received my RMA unit and they will solve the claim in 2,3,4 weeks I would be quite happy but only thing I got is silence.