Does not turn on pimax 8k, error 10500, SHIPMENTS OF GUARANTEES IN EUROPE?

issue

#1

Hi. My pimax 8k does not turn on, the led does not get any color or displayed on the screen, I tested different versions of piplay and ports on the PC and remains the same. Pitools gives me an error of 10500 and the one in the windows administrator tells me unknown device on the usb.

Well, verified by the technicians the hardware breakdown, they tell me to send it to China from Spain, the shipment I get for more than € 100 + tax and fees, they tell me they reimburse me 50€ for the shipment, I remember that people commented that there was a warehouse in the UK to receive viewers with problems IN THIS DIRECTION:

80028(B4J)-TH-044
Phoenix Way
Phoenix Park - Longton
Staffordshire
ST3 2JD Stoke-on-trent

I CAN NOT SEND IT TO UK WHAT IS EUROPE?


#2

Have you tried the latest PiTool beta 129?


#3

Can you post your system setup?


#4

yes of course but nothing, the up and doun volume butons work in windows


#5

I7 7700k, rtx 2080, 32 gb ram, yesterday I use it perfect, Yesterday I was using it for about 3 hours trying to configure it, the distortions and deformations gave me problems but today I connect it, the blue logo of Pimax appeared and it went out forever


#6

That doesn’t sound good. Any updates install?
Maybe unplug the headset cable & replug on headset side.

Btw - Welcome back it’s been a long time. Great to see again.


#7

hello, I think it is hardware error


#8

try going back to a previous version of pitools and firmware.
Uninstall Pitools
Deletes the hidden files, the Pimax folder of the path folders
of your pc.
within users: Appdata and LocalRow
and the folder called pitools that is inside the Roaming call

restart and install everything again


#9

Have you tried Diagnose under help tab?


#10

yes not connected usb and DP


#11

Try to restart PiServiceLauncher in Services.


#12

no my friend I need PIMAX support, the HMD never starts


#13

Have you file a support Ticket via the Support Desk? If so post Supen number here @Doman.Chen can likely help.


#14

yes I am wating… ok perfect


#15

I have set all the ports and even probe with a pci-e USB 3.0 controller, also reinstall the pitools version and I have the latest version of the nvidia driver. The viewer does not turn on in any way and recognizes the usb as an unknown device, the firmware tool does not recognize neither hmd, nor firmware or serial number, does not turn on anything at all


#16

Last 2 days, I open HMD and found 10500, I try to reinstall PiTool and I found that Nvidia update the driver. After I install new driver, it still not work.

I don’t know what happen until I change to use USB 2.0 and found that my all USB 3.0 port are dead. Still not sure what happened.


#17

in my case it is independent of where it connects, the viewer does not give any sign of electrical connection, no led or the front or the button even in the firmware application does not recognize anything and gives me an error of unknown usb in the device administrator. All my nvidia and usb drivers are updated


#18

@Doman.Chen , Help our partner with his problem , please.


#19

Yes please help me, I cant do any more for repair it.


#20

I have no answer from the service desk, please attend to my claim I have no possibility to make it work, I need to support @doman.chen. Please help me