Eliminate gyro drift pretty much completley


#19

Have you tried the latest piplay. 2.2.x as it has manual and auto Giro calibration?


#20

I have just tried 2.0.2.33 and the manual calibration works good, although sometimes it finishes calibrating before I’ve done the full up, down, left, right, it ends on either down or left unless I do it really fast. I make sure it’s done all 4 directions before i start a game, no idea if it would work if i don’t.

I also really like the color and layout of the new piplay, and it’s a lot easier to find my steam vr games in piplay than it is in steam now, which is nice, as it has a much more user freindly grid of images rather than steams long vertical list. A nice bonus.


#21

glad you like it… i suspect that as this version of piplay has auto giro calibration it would still work even if it has not finished its manual calibration. dont forget to make sure you set the face forward when in steamvr display mirror as well :slight_smile:


#22

Unfortunately calibration in Piplay 2.x keeps failing on me. I’ve reverted back to 1.2.98 as the brightness option is not yet bright enough. So, here is how I manage yaw tracking drift, seeing that .98 does not have calibration and I found calibration to be a bit of a hit or miss affair. :poop:

  • Start piplay and set the blue option and brightness settings as per your preference using the debug tool.
  • Start SteamVR with the mirrored display and center the unit using the Z key.
  • Run room setup in SteamVR

Since I started doing this, tracking drift is at an absolute minimum.


#23

Serious am i so s tupid that i don’t understand how to calibrate this thing? I look up and down and leftand right 50x and all failed

@Pimax-Support @doman @bacon


#24

If mem serves i think it might have been @Enopho who might have posted a good how to.


#25

Hi there,

assuming you are using steamvr games, then make sure that you are on the latest Beta piplay and have steamvr beta installed.

launch steam and click on the steamvr icon (top right of steam page)
when it opens click on the drop down on the steamvr popup and choose Display Mirror
when the display mirror window pops up click into this window and make sure that the HMD is facing forward and then press Z - this will tell steamvr which way forward is when running steam games.
next you can close the display mirror window and from within steam click the game you want to play and then choose play in vr.
let it start and the giro should not drift when in game.

unfortunately you should do this every time you start a steamvr game.

hope this helps.

Eno


Pimax 4k, steam vr - big gray box
#26

on very rare occasions (it has only happened to me on 2 occasions) the giro was still drifting on me after doing the above. running the manual giro calibration did not work for me, but rebooting did.

forgot to mention that in my last post…

Eno


#27

thx mate. REbooting what? thepc or steamvr or pimax?


#28

on the rare occasions the setting steamvr’s display mirror to center did not work (and like i said it has only ever happened to me twice!) and usually after an nvidia update which messes my eye infinity settings rebooting of the pc fixes it for me.


#29

Hi Cams86, i would be happy to talk you through it if you need… i used to hate the drift on the Pimax 4K until it stabilized. but if you can follow my instructions above properly im sure it will help.

if you dont understand them or if you cant follow them, dont worry… and dont feel you need to hide it… just tell me and i will give pictures :slight_smile: there are no silly questions here.


#30

ok thought i would screenshot the procedure…

1st off… Make sure you have Latest SteamVR Beta and Piplay Beta.

  1. click on the steamvr icon at the top right of steams main window as shown below with yellow highlighter

  2. click on the drop down on the steamvr’s popup and choose Display Mirror

  3. this will open a mirror of what is showing in your Headset. make sure the headset is pointing forward, as you can see in my screenshot below mine is not forward.

  4. (i dont have the steamvr home turned on just the black room) next you need to click into that display mirror window and press Z while looking forward so the headset position is now forward as shown below.

  5. now you can close the display mirror window and go back to steam, and launch your game!

Do not try calibrating giro while the game is running… if for whatever reason you do this in the wrong order, reboot the pc and then run through it again… you should not have to re-run room setup in steamvr, just have to set the forward facing position. Note that this works for seated positions i have not really tried it on standing positions
Finally as mentioned earlier if for whatever reason the drift is still bugging you, restart your computer and run through it again.

hope this helps you guys.

Eno


#31

Thanks @Heliosurge @Enopho

@Cams86 Which Piplay version you used? have you calibrated the gyro same as below:


#32

yes i tried this but i think im doing something wrong, i done it already 6x.

And it keeps failing and my neck start hurting hehe.


#33

Thank you very much, wow i gave up on drift problems completely i didnt know they fixed it.
This is really nice , eventually pimax seem to do fix those things that bugs us if it is in their capacity.
SO happy i bought 4k lol as first headset

Looking forwardto 8k with no ghosting xD and fov


#34

So I take it this has fixed your drift problem now?

Eno


#35

well i didnt calibrate magnetism manually because i s till fail at that.

But yesterday i did update my pimax drivers from 1.2.57 to 2.0.4.42.
Didn’t played anything after install, i just tried the magnetism calibration but failed so i posted on forum.
Hower i did follow your advice and used Z in steamvr and then launched. And as far as i can tell it dont have to press center every 1min, now maybe once in 7min or something. But its very little drift as far i can tell, very happy with this progress.

I also updated nvidia drivers to latest, both seem to work flawless , previouslyi had problems with not able to recognize hmd or not giving screen only black screen in steamvr etc.

So thanks, i was already happy with 4k now im very happy. Maybe i wont sell my 4k after all when i get my 8k.


#36

good to hear Cams86. to help improve your render a bit more… open steamvr and reduce Super Sampling to 1.0 in steamvr settings, you may also be able to reduce the graphics settings in game as well… then use the piplay render slider in the piplay app - depending on your graphics card and gaming system. move it to the right, then test your game and make sure that it is smooth gameplay… if it is try moving the slider further right until you get a little stutter, then move it back down 1 notch. should help with FPS and render quality as you dont have to rely on steams render anymore.

Eno.


#37

any reason why i should prefer pimax render above steam rendeR?

steamvr render goes to 5.0 maxc and pimax render to 3


#38

you have upgraded the piplay to the latest version so piplay now uses Pimax’s own renderer and no longer uses steam renderer, so having steams one turned on is just adding lots of strain to the GPU but actually does nothing to the game