Elite Dangerous on 5k+

issue

#1

Hey everyone!

I went back into Elite Dangerous on my Pimax 5k+ and boy does it look amazing with a wider FOV.
I was getting 60fps at a dock and 90fps when in space, but I was only in it for 5-10 minutes rebinding all my controls for now.
Can anyone recommend some settings so that I can push the graphics while still keeping a stable 90fps? I know in the space ports/docks, I’ll always have dips, but in general, I want to make it look as good as possible without overdoing it.
Currently I have PiTool 1.0, SteamVR SS at 80%
What other settings should I change in-game or in Nvidia CP maybe?

PC Specs: 8700k @ 4.8, RTX 2080Ti Fe, 32gb ram, and M2 SSD.

Thanks fellow pimaxers!


#2

Hi Michael, I’m hoping to receive my pimax 5k BE preorder soon. This will be among first games I goto. Just wondering if you think the 32gb ram gives any advantage in pimax over 16gb?


#3

i’ve never seen usage go over 13-14gb


#4

Take a look at: Elite Dangerous Setup Guide - Lets make it Dark Again :)

It recommends a mod that removes the fog / haze shader, and like all games, ambient occlusion looks nice but has a heavy hit on performance, you may want to try with it off.


#5

I did a search and found that as well. I’ll follow some of the tips there and see how much better it looks later on. Thanks !