Enjoy DSR UpTo 5K 60Hz~!


#61


#62

This is something simple, it is virtual resolution (somekind of DSR I think not sure), I put a link to share how it works. Now, the quality you gain when you made this custom resolution eg 3840x2160 (4K) is amazing, Try it yourself. And to be clear I wrotte “It is like Pimax 4K actually supports native 4K”.


#63

Does it work on older FW’s too ? I analyzed v248 and I’m 100% sure that one doesn’t support 4k mode. If you feel it works on v248 then it’s 100% not correct. I reversed engineered the firmware and it only supports 2 resolutions, 1080p and 1440p.

It’s possible that they added 4k support in the v265 firmware though… I see if I can try to replicate what you did.


#64

I actually upgraded from Piplay 1.1.92 to 1.2.93 (lasted FW too) and then to 1.2.95.


#65

Can you tell me which steps you made in the Nvidia control panel to achieve this ?


#66

Follow these instruction :

http://www.nvidia.com/object/custom_resolutions.html

Please consider:

  • When making new custom resolution, select Pimax 4K (not monitor)
  • Disable DSR (nvidia 3d propierties) prior making custom resolution.
  • When you finish your custom resolution NEVER TURN ON DSR, it always has to be DISABLE.
  • Piplay 1.2.95
  • Pimax 4K serial 100…

Feed back :slight_smile:


#67

It’s a bit different on my PC, maybe you don’t have win10 ?

anyway what I do:

*right click desktop, select ‘nvidia control panel’

  • 3d settings/manage 3d settings make sure DSR factors and DSR smoothness are both off
  • display/change resolution. Select the "Sensic Inc Pimax’. Then click ‘customize’
  • Click create resolution.

Now I have to select horizontal pixels, vertical pixels, refresh rate. Which exactly did you choose ? And scan type remains progressive I assume ?


#68

Hmm I tried 3840 * 2160 @ 23 hz, doesnt work here. Or did you manual supply timing settings ?


#69

Did you add custom resolution in Windows and disabled DSR in drivers?


#70

? grzvs doesnt speak about that. He is talking about DSR in the control panel. See my post above regarding that. And I’m not sure what you mean with ‘add custom resolution in windows’ ? The whole point is that you do it in nvidia right ?


#71

Doesn’t seem to work here, I get ‘test failed’ all the time in the nvidia control panel when I test the new custom resolution.


#72

Sorry for delay…working …
All your steps are right.

horizontal pixels 3840 vertical pixels 2160 then leave the rest in default . Then TEST and then it will ask for add resolution and put yes (of course). Close nvidia control panel and go to windows resolution and there you will see the new resolution under Pimax 4K (in extended mode, video mode piplay)Then apply it. I have not try this in Pimax mode.


#73

I never pass the test. Which refresh rates did you choose ? And what happens if you choose something that obviously shouldn’t work like 5k resolution ?


#74

more than 4K does not work. Right now I am on my working laptop, when I get home I will send you pics (step by step) of what I had done with my desktop and Pimax 4K. Specs Windows 7 Pro (64bit).


#75

What OS are you on ? EDIT ah ok win7…

Hmm… and refresh rate ? Which one did you select ? I think this could only work with 23 hz ?


#76

Any progress :slight_smile: ? Tnx!


#77

Hi Bro, sorry for delay.
My specs: Win 7 Pro (64bit), GTX 980ti, CPU i5 2500, 8 gig Ram, Monitor Res 1920x1080. Piplay 1.2.95 FW 265

Let´s start.

1- Pimax 4K on, Piplay video mode.

http://imgur.com/4TJ08U2

2- Right Click; Nvidia control panel; 3D settings; Disable Nvidia DSR

http://imgur.com/ldZEszh

3- Nvidia control panel; change resolution; Customize.

http://imgur.com/Vkj06OC

4- Add custom resolution.

http://imgur.com/BqPKfsZ

5- Add custom resolution TAB with default resolution.

http://imgur.com/pkUUuJi

6- Change; horizontal pixels 3840, vertical pixels 2160. Leave all other settings as you see in pic.

http://imgur.com/eC254Uh

7- Press Test and save the new custom resolution.

http://imgur.com/9EWjz6J

8- Now in custom TAB, you should see the new custom resolution added. Close nvidia control panel…

http://imgur.com/fivypuq

9- Go to windows resolution panel, and you should see the new resolution (3840x2160) added. Select and apply it.

http://imgur.com/0hE1wAG

10- Custom resolution applied it.

http://imgur.com/CFWivmu

11- Also added 5K resolution but did not work.

http://imgur.com/MdYU10U

Please consider

  • All the uploaded pics are actually print screen shots. So pics resolutions are monitor (1920x1080) plus Pimax 4K resolution.

  • I tried this method with my playing laptop that has GTX 880M 8 gig (Kepler)and did not work.

  • I have not tried it in Pimax mode.

  • Please feed back.


#78

In windows 10 it’s slightly different but I tried the same thing. It failed though.

I’m pretty sure though that you’re not running at 4k@60hz, because that’s impossible uncompressed via HDMI 1.4. The only way to get that going is via DSC compression. Nvidia does support that over Displayport but not over HDMI.

So the resolution you’ve selected is just impossible. I’m not sure why it’s telling you that it succeeded. But it can’t be 4k@60 hz. So, something is definitely wrong at your end.


#79

Well, I am really happy with this failure or whatever it is :sweat_smile: , because as I said; with my gaming laptop I could not do it. We need more feedback @mobile-technology @crony


#80

Hehe I really want to believe you that you have 4k@60 hz but man … I just don’t see how. It’s a fact that HDMI 1.4 can’t do it without compression. Most logical explanation would be that you think it’s 4k but it’s only 1440p, I don’t have any other explanation …