Firmware 1.0.0.265 for Pimax 4K

orders
events
fix-guide
review

#1

Is there any firmware 1.0.0.265 for P4K anywhere? (.dfu)
I can’t update online.


#2

I don’t recall the last p4k firmware update save aa far as I know was like star wars a long time ago.

@Enopho likely knows last new firmware version.

As far I know. I think 248 is the newest version. This older hlp topic says 248.


#3

I have now 1.0.0.251
But I know for sure that there is 1.0.0.256.

The owner of P4K with this firmware says that ghosting has become less like.

More precisely, firmware 1.0.0.265


#4

@Doman.Chen can we have a link for latest p4k fiemware please?


#5

#6

Wow, thanks! :clap: :grinning: :gift:
I tried to find by number, but for some reason the search was not found.


#7

Awesome CMM! :beers::sunglasses::+1::sparkles:


#8

I’ve been using PiPlay 3.0.0.85 for some time without any real issues, but for some reason I can no longer get the Home, Games and Video screens to work and I just get a timeout unable to connect message. However the Library still works as it should.
Any ideas? Anyone have similar issues?
Thanks.
Regards,
Luke


#9

Just saw Helio’s ping for me.

I cannot tell you what the latest firmware is, as i have tried newer versions of pitool above 1.0.1.95 (using firmware 1.0.0.265) and they did not work so well with the 4k… things like bad distortions, lower fps, and some stutter… so i stuck with those versions as they seem to work best

Eno


#10

ERR_NETWORK_ACCESS_DENIED is what happens on my side.

Looks like the server is down.


#11

Haven’t tried piplay inna long time for video content. It’s possible pimax might have the server down as Cmm said. @Dallas.Hao @doman.chen?


#12

Yeah it looks like 265 is still the last firmware version.


#13

I haven’t seen that message?
I been getting ERROR_CONNECTION_TIMEDOUT.???

Does look like server issues.
Not that it affects me much. Just not a good look.
It’s been like that for some time now.
Thanks guys.
Cheers, Luke


#14

Yep. That’s what I have as well.


#15

I can put that particular piplay version on my Dropbox if it helps? I have all of the installers on my Nas.

Eno