Firmware Trouble!


#16

I had FW Version 1.0.0.0180EN, then, with a new Piplay the FW Changes back to 1.0.0.171CN VErsion.
An Engineer from Pimax told me thats normal, cause they want to work with only one FW Version.
There was no way for me to switch to another FW Version too. Looks for me as Pimax i struggling with many Problems,
The Drivers and Firmware seems more Alpha than Beta.
I Fear we all have a Nice Paperweight now !


#17

Dear Pimax,

I have installed software but my laptop cannot detect the Pimax VR goggles at all.
Can you help with this problem please?

Specs of my laptop are –

OS - Windows 10 Home 64 bit operating system
Processor – Intel i7 – 6700HQ CPU @ 2.6ghz
Ram - 16GB
Graphics card - NVIDIA GeForce GTX 1060
Driver version 372.70

Regards Ross


#18

Do You have a Onboard Graphic Card? You have to deactivate it in BIOS.
If there is no Option for this i have no Idea and Support will have no Idea also! But i think this is what Support will tell you!

I have a Laptop with Nvodoa and Intel Graphics, the Intel could not be deactivatet so i have no chance to run the PimaxVR.

On my DEsktop the PimaxVR was first detected right when i deactivatet te Onbaord Graphics Option on my AsRock Mainboard!

Hopefully you got a Desktop PC too!


#19

Hell, where is the Edit Option, i wanted to correct misspelling!


#20

That's odd, seems to be working now.


#21

Today I uninstall piplay, reinstall latest nvidia drv 372.90, and magicali im back on extend mode with picture in HMD. But I still need fw 1.0.0.180 to use steamvr on 10series nvidia card. Im stuck on fw 1.0.0.171 and no response from pimax, nor gearbest.


link to piplay 1.1.70 is not working, i want try it, if somebody have it


i need this file: international_1.0.0.180.dfu, how to download?
C:\Windows\piserver\pimax\piDfu\DfuSeCommand.exe - looks like fw updater (for stm microcontoler?)

Led on HMD:
red - no HDMI
green - waiting
blue - working


#22

Hi,

i cant give you personal message. If you can give me your email or skype i try to sent you FW and Update tool this evening. It was given to me by an engineer from Pimax. I think on 17:00h UTC (Coordinated Universal Time) i can sent you!


#23

Agein i tried to edit my Post, i cant cause the option is not available! Why?


Firmware hacking / custom modding
#24

Finnaly back on 1.0.0.180:
download fw: http://forum.pimaxvr.com/uploads/download/international_1.0.0.180.dfu
put HMD in dfu mode:
1) disconnect
2) press all 3 btn (up vol/down vol/pwr)
3) plug usb -> white led
4) release pwr btn
5) release down vol btn
6) release up vol btn

When in DFU mode:
C:\Windows\piserver\pimax\piDfu>DfuSeCommand.exe 0 international_1.0.0.180.dfu


Pimax does not work Preparing RMA to Gear best
#25

Thats another Option :slight_smile: !


#26

HMD from gearbest, i dont try it on china ver, just update from FW 1.0.0.171.
pimax mode now work with steamvr. In piplay reporting fw 1.0.0.180
Looking for next fw... manual dioptia, better IPD, stable gyro,...

C:\Windows\piserver\pimax\piDfu>DfuSeCommand.exe 0 international_1.0.0.180.dfu
1 Device(s) found :
Device [1]: STM Device in DFU Mode, having [2] alternate targets
Target 00: Upgrading - Download Phase (100)...Duration: 00:00:06
Upgrade successful !
Name : Internal Flash
return OK


#27

usb reporting like oculus DK2: VID_2833&PID_0021


#28

Sorry, missed your post. But interesting in fw and update tool. Please send me to peter.sk.hw@gmail.com, thx


#29

Sent you a mail a couple of minutes ago, it was blocked and returned. Was a rar file!


#30

Hey Tomkin, are you german ? Can you give me some informations about the pimax 4k VR ?


#31

Give me your email, write to you in german some things!


#32

@Tomkin : ******** :slight_smile:


#33

Thanks a lot for your manual. I had exactly the same problem. After update to 1.0.0.171 (cn) just extend mode was working. Now when I have 1.0.0.180, version changed to (us). I'm still not able to get DirectMode, but at least Pimax mode is working with OCPlugin + DirectModeOnly tools. It is enough to make SteamVR running..


#34

The instructions for getting the Pimax 4K into firmware update mode posted in this thread are a bit incomplete in my opinion. Once you've connected the USB cable with all three buttons depressed, you then need to release each button in the specified order, but slowly. For example: release the power button, wait a while, release the vol down button, wait a while, release the volume up button. If you release each button too quickly, even in the correct order, you'll just end up with a green LED and no connection suitable for firmware upload.

Perhaps not everyone will encounter this problem, but I'm sure that some will.

By the way, getting back to 1.0.0.180 was the only thing that got SteamVR working for me too (I had downloaded the Chinese software version because the English link was broken, and it automatically flashed a different firmware -- hopefully it wont try to do that again).


#35

Please send me to nikishilowrur@gmail.com, thank you.