Flashing Red/Green LED


#1

Hi, my headset stopped working, its LED started flashing red and green.

I’ve read other threads on this issue and tried many possible fixes, but no luck.

Things I’ve tried:

  • Leaving it unplugged overnight, and then replugging it.

  • Holding all three buttons and then releasing them one by one to reset the firmware. (Yes, I did get it to flash white light.)

  • Using the upgrade tool. (Ran it with admin permission and with all Pimax services stopped, but still got this error)

    To fix that error, I’ve tried updating/repairing/reinstalling Microsoft .Net Framework and Microsoft Visual C++. No luck.

It seems like every “solved thread” had to contact support team and use TeamViewer…why can’t Pimax just put out a fix instead of wasting people’s time having to go through all this. I’ve sent my TeamViewer ID and password to the support team 4 days ago, and still no reponse.

Any help would be appreciated, thanks.

@PM_Sean


#2

@sjefdeklerk might be able to help resolve this he made his own flash tool and reset firmware.

I added a poke to Sean. I think @Pimax-Support might be away atm.


#3

Thanks for the quick reply. I’ve tried his tool, but ultimately runs into the same error.

At first I get this…

Then I used the .dll from another tool and the same error…


#4

Hi I had same issue yesterday - trying to clean my display ended with red/green error… :slight_smile:
Trying all tutorials made to exact same point as you [ tried 2 PC`s ].

The problem 0xc000007b [ after solving first error with missing stdfu.dll you probably had -> coping from /oculus/runtime this file is not a fix ! ] is caused by too new version of PiPlay as you definitelly have 2.x, or even 3.x, but @sjefdeklerk made his tool last year, I suppose around V.2017 and since that time Pimax also changed their DLL`s libraries.

All you need is:

  1. FIRST downgrade to 1.2.x [ flash tool will work ! ]
  2. put into DFU mode [ 1) unplug Pimax usb/hdmi, push and hold 3 buttons, plug USB only, wait 8s, release power holding other two for 8s, then release middle, wait 8s, and release last one - clicking it, or option 2) click enter DFU mode in App ]
  3. upgrade FW
  4. have fun with Pimax [ not asking @support without TeamViewer13 session required, they have a lot of work on 8K trying to hold the promised Q2 shipment :slight_smile: ]
    Best regards !

#5

Thanks! The firmware flashing tool is now working, and I downgraded my firmware from 1.0.0.265 to 1.0.251. Now the LED is just green, but the PiPlay software doesn’t recognize it. At least, it’s some progress :confused:


Pimax Support Rating
#6

OK, great ! :slight_smile: Have you tried hacked firmware 1.0.0.248_anti_TakeApart.dfu - 75 KB [ @sjefdeklerk ]
You can download from here: Led flash red and green only
I used it [ as recommended ] and PiPlay recognised device without any problem and my P4K works.


Pimax Support Rating
#7

Yeah, I’ve tried it. Same result. What do you do after flashing it? Do you run PiPlay 1.2.X? or do you uninstall it and run the latest version of PiPlay? My monitor flickers every couple seconds as if a new display is constantly re-plugging itself lol I think my Pimax 4k is stuck in extended mode…I see a third monitor (dual monitor setup) in display settings. Is there a way to force it into Pimax mode?


Pimax Support Rating
#8

After I made the upgrade procedure [ ended with success status - using @sjefdeklerk tool in administrator mode on W10x64OS ] flashing R-G ended, device in normal mode and I could see my desktop in Pimax lenses, like working in extended mode - but as I felt better as HMD worked - installed the latest 2.x version; so maybe try this and make couple of Windows restarts, plus try to unplug-plug. In worst case scenario your HMD may have some HW issue, that cannot be fixed by FW upgrade…


Pimax Support Rating
#9

I opened the device and made it flash green/red again, then I uninstalled PiPlay v1.2.97 immediately without running it, and installed v2.0.7.54. The LED on the headset is now blue and this is what I see :smiley: (After switching to Pimax Mode)

Now, when I cover the proximity sensor on the headset, the display turns on and shows the Pimax logo.

I ran some Steam games and…THE HEADSET IS FREAKIN WORKING!!! (Even though the serial number isn’t showing correctly.)

MAN, I have to stress this important step again…DON’T RUN PIPLAY V1.X AFTER UP/DOWNGRADING THE FIRMWARE! IT WILL AUTOMATICALLY UPDATE THE FIRMWARE WHEN YOU RUN IT. UNINSTALL V1.X AND GET THE LATEST VERSION (In my case it’s v2.0.7.54).

6 days in, still no response from the support. Can’t imagine someone less technical go through this. Anyway, hope this thread helps any future readers.

EDIT: I updated the firmware through PiPlay v2.0.7.54 and everything is showing correctly now. :slight_smile:


#10

There seems to be a problem with support email. The team has been messaged & hopefully fixed tonight.


#12

To fix the serial you may need to do what @pho3nix described. If you have a 2nd pc can make it less painful.

If there not getting the mail hard to respond. Plus try getting a response from EA’s Origin. Never got a response for a non working purchase but a year later it magically worked.


Pimax Support Rating
#13

Read my edit, i already fixed it…


#14

Cool didn’t see your edit lol


#16

Well as much as i try to read all. Its not easy. Putting @Heliosurge works. & there is probably at least 10 threads on fixing the red green flashing.

I did hope the team had fixed up their flasher tool to work with current piplay version.

It is likely you missed a step & didn’t use sj’s reset firmware; nowhere did pho3nix. Its not downgrading its a special firmware hack to reset the intrusion routine.

@PM_Sean is also a good resource. He might be able to get the team to fix up their flashing tool.

Plus also poked 2 ppl during your initial trouble. @pho3nix found a solution & posted it tho somewhat a hassle.


Pimax Support Rating
#17

Yeah, and I’ve read many of them. Most people are getting the 0xc000007b or the missing .dll error.

There should be a Q&A section for each “LED light situation”, or a pinned post for the official solution. Instead of having people post 10 different topics about it, this way it saves time for everyone.

The team should also include the flashing tool in the latest PiPlay v3.X debugging doctor or w.e it’s called, when it’s made.

There are also a lot of people with the “stuck in green” LED problem. So this thread might help too.


#18

Stuck in green with no pic is likely the Amd gpu driver issue. Simple install of previous version & nothing too recent that the individual hasn’t responded back yet.

The missing dll is related to the piplay structure being changed considerably & the official flasher tool & @sjefdeklerk need some kind of update to work.


#19

Well I had the stuck in green problem after flashing it and running PiPlay v1.X. I’ve mentioned twice already, the fix is not the downgrading firmware. The fix is DON’T RUN PiPlay v1.x afterwards, instead, UNINSTALL IT. And get the latest version and run that.

Yes, I know what caused the dll and 0xc000007b problem. I ran into both of them myself, and fixed it.

EDIT Just because I emailed them on the weekend doesn’t mean they get to 6 extra days to respond, especially when they are based in asia, meaning they are one day ahead of us. Also, no one is forcing you to volunteer here. If you can’t handle your personal job and this then quit, don’t give useless solutions and then blame it on how you dont get paid.

EDITED TO REMOVE INAPPROPRIATE CONTENT! PLEASE READ OVER FORUM RULES. Mail server for pimax support personel was experiencing issues. Resulting in your mail not being received. Moderator job complete.


#20

Well I am not paid by pimax. So tone it down. Plus you posted for support on a weekend of which they are out of the office.

So you need to realise & respect community & pimax team when asking for support.

I am also posting while at work during non break hours which could affect my income.

And there are users running the latest firmware on 1.1.92 so it is likely the newer piplay didn’t fully uninstall.

Edit only posted that I am not paid by pimax due to thinking i am. I think you will find the community is less helpful to those who choose to act poorly. Btw i didn’t post the solution only added pokes to help get you support. Enjoy waiting next time. But thank you for requesting me to moderate; since I am a moderator & not tech support. :beers::sunglasses::+1::sparkles:


#21

And for your information 2 days (after you posted in the forum) to have an issue corrected is very acceptable. Next time post in the forum & send support an email.

Now congrats on getting your headset up & running as either your setup is different thsn @pho3nix or there was a disconnect in understanding the steps he presented. He never said to use any firmware except sj’s Take apart reset firmware.


#22