HDMI/DP not connected due to piplay software issue


#1

if in PIMAX mode and Pimax is deactivated via power button, then a failure “HDMI/DP disconnected” occurs. (Win 7 ultimate, AMD RX580, Driver 17.9.1 due to DX9 issues of newer drivers)
Pimax software obviously stores the status based on user profile and no easy Kind of reset is possible, except reinstallation. I tried complete shutdown, and power off, pushing the power button serveral times with no effort.
I think it may possibly be a PIMAX software issue because I can Switch windows user, start PIMAX and with the other user no error occurs. So it seems to be a user profile defined error of PIMAX.
Also a strange effect is, I can view Videos with PIMAX despite this HDMI error shown. Obviously HDMI runs.
Please advise how to reset this error.


#2

Welcome to the pimax forums I have bumped your user level up 1 for your convienance.

Pimax needs to be connected to a native hdmi port. Display port 2 hdmi will cause conflict.

If you can post your system specs
Cpu/Ram

If you have internal gpu it will need to be disabled in the bios.

I would reccommend putting a support ticket on their main site in case we have difficulty helping you resolve this issue. @Pimax-Support has a great tool using Skype with Teamviewer if needed.

Here is a getting started guide that might help.

[P4HLP] Getting Started


#3

Thank You for quick reply.
there is no internal gpu, and I use native hdmi without displayport adapters (Both of them with same effect)
System is AMD FX-9590 on ASUS M5A99X EVO R2 with 32 GB Ram, Graphic Card ASUS STRIX RX580.
I now had the computer some minutes complete down, without power, then after reboot, no error ocurs with original used profile.
But I can repeat this effect when in PIMAX mode (current software version 3.0.0.81)
Start Piplay application, power of PIMAX VR with button, close Piplay, then start PIMAX VR again. If you try to start Piplay, the error occurs with HDMI disconnected message.
I disconnected then HDMI plug and connected again (Hardware recognition starts with a flicker of Monitor) and started Piplay again. Now the error is gone.
Why do i need to disconnect HDMI physically?
This is a piplay related issue and should be solved.


#4

Your welcome. Please uninstall piplay & download piplay 2.0.7 (one just before v3.x) it has less ghostings & recently users did experience issues with the version you have installed.

Here is a link for your convienance

Also if you have a spare hd. Download windows 10 iso. I have read you mighr be able to use your win7 product key on windows 10.


#5

Thank You for quick reply again.
I had this issue even with the older mentioned version, too, so this does not help.
I did not mention the ghosting issue, so perhaps Your answer is for an other thread.
I would appreciate if PIMAX fixes the software issues. I will not use Win 10, this is no solution.


#6

I understand your position on W10. While I use it. It is only used for gaming. I use Linux for pretty much everything else due to security & stability.

I do look forward to the day when Linux has full support of games. It’s coming but still not there yet.

Have you put a support ticket in? As may need teamviewer session with @Pimax-Support. The support ticket will help notify them of an issue quicker.

Its quite possible there is software conflicting. If your monitor & headset both using native hdmi? If so try connecting your monitor to a dp2hdmi adapter. Display Port uses its own Pathways. Where as the 2 hdmi ports might be causing a conflict.

Not running windows 7 or could test.


#7

I have the very same problem. HDMI is recognized by the Computer,. It states USB Connected and HDMI/DP connected. But no PIMAX view possible, only default monitorview. The VR-set is treated like standard monitor.


#8

Have you put a support ticket in? & can you post your specs. Are you running Win7 or 10?


#9

no I have no ticket. Configuration below. When I first started the Pimax it worked ok. I had the PIMAX view. Then I changed to a movie view and there it got stuck Piplay simply does not recognize the VR-set.
The set itself works ok, as I tried it on another computer.
Oculus works fine on this computer.


Though connected, PiPlay doesn't display it
#10

Well put a support ticket in on their website

In the meantime please post your config & perhaps @Community might be able to troubleshoot this issue with you.

Please post
Windows 7 or 10
Cpu/Ram
Gpu/Driver version
Piplay version

Thanks


#11

If you’ve installed newest piplay 3.0.x

Download & install 2.0.7.54


#12

The configuration was posted in above attachement.
piplay 2.0.7.54 does not work either.

I also tried above suggestions.
I also tried older Nvidia drivers.
If it had not worked in the first place, I would think its a hardware problem with my computer, but it had worked.
And as I said before the VR-set also works.


#13

again: This is what PiPlay tells me: Everything connected but no PIMAX-Connection.


#14

What color is the headset led


#15

Because I have the same behaviour, forgive me to answer here. Mine is green


#16

If your on amd install previous gpu driver. Also please put in a support ticket as you may need skype with Teamviewer session. The team should be back in the office tuesday.

@Pimax-Support @PM_Sean.

Here is a link green indicates hdmi connection issue. Plz post your system specs.


#17

What you are telling me is not very helpful, I posted my spec already in my first mail. it is the attached file. Are you not seeing this?I will post it here again it is a copy from Dr.Pi.


#18

You still haven’t posted your Gpu driver version.

The Team should be back sometime Tursday. They will likely need to setup a Teamviewer session.

Do you havr a second pc you can test the headset on? & if it was working before do you know what was installed before it stopped working?

The only thing I can suggest is to try & reset the firmware.

My post above yours is to Kalyi.


#19

I tested the unit on 2 other PCs. There it worked ok, same Nvidia driver(latest).
How do I reset the firmware of the VR-unit.
Maybe this works.


#20

With the headset working on another pc. The firmware is good.

Try the headset with only it, keyboard & mouse connected. (Might have a conflict with another device)

If it still doesn’t work. Exit piplay completely. Summon the Taskmanager & kilk any instance of piplay & pi servers.

Install piplay again & test.