Help! Controllers and LH not connected

pitool

#1

Hello,

I’m new to the Pimax 5k+, coming from an Oculus Rift. I purchased a new Lighthouse 1.0 and two vive controllers and got my 5K+ today. The headset is working ok, but for some reason, the PiTool reports “Disconnected” for the two Vive controllers, and the LH. I understand that the headset itself contains the hardware to sync with the vive controllers, so no additional vive hardware is needed.

The LH is in A mode and sitting on my desk with a green light.

The two vive controllers are fully charged and power on, but they do not appear in PiTool or Steam. I’ve tried most of the items on the forums, and I’ve spent the last 4 hours online trying to find a solution. Nothing has moved the needle yet.

Some suggested removing the Lighthouse folder in Steam, but I don’t have that folder.

I also DO NOT have a “Pair Controllers” button in PiTool that most of you have, so I’m not sure why this is missing.

The headsetup has the latest firmware and PITool was download today from Pimax, so it’s up to date as well.

I’ve tried removing the PiTool and reinstalling, still nothing.

Another forum was talking about modifying the config file in Steam to include:
Add "activateMultipleDrivers": true, "requireHmd" : false,

Did this too and no good results.

I even called Pimax today, and the gal on the phone was very nice, but she said she was not at her computer so she couldn’t help me at the moment. She was telling me to press the Pair Controller button in the PiTool, but I don’t have that button, and then she was lost about what to do next and said she would send me some setup/getting started videos to help with the setup. Watched the videos, and nothing related to this problem was found.

Has anyone else run into this and did you find a solution?

Looking forward to trying the headset, but so far all I’ve seen is the home screen. :frowning:

Another new Pimax customer who is frustrated that this doesn’t work out of the box.

Thank you in advance for any assistance!

Cheers,
David


#2

Hi, For a single LH, I’ve seen suggestions that it might not get detected if you’re close to it (under 2m) typical of desk setup rather than corner of room mounting.

Try moving away from the lighthouse, approx 2m if you can and see it picks it up, then you should be fine to move back.

Once detected you should be free to then sync the controllers (if the option appears?).


#3

Also try using the “Restart Service” button after pressing the diagnose link on the status tab of PiTool.


#4

Hi,
I see that you dont have the pair controller button.
Did you check the “use lighthouse tracking” in the headset settings of pitool ? What version are you using ?

Regards


#5

Thank you all so far for the replies and assistance.

Spamenigma – Thank you, I tried several different distances: close, medium and far and SteamVR doesn’t show either the LH or the two vive controllers in any position.

DrWilken – Thank you. I’ve tried the Restart Service button about six times, and still no LH or vive controllers showing up. I’ve tried rebooting many different ways, sometimes with the HMD off, and other times when it’s on during reboot. Still no controllers. I don’t see a Diagnose link on the status tab in Pitools.

The only options on the status screen:

Start SteamVR – Button
Room Setup – Button

A picture of the Pimax 5k plus and below all this is a box containing the list of controllers. Two vive controllers show “disconnected”, and two LH images show “disconnected”. SteamVR only shows the headset and an Xbox controller that I installed.

If I go into SteamVR, setup, Devices, Pair Controller; it takes me to a screen that says Initializing, looking for your VR hardware. It won’t go past this screen. It seems like Steam doesn’t recognize the headset.

TheMalkavien: Thanks for the suggestion. I have “Turn on Lighthouse tracking”: checked. Tried unchecking and checking several times, no changes.

Current PiTool Version: V1.0.1.132
HMD Firmware: V2.1.255.212
SteamVR: 1.6.10


#6

Have you tried this ?


#7

I believe I have. This looks like the next screen in Steam that I cannot get to. Is this in: SteamVR, setup, Devices, Pair Controller? It takes me to a screen that says Initializing, looking for your VR hardware. It won’t go past this screen.

Here is what my Status screen looks like:


#8

Just a quick update,

Yesterday I was advised to download the .180 beta Pitool to see if that would help. While it did not solve the problem, I was now able to see the Pair controllers button in PiTool, but still didn’t get the controllers or LH connected.

Tonight, I had a remote session with Pimax_China support, and the result was to return the headset for exchange. Support tried a number of things, installed some additional software to try and troubleshoot and no go on the LH or controllers.

On a side note, Support asked me to set the LH to mode “b”, which I always read it should be on “a” when you only have one, but they had me change it to “b”.

So far everyone at Pimax has been responsive and helpful. Thank you Pimax! It’s a bummer it has to go back, but hopefully, that resolves the issues.

Thanks again to all for the help a few days ago.


#9

I’ve always done the same but have later learned it doesn’t matter if it’s A or B.

I’m using channel A for my single basestation for seated gaming and B+C for my room scale gaming (different room).


#10

Update: I sent back the headset that I was using to the Pimax Florida office, and they quickly shipped a replacement unit to me.

Btw: Pimax has been very supportive and helpful while trying to get me fixed.

Unfortunately, the new HMD is still not talking to the LH or vive controllers.

While waiting for the new HMD to arrive, I purchased a new lighthouse, just to rule out something on that end. Didn’t make a difference.

I then had another remote session with Pimax support, and he spent about 2 hours looking for a solution, now that we have replaced the LH and HMD, and no go.

I did notice something interesting in all this.
On the support session, they use an app called Lighthouse_console.exe, located in the Pimax folder. He accesses this by going into Powershell and launching it. He would then type in Lighthouse_console.exe, and it reports back, No lighthouse detected.

If I right-click on this Lighthouse_console.exe and do “Run As Administrator,” it pops open and reports back 5 Lighthouse sensors found in the HMD, it’s serial number, and all the data a working lighthouse module would report so they are working, but for some reason we cannot get them to talk with the LH.

So I’m wondering if this is some kind of permissions issue.

We have tried all of my USB ports, 2.0,3.0,3.1. Even a PCI Startech 3.1 USB card that has dedicated channels and 900mah output on each channel.

At the end of the session, the tech said he thought this was a PCI issue and I should try to remove the PCI 3.1 card. I did, and nothing changed.

On this PC, I’ve never had any other USB device, not work.

We also couldn’t get it to work on the motherboards USB ports :frowning: