HMD power cycling on, and off when connected (SOLVED)


#1

So as of this afternoon, I was tooling around with X-plane, and thought it was time I fired up the Pimax. I powered it on, and enabled VR in X-plane. After a few short flashes on the screen, I put the HMD on, and saw X-plane in VR for the first time. Frame-rate was a bit slow, but it looked fantastic. I toggled VR back off, and closed down X plane.

I loaded PiPlay, and thought I would enable the 1920X1080 option in PiPlay. As soon as I clicked the checkbox, the HMD locked up, as well as my computer.
This is odd because the Pimax has been working flawlessly. I powered the HMD off, and forced a restart on teh computer. Fired everything back up, and it seemed fine. I powered the HMD on, and lock up.

I decided before I did too much, I would try the pimax on another computer. I connected it to my surface book 2, and powered it on. I noticed right away, the display would power on, the surface display would flash, so I could tell it saw the pimax, and as just before it was all happy, the HMD started to cycle.

What might cause the Pimax to get stuck on a power cycling mode? I thought I might flash bios on the Pimax, but I cant because it continues to power cycle itself as soon as it is powered on.
Its hard to explain, but my questions is:

Is there a way to hard re-set the Pimax 4k HMD? Or does anyone know why seemingly changing the HMD to force 1920 x 1080 in PiPlay would cause this ossolating or cycling behavior?

I would love to figure this out, but I have not connected the HMD to 3 different computers, and I get the same power on, power off, cycling on the HMD now.

Help or suggestions?
Hateful because it has worked without a hitch for well over a year now, and now, it is basically useless.

Thanks,
-Pete


#2

Hi Pete. I do recall @Pimax-Support had posted a sequence of pressing & holding buttons.

Will try & search for it. @Enopho might recall the method.


#3

False alarm!
Working with tech for 30 years, I KNOW that I need to disconnect and let disconnected for 15-30 minutes. Seems when I did that, I was able to get functionality back on the HMD, on all 3 computers to boot.

It was stuck in a weird power cycling issue though…honest it was!!

Moral of the story,: When something you love stops working…
-1. clam down, and think logically.
-2. be sure to remove power and let it set for 30 minutes
(rather than wasting an afternoon jacking around with software that was working perfectly fro the past year, trying hardware on 3 different devices, etc.)… :wink:

    1. After a few minutes of being powered off, completely, power it back on and try again.

Trust yourself when you know you have the chops :slight_smile:
All well, and all working again. Off for some X-plane VR!

-Pete

#4

Thank you!! I will do the same. I THOUGHT I read it somewhere on the forums at some point, but it could have been elsewhere.


#5

Follow the above then use official method here below


#6

Awesome you got it working. :beers::sunglasses::+1::sparkles: