Horizontal Bar software glitch

issue

#1

It seems this issue is not related to the cable @PimaxUSA @Dallas.Hao @Heliosurge @SweViver

I have had this issue intermittently since the very first day.

But with the release of PITool 0.144 and per game profiles, the issue is even more reproducable.

Basically when I first power on the headset usually its fine.
Then when I do anything that requires a restart of the HMD:
so for example

  1. Switching from global tab to program specific tab.
  2. Changing Refresh rate

when the screen comes back the image looks like this

The only way to fix it is to click on Reboot HMD. or Hold the power button for 3 seconds to turn the headset off and then turn it on again.

Has anyone else experienced this horizontal bar? It can’t be only me.


#2

I actually saw this, but only got it once and I wasn’t sure what caused it, it scared me half to death because I thought my headset had a faulty part.


#3

Sometimes there is such a picture in my 8K after rebooting the headset (changing the refresh rate of the panels, etc.). pictures through the lens:


The image freezes in the form of some kind of colored waves. It is treated only by rebooting the headset. It happens sometimes during the day.


#4

I don’t use pi home but have the odd time had a graphical glitch. Though not the rainbow requiring a hmd reset & once in awhile maybe a reboot. Maybe a pic shift it’s been awhile. Have had Skyrim completely exit/crash.


#5

I’ve seen this only once, a couple of months ago. I rebooted the headset and I haven’t seen it since.

I’ve seen this quite a bit, but only once or twice, since I got a replacement for my bad Pimax cable.


#6

I have had it quite consistently if I change refresh rate, just about every time I do it. Restarting a couple of times generally sorts it so haven’t really been too worried about it.


#7

I already thought that only I have this phenomenon occurs…thanks
That is, I need to create a ticket to the support service to replace the cable? :roll_eyes:

(I have never contacted Pimax support yet. I hope I find some guides how to do it :sunglasses: )


Everything, I sent a ticket to Pimax Odoo on this occasion (No. 16 489).
I hope the Pimax will replace the cable.


#8

next time it happens instead of rebooting. try changing the refresh rate in pitool. For me it causes the headset to reset the display and will fix it. So i think its a software bug.


#9

you should be :face_with_raised_eyebrow:. I was just like you until this pitool. now it seems to happen every other game change.


#10

I think I well need to try to get a new cable as well. But i feel like it could be a software thing. But that may not make sense because everyone would have the issue.

I actually had this issue on Day 1 of recieving my pimax. First power up. I almost had a stroke. then i rebooted and it went away. But it woyld cone back occassionally.
I dont tend to change refresh rate to often so that probably went i didn’t notice it as much but now this pitool version which allows different refresh rates per game it’s happening enough to cause concern.

FYI guess how many times this has happened on my htc vive, rift, psvr and odessey combined.

A big fat zero. We are so used to bugs now that we are accepting then as normal, when it’s definitely not.


#11

Yes, I do just that sometimes: I change the update frequency and the headset restarts :beer: :sunglasses:


#12

I also do not understand a little why this is happening from the cable.
But just in case I would like to replace it with a new one.
Hopefully the Pimax will send it out soon. While - are silent. I don’t even know how fast the ticket system works :roll_eyes:


#13

I’m not sure if it is a cable thing. I have this rainbow-y error in 1 of 5 times, annoying but restarting HMD works usually.


#14

well be waiting for a while im guessing. I also have sparkles you can see it in dark scenes


#15

1/100 would be once too many for me


#16

Actually it seems to only do it when i change from 72 to 90.


#17

I can now confirm that this is a software bug.

  1. Turn on Headset for 1st Time - 90hz No Problem
  2. Change to 64Hz. - No Problem
  3. Change back to 90 Hz - Problem occurs
  4. Change back to 64 Hz - No Problem
  5. Change to 72 Hz - No Problem
  6. Change to 90 Hz- Problem Occurs.

@PimaxUSA @Dallas.Hao @SweViver

Please some one at pimax fix this. I got an email from the support today

        This is Wythe from the Pimax support team, we have received your feedback.
        I'm sorry you have such a issue.We carefully checked the forum you sent us.
        Whether this problem occurs when the frequency is switched, and it needs to be reconnected to restore the power.
        Our software department has confirmed that this phenomenon is a bug that currently exists with switching frequency and part of just starting up.
        We will check if the issue is related to the line.
        We will continue to follow up on this issue, and I will notify development colleagues to follow up. development will fix it first through the software. If it can't be solved, we will change the cable for you.
        It may take some time, any other feedback, please let me know, your information will help us a lot.
        Have a good day!```

so hopefully this goes to the right people

#18

@drowhunter It’s the issue of your firmware version, you can contact our tech support in odoo to upgrade your hardware version


#19

Ok , not what I was expecting. I have contacted support about this… let’s see what happens.


#20

so support got back to me with this response.

We have confirmed that this problem is caused by the switching of the refresh rate.
The temporary solution is that the plug and unplug the power cord will return to normal.
At present our engineers are conducting in-depth analysis and may need some time, Our future solution is solved by upgrading Pitool and firmware.

so they seem to have acknowledged that it is a software bug and will be fix in an upcoming pitool.