How to play Dirt Rally on Pimax 4K?


#1

Hi guys,

i’m having a hard time starting Dirt Rallye in VR 360 on my Pimax 4k…
Best thing i can get is a flat projection of the game in the SteamVR room… but nothing immersive like other games (Subnautica, ED, Solus…)

It seems i’ve tried all configurations :

  • Pimax and extended modes on Piplay
  • With or without SteamVR started
  • Revive patch and inject (don’t really understand this)
  • Fullscreen or windowed in game settings…

Please help me figuring how to launch Dirt Rallye in real VR 360.


How to run DIRT RALLY on PIMAX 4K?
#2

there is threads on dirt rally, as far as i know no one has got it working correctly on the pimax.

google “richard burns vr”, you can get copies of that easy, it’s not as pretty as dirt but it is a great game and vr experience


#3

Once you can get DiRT Rally to even launch in VR, all is lost because the game will constantly pause when head movement is not detected.

vorpX (not free) fixes this but the game looks extra bad.


#4

I got Dirt Rally working last night, and it is working well actually. (other than needing to constantly move your heads to keep the HMD awake. I’m working on that…) If/when I find the solution to this, I will report back.

I seemed to have best success with loading Pimax 1.2.50 (so far)

What needs to be done to get Dirt Rally working correctly is:

-Be sure the HMD is in Pimax mode
-Execute Steam
-Run Revive
Once ReVive is running and shows in the system tray, right click on it, and choose ‘Patch’
-navigate to the Drit Rally exe in your \Steam\steamapps\common\DiRT Rally\ install folder to complete the patch.
Files that are required to enable VR will be silently copied to the folder by ReVive.

Once you ‘Patch’ Dirt rally from ReVive, enable steam VR and when you click on Dirt Rally to run it, it will state that “Dirt Rally does not support VR, it will appear on your desktop, and may affect VR performance”, but that is telling you it will be displayed on your desktop as well as the HMD.

(As a quick note. Use the left control key in Dirt Rally to center your view once in the cockpit.)

I hope you can get it working as well. Check out this link about ReVive to see what Software needs to be ‘Injected’ to, and what needs to be ‘Patched’.

GAME ON!
-BullGod


#5

Yeah if you can figure out how to avoid the always moving your head thing I’d definitely be interested. Revive does have an option to disable proximity sensor but I couldn’t figure that out…


#6

I solved the problem of the game. Steam \ steamapps \ common \ SteamVR \ resources \ settings \ default.vsettings.
The string “IgnoreActivityLevel”: false, the “revive” section: change the false to true. After stopping steamvr, the value is returned.
Before running steamvr, you must change the value again.


#7

Awesome, so no more having to move your head?


#8

Just tested Koral’s suggestion with ver. 1.0.6 of Revive and it works:

Remove old Revive files from the DiRT Rally Install location if present. (openvr_api.dll/xinput1_3)

Patch the drt.exe w/ Revive & make the necessary changes from Koral’s post.

Result:

Constant head movement no longer required.


#9

Haven’t had the chance to try this yet, but I suspect you can make the setting stick, by:

a) setting the default.vsettings to read only after you have changed it, or
b) putting this in your steamvr.settings file (Steam/config/steamvr.settings)

},
“power” : {
“IgnoreActivityLevel”: true
},

Be sure to check that the settings file is formatted correctly, by using this: http://jsonlint.com. I’m no expert so I could be wrong, or have made a mistake. And maybe it affects other games negatively?

I’m downloading the game now, so I will test the above. Cheers for solving the problem.

Update: Yeah one or both of those things works.


#10

Not on my side, setting default.vsettings to read only had no effect on “IgnoreActivityLevel”.

After SteamVR restart, the true became a false everytime.

The other setting mentioned for steamvr.settings had no effect.


#11

Remember … you need the update v.1.2 to play in VR mode. I try all the options with other versions and it only works with 1.2.
Any way, the ghosting effect is present and its not confortable to play at all.


#12

Works on 1.1.92 on my side, no problem.


#13

Im not talking about Pimax software updates. Im talking about Rally Dirt 1.2 update


#14

That’s weird, it works every time for me.


#15

Understood, 1.23 is my DiRT Rally version.


#16

Running Steam Beta as well?

My default.vrsettings keeps getting written to even if read-only flag is set.


#17

Read only is working for me. My default.vsettings file hasn’t been written to for six days, which is when I first set it.
I am using Steam VR Beta.

Could it be UAC/permissions problem? Are you running steam as admin or something like that?

Or maybe the default.vsettings file has a typo and is being regenerated? Probably not, but I’d recommend checking just in case after making changes, here:

http://jsonlint.com


#18

Steam Beta is launched as Admin & default.vrsettings had no errors and UAC is off.

The problem was Notepad++, Read-only was set but not actually activating.

Had to set the Read-only flag manually.

Thanks for the follow-up, it made me look into it further.


#19

Hi

All I get is the room that looks like I’m in a wireframe dome, with a Steam menu in front of me. I can’t see Dirt Rally. Is there anything else I need to do?

I’m using PiPlay 1.2.57 in Pimax mode,and I assume I have the latest Dirt Rally because I only bought it off steam yesterday - because it’s £12! in the Steam sale at the moment), and I do this:

Start PiPlay, wait for the logo to appear.
LED is blue
Start Steam VR
Right click on Revive in the system tray, and patch drt.exe (I can see the openvr DLLs)
Click “Play” on Dirt Rally in Steam (no option available to “Play in VR”)
It shows the Dirt Rally splash screen, but after a second, it disappears.
All I can see is the wireframe dome in my HMD.

The Occulus software keeps popping up asking me to go through a “Get to know your Occulus Rift” wizard. DO I need to complete this first?

Any ideas what I’m doing wrong?

Thanks


#20

You need to patch the game with revive.

You have to either use 1.1.92, or put up with using a monitor to navigate menus. On all later versions, in game menus won’t display in the headset. It works perfectly on 1.1.92 because that has the best SteamVR compatibility.

Then you also have edit the file mentioned above. Then you are done. It is great in vr.