How to play Dirt Rally on Pimax 4K?


#21

Thanks for the quick reply. I’ve only just installed 1.2.57. Using 1.1.92 I always got the game being projected onto a screen in a steam room as the earlier posts mentioned. I am patching the game with ReVive. So, depending on which PiPlay version I use, this is what I’m seeing:

1.1.92: projected onto a flat screen in a steam vr room

1.2.57: can’t see the game at all, just the wireframe dome and a steam menu.

I must be missing something fairly obvious but I can’t think what it is.

I’ll edit the steam config file too, but I think that’s more to do with the screen pausing. I’ll try it though.

Very grateful for any more ideas, thanks

[Edit: I’m back on 1.1.92 now, and I’m still getting the wireframe dome screen. Help :slight_smile: ]


#22

Sounds like you need to disable Steam’s desktop theater or whatever it is called. Right click Dirt Rally in steam, go to properties, there should be an option to disable theater mode. If not then try the main Steam settings.


#23

Cheers, I’ll give that a go tonight


#24

Thanks jonnypanic, that works. It’s in the main settings. Great fun too :slight_smile:


#25

Think it’s locked at the monitors maximum resolution, which for me is 1080. Does anyone know if its possible (with some clever fiddling) to get it to run at 2k on the HMD and even better, prevent it from running on the monitor altogether (to improve performance)?


#26

It should be 2k. Are other games running at 1080 too? On 1.1.92 you have to activate 2k in piplay settings before it works.


#27

You’re right actually, when I look at the cockpit etc, I’m certain it’s in 2k. The trees in the distance look a bit blurry (for me) which was why I was thinking it was at the lower resolution but if I look at the detail around me it’s actually very good.

I’d be very interested in whether anyone has managed to stop it from rendering the game on the monitor though, via some sort of hack. My frame rate does get a bit choppy at times and I imagine having to render it on the HMD and the monitor isn’t helping performance.


#28

Changing ipdaffects distance focus. I try to find a balance so both near and far objects look clear.


#29

Got it looking pretty awesome now. I’d forgotten to up the resolution in game, and got my IPD sorted. I’ve also cranked up the VR settngs to ‘Nausea Level’ in the HUD setting. Dusted off my old LogiTech Momo.

Have to say: what a superb gaming experience! Thanks for all the help with this :slight_smile:


#30

How do we stop the loss of headtracking pausing the game


#31

“IgnoreActivityLevel”: true

See the posts above for more info.


#32

Just trying Reshade, and while I can see the Reshade improvements on my monitor, the picture in my HMD is just the same as it always was.

Do I need to do something else to see the Reshade effects in my HMD too?

Thanks


#33

Have you managed to get reshade working in other VR games? I know it is possible on 2D games, but fully supported VR?


#34

Enbseries & Reshade does not take when using Direct Mode, currently but it does work when using something like Cinema Mode in Direct Mode.

There is some old info on the Reshade Forums where it was attempted but this unfortunately did not pan out.

https://reshade.me/forum/suggestions/1611-regarding-the-oculus-rift


#35

Interesting. So good for old ports like doom and quake 2. I reckon my pc would choke though.


#36

Give this a go:

http://www.malcolm-s.net/q2vr/


#37

Excellent. I’ve been playing the old one that only works in extended mode. Half Life 2 is getting an updated VR mod too.


#38

Yes but no go with the Half Life VR (Beta) working yet :frowning:


#39

on 1.1.92? Works for me.


#40

I just don’t want to go back to earlier the Piplay version.
I’m finding that the video quality of the latest Piplay (1.2.57) is very good and compatibility with SteamVR and OCHome is better as well.
Hopefully I’ll find a workaround for HL series as well. But I’m glad that it’s working for you.