How to Power Off Basestations remotely?

events

#1

Hi everyone,

I’ve recently received my Pimax 5k+ and I am using it with the HTC Vive Basestations and Controllers (v1.0).

My current problem is that the base stations are permanently powered on and there seems no way to change that, at least while using the Pimax 5k+.

Reason for that:

  • To be able to activate the Standby mode of the lighthouses and telling them to shutdown/power on every time when SteamVR starts at least the breakout box of the HTC Vive has to be connected. Why?
  • Apparently, within the breakout box there is a Bluetooth chip hidden which communicates with the lighthouses. So far, this would be okay for me just to let it be connected while letting the HTC Vive HMD disconnected. But!
  • If I only connect the breakout box with my PC (with HDMI, USB, and Power) I see within the SteamVR Settings that the ‘Bluetooth Service’ [roughly translated] is not available. So what went wrong?
  • I’ve reinstalled everything, tried out a lot, at the End I only got SteamVR to recognize that there IS a breakout box connected with the necessary Bluetooth connection by also connecting the HTC Vive HMD and this is not a solution for me.

There are now some possible ways to solve this, but before I consider them I wanted to ask if someone has a solution already.

Possible ways:

  • Just accept that they have to be powered on/off by hand (does this damage them?)
  • Using Smart Home power sockets to activate them manually but at least remote.
  • Find a way to get SteamVR to recognize a 3rd Party Bluetooth Dongle to communicate with the lighthouses even if there is no breakout box.
  • Find a way to get SteamVR to recognize the Bluetooth connection of the breakout box even if the HTC Vive isn’t connected.
  • Find another Bluetooth dongle which supports the communication with the lighthouses (from Broadcom) and writing my own Tool to send the commands to them. Any references for this is appreciated.

P.s.: I also found out without the breakout box and the HTC Vive it’s not possible to upgrade the firmware nor it’s being shown within SteamVR that there is an available firmware update to be installed.


Lighthouse 2.0 Channel Config - Bluetooth?
Vive breakout box no longer shutting off base stations
Table of Contents (Wiki)
#2

This is exactly what I would like to know . I just purchased some on gumtree but no breakout box . I have never owned a Vive so I haven’t got a clue . Smart home sockets sounds good .


#3

What i do now is unplug basestation B. Doing that basestaion C goes to sleep


#4

@TheHolyOne

I have tried for many days to get this working, including external usb bluetooth, but nothing works.
As soon as the vive is disconnected and you reboot your PC then you will get the steamvr error bluetooth service not available.

The only way to get it working as intended would be a request to the SteamVR developers.
I suspect there is some communication between the headset and the breakout box, probably for the bluetooth phone intergration, without that communication bluetooth seems to be unavailable

There has been a few threads on here about it and reddit, but no one has found a solouction.

KraitPhantom


#5

I’ve mirrored this thread in the Steam and also in the Pimax subreddit:


#6

Thanks for the information. At the moment i am trying to find the ‘right’ way to get with Steam in touch about this topic. Any tipps / recommendations how to contact them?


#7

@TheUnholyOne

you could try here https://steamcommunity.com/app/250820/discussions/4/

I cant do a post on there now as i dont have my login stored on this laptop, i will try and get onto my pc later today.

KraitPhantom


#8

btw. if really nothing helps, this should:

Quote: Btlejack provides everything you need to sniff, jam and hijack Bluetooth Low Energy devices.


#9

I just ordered two of these from Amazon, no messing about with Bluetooth, just a simple click on and off.


#10

image


Power 5K+ from Link Box
#11

What is wrong with just keeping them ON all the time?


#12

I’ve encounterd a post by a user here that he’s never turned them off and everything is fine.
If you want to risk it why not but sooner or later one of the components will wear out.(could be a lot of hour or not)


#13

they make a very high frequent sound - it’s disturbing and making me headache. While playing (with headphones) this is okay, but let it stay all the time on would make me crazy over time.


#14

Their designed lifespan is 50,000 hours. I don’t think I’ll still will be using them in 6 years.


#15

For Light house firmware updates will likely need to connect them for the time being directly to the pc.

As for recognizing a different Bluetooth might be possible as to get original Wii Motes to connect to pc you had to install Toshiba bluetooth software & edit it’s config file with your bluetooth driver name.

So in theory something similar might be possible.

@twack3r i think posted the type of motors in LHes are okay to leave on as it reduces wear & tear from power up & down?


#16

Yes, they are using HDD motors so it is literally best practice to keep them running rather than stop and go, which those motors are not designed for.

Still, there are many reasons one would want to be able to power manage them via bluetooth, particularly having the ability to upgrade fw wirelessly. It’s beyond me why the original linkboxes cannot be used for that functionality, as it did work back in October 2018. It’s something Pimax need to address with Valve directly and asap imo.


#17

Can this be added as a request for pimax to work on? Seems like it could be added to pitool so when the hmd is not detected lighthouse’s turn off.


#18

My guess on why the linkboxes stopped working is htc might have made changes to make it Vive only feature.


#19

This is what Im using, you can program remote to turn off all LH’s and HMD with on button.

Not sure if this model lets you turn everything on and off with one button, this pic is just a suggestion, but I know some models you can


#20

Those look very similar to the Etekcity ones I bought. Mine doesn’t have an All Off button, though. That’s a nice touch.