How to solve "Disconnect" or "Not tracked" of headset, base station, controller randomly, image follow head although not use base station. (PiTool 91)

fix-guide

#11

My Pimax 5K+ was shown as disconnected for 4 days. I tried everything includes flash the firmware, reinstall pitool, still no luck. Today I tried to update usb driver, as well as delete all residue of Pitool after uninstallation. Then I reinstall the Pitool, now finally my 5K+ is alive again!!! Thank you guys so much! I appreciate the help from here. Happy New Year to you all!


#12

BTW, this time, I also updated my win10 to most current version.
Before today, I tried using different USB port or DP port, but no working.


#13

The current PiTool version at the Pimax web is v1.0.1.91.
But just after installing that version the PiTool check version alerts you that a new versión is available (the v1.0.1.95) ¿¿:roll_eyes:??
Why not just put on the web always the latest?


#14

My understanding is that this is intentional. Pimax only updates the web-linked version, once the latest has had more testing. It’s available in PiTools so that people who are having problems can try out “early” builds.


#15

Remove other device from usb or if you have a link box or usb hub with adapter, may try to use it.

Try to move file in lighthouse and restart PiService sometimes.


Help! Pimax 5k+ not detected in PiTool and LED is solid Red
#16

Finally I solved the problem!!! :-)))))
It was a very very silly issue.

Yesterday arrived the DP to miniDP adapter, so I tested the Pimax5K+ in the laptop MSI GS63VR (just to check the issue in another computer). The problem was exactly the same “Not tracked”. I tried everything (uninstall/install, restart PIserviceLauncher, delete LH folder, etc, etc).

Then, I started to rotate the headset in all directions (pitch, roll, yaw) and suddenly it worked! I couldn´t believe it.

Then, I put the Pimax5K+ over the desktop PC and initially the problem was the same but I just rotate the headset about 360 in all directions a it worked!!

I restarted the headset more than 10 times to try to determine exactly what kind of rotation (pitch, roll, yaw) and how much degrees (90, 180, 360) it was needed to be on tracking again.
Then I realised that it doesn´t depend on the rotations I made, it was more related to the DISTANCE!!

I measure the distance (with a meter tool) and it was 120cm!, I thought it was more but it was just 1.2 meter distance. With 1.2 meter the initialisation tracking routine doesn´t work very well. I put the headset at 1.5 meters and it worked perfectly!!

When I used the VivePro it was working perfectly at 1 meter distance, so for the Pimax5K+ I placed the basestation (I only use one basestation) at the same place I was using with VivePro, assuming the distance was also ok. But as I have seen it is not enough!.

The curious thing is that once the “not tracked” disappear and the headset is ready, I can put it at 1 meter distance and it works perfectly during all game play. The problem with 1 meter is only for the initialization.

I will now start to tweak and set my favorite and only VR game (IL-2) for the Pimax5K+.

A big thank to the support team who help me via teamviewer in these previous days!


Table of Contents (Wiki)
#17

This was an issue that a previous user also had (they were using a seated setup) and unfortunately that knowledge didn’t trickle into this thread. :cry:

That is why I have been accumulating solutions to help spread the knowledge a bit more easily :smile:

My assumption is that you need to be further away because the HMD is physically larger.

Untitled


Quick question about base station tracking
#18

I get the new headset, found problem again, although all device are connected, but controller always disconnect and disappeared while playing.

I swap to use the usb 3.0 port which ever used and issue is solved.


#19

LOL, OMG just spend 30 minutes fighting with this, you’re absolutely right. The basestation can’t be on my desk, I have to walk back ~5ft then tracking activates. Thanks!


#20

Today I try to setup the second headset (replacement) which never be remoted to update by support.

First time, it can be connected normally, but after restart again, the headset never be connected. It show that I have to place helmet which can be seen by base station.

I try to use 1 base station and not success.

But I try to run the game such as “Lucky tale” and the headset become connected automatically while room set up not work if I close the game.


#21

Yeah, distance is important. But also be careful with reflections from mirror or glassy surfaces!!
This was another funny solved issue I had.


#22

I will say that I love the Pimax 5k+ when it has worked the few times over the last few days, since I’ve received it. However that is the exception, that it actually works. I’ve been through the above info. I found others info about how to fix it. I’ve tried to open a ticket, but I can’t. I’m really getting frustrated. How can I get help?

ISSUE: 5k+ Not Tracked

I’m coming from Oculus. I don’t have a Vive. I’ve borrowed 2 lighthouse and 2 Vive controller. I’ve tried all the “not tracked” procedures, I can find on the forums. It’s not working. There is no one solution that solves it, and so far, it’s not repeatable.

Have worked but not repeatable:
Long procedure that I’m responding to has worked and has not.
When Not Tracked, start SteamVR anyway. Settings/Developer/Disable Power management follow the prompt, unplug and plug USB. Close SteamVR. Restart HDM under settings/HMD Reboot HMD. This has worked and not worked.
I’ve unplugged all my devices except my mouse, keyboard, wheel, and Pimax. Worked/Not worked.

I really need help!!! Getting sick of all the looking at an expensive headset, that is really an IT project.


#23

It look you need to get remoting to fix the headset by company.


#24

Removed one more USB from my computer, that I forgot about. I have a SoundBlaster X7, I disconnected and the Pimax works. I’ve hooked back up and it work for a while. I’ve left it disconnected and I’ve shut the computer down about 5x since then. Each time it start it works. Any issues seem to be solved with a HDM reboot. Working much better. One big issue, I love my SoundBlaster X7 and AM NOT going to get rid of it. Any suggestions on what might be the conflict or a way around this?


#25

Do you already disable power management in device manager?


#26

Thank you to all who helped making this thread.

I received my 5K+, and despite fiddling with the settings for an hour, I couldn’t make pitool detect the controllers and base station.
The solution at the end of the opening post did the trick (even if the listed processes aren’t all here with pitool current version).


#28

That truly sucks. It should not be that hard. Pimax needs to get this to consumer quality level. Right now it’s still beta without a full set of developer tools.


#29

Yep. I spent an hour trying to get my Vive controller to stop showing up in random places around the room. Restartin PC didnt help, then run room set up in Steam VR, then in Pi Tools. Im not even sure what fixed it they just started working :roll_eyes::exploding_head::angry:


#30

I’m finding this incredibly frustrating. I originally installed PiTool 181_95 and never had an issue tracking my headset. then yesterday I decided to install 103_R191, my headset then did a firmware upgrade and since then EVERYTIME I either turn off my headset or restart my PC I lose tracking. Somethines I just need to turn a controller on and it picks up the lighthouses and then the headset but other times it just refuses to work.

this must be a firmware issue with the 103_R191 release. I ish Pimax had some proper version control and the ability to go back on firmware to avoid this sort of problem.


#31

Some sent me info on permanently disabling the Power option. Ive tryed to attach a snapshot of the direction directly below, that worked for me.

Power%20management%20steps

This worked and corrected my issues. I’ve had it working for close to a week and I’ve now added in by SoundBlaster X7 back into the mix and everything is working well together.

I still occasionally have issues with a USB Device losing connect. So far not in critical situations.

I’m still occasionally having to do a “HDM” reboot if I get a grey screen after leaving iRacing. I have to closed SteamVR and then go to Pimax. Reboot HDM and then restart SteamVR. I can then start iRacing on their website, not through the SteamVR homeroom.

I’m happy now with the Pimax headset. Great improvement over Oculus Rift in iRacing!!!