How to solve "Disconnect" or "Not tracked" of headset, base station, controller randomly, image follow head although not use base station. (PiTool 91)

fix-guide

#21

Yeah, distance is important. But also be careful with reflections from mirror or glassy surfaces!!
This was another funny solved issue I had.


#22

I will say that I love the Pimax 5k+ when it has worked the few times over the last few days, since I’ve received it. However that is the exception, that it actually works. I’ve been through the above info. I found others info about how to fix it. I’ve tried to open a ticket, but I can’t. I’m really getting frustrated. How can I get help?

ISSUE: 5k+ Not Tracked

I’m coming from Oculus. I don’t have a Vive. I’ve borrowed 2 lighthouse and 2 Vive controller. I’ve tried all the “not tracked” procedures, I can find on the forums. It’s not working. There is no one solution that solves it, and so far, it’s not repeatable.

Have worked but not repeatable:
Long procedure that I’m responding to has worked and has not.
When Not Tracked, start SteamVR anyway. Settings/Developer/Disable Power management follow the prompt, unplug and plug USB. Close SteamVR. Restart HDM under settings/HMD Reboot HMD. This has worked and not worked.
I’ve unplugged all my devices except my mouse, keyboard, wheel, and Pimax. Worked/Not worked.

I really need help!!! Getting sick of all the looking at an expensive headset, that is really an IT project.


#23

It look you need to get remoting to fix the headset by company.


#24

Removed one more USB from my computer, that I forgot about. I have a SoundBlaster X7, I disconnected and the Pimax works. I’ve hooked back up and it work for a while. I’ve left it disconnected and I’ve shut the computer down about 5x since then. Each time it start it works. Any issues seem to be solved with a HDM reboot. Working much better. One big issue, I love my SoundBlaster X7 and AM NOT going to get rid of it. Any suggestions on what might be the conflict or a way around this?


#25

Do you already disable power management in device manager?


#26

Thank you to all who helped making this thread.

I received my 5K+, and despite fiddling with the settings for an hour, I couldn’t make pitool detect the controllers and base station.
The solution at the end of the opening post did the trick (even if the listed processes aren’t all here with pitool current version).


#28

That truly sucks. It should not be that hard. Pimax needs to get this to consumer quality level. Right now it’s still beta without a full set of developer tools.


#29

Yep. I spent an hour trying to get my Vive controller to stop showing up in random places around the room. Restartin PC didnt help, then run room set up in Steam VR, then in Pi Tools. Im not even sure what fixed it they just started working :roll_eyes::exploding_head::angry:


#30

I’m finding this incredibly frustrating. I originally installed PiTool 181_95 and never had an issue tracking my headset. then yesterday I decided to install 103_R191, my headset then did a firmware upgrade and since then EVERYTIME I either turn off my headset or restart my PC I lose tracking. Somethines I just need to turn a controller on and it picks up the lighthouses and then the headset but other times it just refuses to work.

this must be a firmware issue with the 103_R191 release. I ish Pimax had some proper version control and the ability to go back on firmware to avoid this sort of problem.


#31

Some sent me info on permanently disabling the Power option. Ive tryed to attach a snapshot of the direction directly below, that worked for me.

Power%20management%20steps

This worked and corrected my issues. I’ve had it working for close to a week and I’ve now added in by SoundBlaster X7 back into the mix and everything is working well together.

I still occasionally have issues with a USB Device losing connect. So far not in critical situations.

I’m still occasionally having to do a “HDM” reboot if I get a grey screen after leaving iRacing. I have to closed SteamVR and then go to Pimax. Reboot HDM and then restart SteamVR. I can then start iRacing on their website, not through the SteamVR homeroom.

I’m happy now with the Pimax headset. Great improvement over Oculus Rift in iRacing!!!


#32

I plug out the cable and ship the cable to my friend for test.
After I get cable back and I try to do every method and it not work.
It always show 10500

So I try to replug the cable while open PiTool and the headset is updated, but it still not connected. It show 10600

I check by dianose in Help page.
It show that I have to update nvidia driver and so I update my gtx 1070 driver.

After that restart PiserviceLauncher in service of task manager.
The headset become connect, but it still show that placinng the headset to see by base station.
Then pairing the controller again and now it work.

Conclusion : update GPU driver is important.


#33

Although I use the latest GPU driver, but not sure what happened and I can’t connect the headset.

I try to update the pitool to latest firmware (111) and it still can’t be connect.
After I try a lot of method, so I decide to reinstall gpu driver and restart piservicelauncher again and now the headset be connected.

p.s. After firmware 109, lighthouse folder is changed and you don’t need to remove file in lighthouse folder anymore.


#34

I just received the 5k+ and I’m having the same problem that the headset is not tracked. I have tried everything suggested in this thread and still I cannot get the headset to track.

I can confirm that the Lighthouse Folder is no longer there using Firmware 109.

My specs:
CPU: i9-9900k
Ram: 16gb 3000 mhz
GPU: Asus RTX 2080 ti
Pimax 5k+ P2 Version
1 Original Vive Lighthouse
2 Original Vive Controllers

Here are the list of things I have tried.

  1. Move the lighthouse in various positions, distances, and angles from 1m to 5m away and from 2m high to 3m high. I’ve also rotated the headset, hide and reveal it’s sensors to the base station multiple times. There are no obstructions between the base station and the headset.
  2. Tried every single USB port including the 2.0, 3.0, and 3.1 (red).
  3. The Vive Linkbox is NOT connected.
  4. Pitool does have the use Lighthouse ticker checked. If this is not checked, the headset becomes active immediately and goes into it’s 3dof mode. Once it is checked, the headset goes back to Not Tracked.
  5. Disabled Power Management in SteamVr.
  6. Disabled “allow computer to turn off devices” in the USB Root Hub under the Device Manager.
  7. Stopped and restarted the Piservicelauncher.exe in the Service Tab of the Task Manager.
  8. There is no sunlight or reflections in the environment. I having issues both night and day.
  9. Removed the Pimax cable from the headset and re-seated it securely.
  10. Uninstalled and re-installed Pitool (109) multiple times.

I don’t know what else to do. Any help or suggestions is greatly appreciated. Thanks.


#35

Same here… Did most of the things you listed… still HMD not tracked. Things is this issue happens on windows 10, in windows 7 (same pc) my 5k+ works fine. Also, I tried my vive on win 10 and it works…
I am at a loss here :confused:
Edit: I reverted firmware to .181 with dfu tool and now it works with older pitool version 1.95 … but when I update to latest firmware then reboot, it shows not tracked again.
Edit: Fixed via remote desktop by support


#36

what did support do? i have the same problem


#37

I’m in the same position as most people here; I received my new 5k+ and I bought a new lighthouse from Vive, but I can’t connect to it. I’ve tried all the suggestions, but I’m at a bit of a loss.

It’s so crazy a bug this widespread hasn’t been fixed yet. :frowning:


#38

That’s awesome to hear! I cant wait to try it out in iRacing!! As soon as it connects to the lighthouse, I’ll be in there!


#39

I have the same problem.
PImax support help in this problem?


[Replied]HMD not booting/waking up when starting computer
#40

Same problem here, any solution?


#41

I would like to contact @Doman.Chen, cause I face the issue that the lighthouses cannot track the HMD in a stable way. But I cannot contact him?! Never had this tracking issues before with my HTC Vive.