Improve pimax image



Hi i just recieved my 5k+ and although it wins in several areas, im a little underwhelmed at the image quality. For instance the picture looks extremely smokey, washed out and grey. Also I cant find the sweet spot for the life of me resulting in a lot of lens flare, distortion and blurriness. I have looked all over the place for some concrete solutions to these problems to no avail. Am i missing an important setting. Please help as i had only JUST forked out 1000 aud for a vive and the another 1050 for the Pimax just 2 weeks later hoping that it will scratch my vr itch


The picture will have a somewhat washed out look compared to Vive due to Oled vs Lcd.

I use Hmd Brightness on Low.
Then Brightness -1
Contrast +2

Do you know if your ipd is Symetrical or Asymetrical? Ie ipd 64 32/32 (Sym) or 31/33 (Asym).

Here is a link to some helpful guides.



Note that it isn’t just up/down, left/right when trying to find the sweet spot for canted displays. You also have to adjust it in/out - changing the distance between your eyes and the lenses. I found that getting too close to the lenses resulted in some rather obnoxious Fresnel rings (aka circular rings of light).

If you want to increase the distance between your eyes and the lenses you can either get a thicker face foam or add some double-sided velcro in between the foam and the headset. Some people also reported needing to change the angle of the headset (ie tilting up/down), which you can do by only adding the velcro to one side of the headset.

Others reported that they had eye strain and that the headset imager never looked right. This was found to be due to a mismatch between the hardware IPD setting and people’s “actual” IPD. There is a software IPD offset that you can adjust in PiTool to account for this.

Table of Contents (Wiki)

I suspect not being able to get a clear image in both eyes and in only one eye at a time as some people report might be caused by different ipd measurements for each eye.

individual per eye ipd settings havent been implemented into Pitool yet, but an option for an advanced ipd setting has been requested by a lot of people, so that might be coming soon and could solve your issues with the sweet spot.

I just made a poll requesting the option to modify LCD backlight settings to improve black levels, and for different colour presets to be switchable in game by pressing buttons on the HMD.
I think both of my above suggestions would solve both the issues you are experiencing, so you should post if you want these features as @SweViver has said if enough people ask for it, then it might be implemented.


What others said. Plus, in my mind the image quality really comes into its own on the Pimax 5k+ once you get supersampling up to around 120%. Give it a try.

The IPD offset software slider is super useful. Also the Vertical offset for 3d depth. Get as close as you can with the physical slider, then start to experiment with the software offset. You will start to get a feel for what feels right to you.


The distortion and blurriness can be greatly reduced with a bit of customization.

There’s something about the Pimax design (probably the canted panels) which makes it tricky to get the position “just right”. For best results, you need the headset positioned very precisely, but when you’ve done it, most the of wide FOV should be in focus. (In driving games, you should be able to face straight ahead and glance to the left or right (without turning your head) and see the side mirrors clearly.)

Unfortunately, there apparently is a small percentage of people who seem to have great difficulty in getting a good experience. Personally, on Normal FOV, I see almost no distortions.

I’ve added a single strip of double-sided Velcro on the top edge of my 8K, between the face-pad and the main body of the headset. I’m still using the 14mm foam face-pad that came with my unit. (Note that Pimax has shipped 3 different thickness, so yours may differ from mine.) I’ve tried 2 other “deluxe” face-pads, but didn’t like them as well as the OG. I’ve also added a counterweight, to reduce nose and face pressure. (Search the forum for details.)


What Pitool version are you using ?

I found that, when I tested 180 version the image was really blurry and out of focus. I just could not make the image clear. I tested with different ipd, vertical, brightness, contrast settings but nothing helped.

With Pitool version 132 picture quality is much better.

I’m using VR Cover face foam for Oculus.



I’m also using the 180 version. The blurry issue sounds like the SteamVR max res setting is too low, but I thought that problem was fixed in recent versions. The 2 versions should have similar images.

I’m not sure what to suggest at this point.


@sweviver posted about steam polling your video card performance.

Try going to SteamVR\Settings\Developer\Disable Gpu profiling

On desktop.


Does this really help?
I have tried disabling this option, and my numbers in steamvr.vrsettings are still being measured and added upon every restart of SteamVR. Also, the SteamVR issue I posted about a few days ago is regardless of what PiTool version is used. So this must be something else.

@Japo are you using Large FOV? Maybe its the maxRecommendedResolution being set too low? Check this thread:


I have had this option off since start. Haven’t notice gpu performance issues but would need to test further.

Could be my Nvidia & Amd cpu power profiles might not be experiencing the gpu polling. Essentially it sounds like if it’s ignoring the Dev option that Valve has a serious bug to fix.


Thanks Heliosurge and Martin for the tips.

I have Gpu profiling disabled and I’m using Normal FOV, Pitool 1 and steam at 100 %
This gives resolution 3200x2632. maxRecommendedResolution is 8192.

I tested 180 in iRacing. The 132 version works well so I’m using that now and will test the next beta version when it’s out.

The difference between 180 and 132 was huge.