Increase brightness DRAMATICALLY in Assetto Corsa


#1

Hi there!

I don’t know if the community has already discovered this solution, but I couldn’t find it anywhere, so I’ll post it here for you guys.

Assetto Corsa always seemed too dark. I could only play at 12:00-14:00 and with clear or very good weather (no dark clouds), otherwise I couldn’t even see the road.

As @iDaver discovered in this thread Beginner’s setup guide, what matters most is not really the brightness, but the gamma value. There was a solution involving changing the gamma value in video mode and then going back to pimax mode, but for some reason the setting doesn’t stick anymore.

I started messing around with Content Manager (a MUST for Assetto Corsa) and discovered a solution:

  • Click on “SETTINGS” at the top right
  • Click on “VIDEO” on the left
  • Scroll down to “Post-Processing” (you must have a post-processing filter activated for this solution to work
  • Make sure that the “Enable post-processing effects” tick is ACTIVATED
  • Check the “Filter” that you have activated (I use “_gbWSuite”) and click on “Manage” at the right of the filter’s name. Content Manager will open a bunch of text which is the post-processing filter program (or sort of).
  • Scroll down to “[TONEMAPPING]”
  • Within this part of the program, you can see “GAMMA=1.15” (1.15 or whatever gamma value it is at the time).
  • Increase this value. Maximum working value is 2.6. If you set a gamma value of more than 2.6, the image will appear as dim as always.
  • Click “Save” at the bottom.
  • Go back to “DRIVE” at the top, start a race, practice or whatever and BE AMAZED with the dramatic change in the overall brigthness!!

Maximum values:

  • Gamma: 2.6
  • Saturation (in the general “VIDEO” settings): 98%

For some reason, if I exceed any of the above values, the image appears as dim as always. However, if the value is as above or lower, it works, and the image is MUCH brighter than before.

Other recommendations:

  • Activate “Sunrays” in “Post-Processing”. It makes a HUGE difference in realism and, hence, immersion. It is a small tweak, but it really adds a lot to the experience.
  • If you want to race at night (using the recently discovered lights shader and the night time weathers), deactivate the Post-Processing filter (you can turn it on again later to drive at day time). If you don’t do it, the image will appear dimmer and the car’s lights will be too dim, but if you just deactivate the pp filter the night time driving will be much more realistic. It is easy: night time driving --> pp filter off // day time driving --> pp filter on.

My winning setup:

  • Gamma: 2.5-2.6
  • Saturation: 94%
  • Day time driving Post-Processing filter: _gbWSuite (Good and bad weather suite)
  • Night time driving Post-Processing filter: none (just deactivate it)
  • Brightness level of the Pimax 4K headset (set on Piplay): 3 (the brightest option).

How does it affect the game?

As I said above, before I was only able to play at 12:00-14:00 (approximately) and with good weather, otherwise I couldn’t even see the road. Now, I can drive at any time of the day, with any weather, and the light is super realistic. I did the tests on the Nurburgring track, because I’ve been there in real life, and the light at any given time of the day feels exactly as it should feel. You set morning time, it feels like morning at the ring. You set 17:00 or 18:00 and it feels like a weekend Touristenfarten in real life. I even tried to drive at 7:00 AM with a few clouds and the experience was amazing, a true sunrise at the ring. It really feels like I am there again.

It is amazing when the sun strikes you directly, it even disturbs you as it should and as it happens in real life (even if the brightness is not as disturbing as that of the real sun, fortunately!!). Driving a convertible around 12:00-14:00 with clear weather even makes me narrow my eyes as the light is so bright, just like real life.

This has made a world of difference in my experience with the Pimax 4K headset in Assetto Corsa. If I could only solve the drift problem there would really be no better headset for me as of today.


#2

Moving this topic to content area… Well done for finding this, don’t think I have seen this fix before!


#3

Amazing post, all this time I had no idea you could adjust gamma in CM.

Also to remove drift go to device settings in piplay and perform a magnetism calibration, this gets rid of drift for me almost totaly. Point headset at ceiling, then floor, the 90 deg to left, then 90 deg to right to calibrate. Do this every time you use the pimax. Sometimes it won’t calibrate so you need to turn the headset off and on.

Some people say having steams mirror on screen and centering that before use also helps but for me calibration fixed it.

Dave