Index Controller (Knuckles) - Easy Working Solution!

fix-guide

#118

I have this same issue. Just using Pitool, my Vive w/knuckles works fine. It’s mostly my left controller… and it’s really frustrating trying to play Onward when i can’t grip the gun consistently.


#119

Did anyone use this technique with success, then update to the new Pitool Beta that “fixes” index controller support?

I’m trying to figure out how/if I should undo what this fix did in order to use the new Pitool. Because I have the new Pitool, and now nothing’s working. It just shows controllers are disconnected, even after pairing them.


#120

i did, i’ve just deleted the content of the additional (old) driver folder and installed new pitools (should not be importend when the old driver is deleted, has nothing to do with pitools, its a stream thing and even if steam was started it should be possible to close it, delete the contend of the folder and start steam again)
had no problwms, the controller where still paired in pitools after the update and steam vr started with the proper mini icons of the controller (only generic “C” for the old driver with the old pitools)


#121

Just to say that if you have it all working (via latest pitool and latest index firmware) then what I’ve found is two obvious things to say “yes, it’s fully working now” :slight_smile:

  1. you get the actual index controller images in steam vr (but normal ones in pitools) and not the Cs

  2. My index point finger no longer has to actual press down on the gun trigger to close. It now closes far more naturally away from the gun trigger point (maybe this is after playing for 2 days though calibration). I can even “pinch” my index and middle finger together for “dainty pickup” of items :slight_smile:

Hope you guys get to this point too!


#122

one question though…

Anyone know if there’s an option to stop turning the index controllers on starting steamvr? It’s getting in the way of playing oculus games. Although, bizarrely, Steamvr starts anyway when trying to launch an oculus game from within pitool (latest.)

Maybe I need to uninstall revive?


#123

I deleted it and my knuckles did not respond. Had to put the files back and it worked. I have indexcontroller and it doesnt say steamvrknuckles. Did you delete the whole folder or just the content inside?


#124

If you’re using SteamVR Beta switch back to the normal branch or vice versa so all files are re written.


#125

Yep this worked thanks


#126

maybe your pitools was not updated properly?
check the file date of your pimax steam plugin
C:\Program Files\Pimax\SteamVRSupport\drivers\aapvr\bin\win64\driver_aapvr.dll
should be 28.06.2019
reinstall new pitools beta 144

just the content of “SteamVRKnucklesDriver” (one file and one folder)


#127

Hi, i have the same annyoing problems with jumping index controllers, loosing tracking. Did you solve this? Any hints?


#128

Thanks for the guide! Can confirm custom bindings won’t work until firmware update.


#129

Did you solve the issue with the tracking loss ?


#130

I just uninstalled SteamVR, PiTool, and deleted all remains manually. Restarted PC. Installed SteamVR + PiTool 144.

Everything worked right away.

No need for a FW update to the Controllers either. Why do you think would this be necessary?


#131

Controller Firmware updates(like any firmware update) is to improve/fix and/or add functions.


#132

Steams reply to knuckles and pimax tracking issues,time to ditch the pimax fed up of all the troubleshooting its taking the fun outta vr for ma


#133

Have you tried ditching openvr advanced settings as mentioned? And limiting Wireless interferences?

Would be interesting to compare logs with someone that has it working. There would likely be a different amount of tracking data headset wise due to difference in number of sensors & positions.


#134

Mind you, they’re not saying Pimax tracking is crap, just that they’re not using the same log levels as the default implementation.

Btw, what log files did you send them where you can see the disconnects? Would be interesting for the rest of us to check.


#135

It was the steam vr logs and the windows logs


#136

Starting to think that Pimax wasn’t worth it. It seems that everything needs to be fiddled with just to get certain things to work. It all should work within pitool itself.


#137

Overwrite? What does that even mean lol