Index Controller (Knuckles) - Easy Working Solution!

fix-guide

#41

That not sure bur shouldn’t need to in my experiences with other usb like devices.

Each device should have it’s own pairing ids.


#42

Awesome. Hopefully they have a big enough internal mem for arcades. :beers::wink::+1::sparkles:


#43

On the actual PiTool the first connected device defines the model, if you connect the Wands, than turn off, and connect the Index Controller, you should get the Wands shape


#44

Confirmed, this also works for me.


#45

Sorry for the dumb question, but how do I pair them with the headset in Pitool? Or do I not do that part?
Pitool says to press the App and System buttons, but the index controllers don’t have the app button as far as I can tell.


#46

@mmorselli said you want B+System to pair


#48

Tried the old driver hack to get the index controllers working but still invisible in aperture labs and look like wands in steam home, Maybe I need to wipe the old index controller pairings in pitool somehow?

Also, I’ve got steam spread over 3 drives and tried installing the new drivers on C: drive and restarted and replaced like for like the new with the old driver stuff. any other ideas?

Really hoping the new pitool software gets here asap! :slight_smile:


#49

They also come up as “aapr” in the controller bindings and that is the name of the driver in pitools steamvr support folder so maybe it’s related to that?

In both pitool and steam they are the C shaped icons


#50

Never mind got it working sigh! :slight_smile:
I’d put the old drivers inside of the empty folder so instead put in in same top level folder and restarted. Yay!


#51

I don’t think mine are working. I have C’s in Steam VR


#52

Everything seems to be working except finger tracking, at least in Steam VR Home instead of controllers I can see hands, but I can’t move my fingers, also in Hand lab game my robo hands are staying in fixed positon on the ground. In steam view i can see my index controllers properly (there is no visible input on finger tracking)

Any ideas what i did wrong?


#53

My issue also…


#54

i have “C” too but mine are working fine in Steam Home and Aperture Hand Lab


#55

my index controllers just won’t get detected. I followed all the steps above. the only thing that worked was the firmware update when connecting them with the usb cable. If I connect them with USB and run PiTool + SteamVR they seem to work except it shows a C instead the controller icon in SteamVR. If I power the controllers on without the USB connection they won’t get detected and the LED on the controllers shines blue. (@mmorselli is it normal that the download of the new drivers from the first link is 0 bytes ?)

EDIT: now they work (only the icon still shows C). in PiTool I had to disable “Compatible With Vive Only Game” which let me pair 1 controller. then I turned the option back on and I was able to pair the second controller :slight_smile:


#56

yes, because this driver is deprecated and no more used. The fix above only provides some graphics file missing, but driver used is still the newest one, integrated into SteamVR


#57

Received my Knuckles controllers today and Pimax still hasn’t fixed compatibility.

I’m tired of constant workarounds.

It’s a sad turn of events, but I think it’s time for me to turn in my Pimax card.


#58

I’m having the same issue as you, have you found a fix for it yet?


#59

blue is just on, green is what you need (connected)
after “installing” the steamDB link (upper right corner, will open steam and “install” the driver) the “” are there because you get a empty directory with a comment that is has been kind of replaced, copy the old driver into that place

close steam, start pitool use pair in pitool and press system+B for a few seconds to get the controller into pairing mode, after 1st controller pitool will ask if you want another, yes and system+B for the 2nd controller to pair (the the old wands should to be switched off)
after that just start steam vr with pitools and it should work (“C” in steam vr seems to be normal - at least with the old driver used here, the new driver is part of steam as far as i understood)


#60

Yeah ignore me… working fine too. I have C’s but they work. I had to restart a few times. And close down PiTool and SVR to get them working. Working fine in Space thingy and HandLab… super ****ing fun too… and I think it’s learning about my mansize hands

Thanks mmorselli for the workaround


#61

Try the workaround for now. I understand your frustration. But they work great