Index Controller (Knuckles) - Easy Working Solution!

fix-guide

#62

New Pitool is coming & apparently valve is working with them to fix it since it broke after your march article when it worked fine. Cas & chary so far seem to have Unicorn as they had 0 problems & no workarounds needed.

With these controllers being new will take sometime to get everything in place. No different than early issues with Steamcontroller & steamlink when first released.

What would be cool (off topic) is to hack a driver to use Oculus touch wireless with tracking pucks.


#63

My index controllers are working fine however I would like to use a combination of index controller on my left hand and vive controller on my right hand as I have a gun controller in which you put a vive controller and I use that for all my gun games.

This seems impossible to do as SteamVR seems to get completely confused and thinks that my vive controller is an index controller. Anybody got any ideas for accomplishing this?


#64

This might be a question @mmorselli might know as he has a fair bit of experience with valve’s new controllers


#65

Could you provide any further explanation on this @Matt_Goodman ? I’m experiencing the exact same issue however don’t fully understand how you were able to resolve it. Thanks.


#66

the zip already contains the folder “SteamVRKnucklesDriver” and in that is what you shoud place in
C:\Program Files (x86)\Steam\steamapps\common\SteamVRKnucklesDriver
you should not have
C:\Program Files (x86)\Steam\steamapps\common\SteamVRKnucklesDriver\SteamVRKnucklesDriver


#67

btw. the newer steam vr integrated driver (that will be overruled with the old one) is located in
C:\Program Files (x86)\Steam\steamapps\common\SteamVR\drivers\indexcontroller
just if anyone wants to compare something


#68

Thank you for this! I was able to set up the knuckles smoothly within a min.


#69

My controllers work but dont show up at all in moondust or aperture labs. In moon dust they are fully functioning, just invisible. In aperture labs they are stuck in the floor.

I followed the instructions and have reset a bunch.


#70
  • check file location ( SteamVRKnucklesDriver folder should contains driver.vrdrivermanifest and resources folder)
  • reboot

#71

Are the hands in the Aperture Labs supposed to be super floaty? I feel like they drag behind a lot compared to when I’m the home environment.


#72

It is Still broke, not sure what to do


#73

workaround didn’t work for me…


#74

Make sure you guys are putting the old drivers in \SteamVRKnucklesDriver NOT \EmptySteamDepot.

Also I paired my controllers in pitool before installing the drivers, not sure if that makes a difference.


#75

I did both of these and its still broke.


#76

Do your controllers work fine in vr home?


#77

Maybe be do the pimax pitool pairing controllers option again after restarting PC.

That seemed to work for me.

The other thing I did after pairing again (but may or may not have helped) is I started pitool with the vice wands, loaded up steamvr home, turned off the wands and turned on the index controllers.

Whatever I did, it works every time now.

Other things to try are, redo the room setup in steamvr.


#78

I paired my controllers BEFORE installing the new drivers also… still working


#79

Got mines to work and updated firmware

1.paired both index to pitool.
2.installed driver and replaced it with the old files
3.in order to update firmware i had to overwrite the old files with the new one. So basically step 2 but reverse.
4.Everything working.


#80

@Toba are you saying you’re seeing now knuckles icons in steamvr? How is that possible? My are “C” whatever i do. Could you elaborate on that 2nd and 3rd point?


#81

I still get the C in steamvr when playing.

Just follow the instruction in the first post but before you overwrite the new driver with the old one copy and paste it somewhere. In this thread there’s instruction on how to update firmware but for some reason i kept getting the C and i couldnt update. So i took the files i copied during step one and copied it over the old driver. Then the index icon came on and i was able to update. The C came back when my headset is on.

So basically
1.install new driver
2. Copy the new one and save it somewhere
3.overwrite the new driver with the old driver.
4.follow step to update firmware
3.overwrite old driver with the new one you copied.
4.turn steamvr on and connect index via usb.
5.done.