Index Controller (Knuckles) - Easy Working Solution!

fix-guide

#82

this driver shouldn’t be used by SteamVR, the new one is empty and the old doesn’t install anything. SteamVR should use the built-in one

I’m glad you solved, but better not to spread palliative procedures that really do nothing


#83

I solved it by upgrading to the beta version of pitool


#84

Glad you sorted it…


#85

I mean he asked so i told him. The firmware update method does not work for the new steam update. Also im confused what do you mean the driver shouldn’t be used by steamvr? Am i suppose to delete them?


#86

The story in short:

  • during Knuckles development, Valve provided an external driver for developers only. This is the driver we install from SteamDB
  • Pimax used this driver to develop Knuckles support in PITool
  • As the retail release comes closer, Valve has integrated the drivers into SteamVR, and replaced the external one with an empty folder (to save our precious disk space, or to make Pimax a joke?)
  • the external driver folder contained the graphic models of the controllers, and PiTool kept looking for them in the old location. This fix puts a copy back in that folder

So the old driver, installed with SteamDB, is still deprecated, no matter what version we put in that folder, the SteamVR integrated one is still used, except for the models shown by PiTool

The firmware update must work in any case, as long as all Pimax software is not active.


#87

Ok that helps a lot but still doesn’t explain why i couldn’t update the knuckles until i threw the newer driver in the folder?


#88

For people not seeing hands in the Moondust/Hand Demo. Make sure Steam VR Home is enabled in your settings. I noticed I had no hands in Moondust when I had it turned off.


#89

Because sometime correlation does not imply causation


#90

deleted think I was talking crap


#91

I found the real issue with knuckles not beign able to be seen in steamvr, the solution for it and the answer on the question why Cas and Chary didn’t have to nothing to get them working with pimax.

The problem isn’t the new folder with no content but just the name of controllers in the file steam>steamapps>common>steamvr>drivers>indexcontrollers>driver.drivermanifest

Just open it with any text editor (notepad) and edit the “name”. Instead of “indexcontrollers” put in “knuckles”. Problem solved, don’t need to insall ANY new files. Knuckles are visible.

Now the solution of Cas and Chary - they had already old knuckles driver installed so they had files with content in the path steam>steamapps>common>steamvrknucklesdriver. As the pitool is checking both pathes (knucklesdriver folder AND native indexcontroller folder) for files, they did had already the file driver.drivermanifest with " knuckles" rdy as an old version of it was exactly with only that one change.

Cheers


#92

And now my very odd issue with knuckles. One of my controllers (sometimes the right one, sometimes the left one) keeps disappering in any application. Doesn’t matter i start steamvrhome or Onward or i just open the dashboard. One of my controller isn’t tracked correctly, it just disappers randomly.

I tried to reinstall everything, pitools,steam,steamvr etc. I tried with steam vr tracking 2.0 and 1.0 - same issue.

On my OG Vive everything works perfrect so it isn’t a hardware issue. For some reason the pitool is telling the knuckles "don’t track both controllers same, one needs to lose the tracking constantly).

Any ideas?


#93

It would be good to have a video guide on how to install this controllers.


#94

i don’t think pitool is checking anything like this, its all about steam vr and the how pimax integrates into steam vr
the pimax hmd announces the path of its integration dll to steam vr like “C:\Program Files\Pimax\SteamVRSupport\drivers\aapvr\bin\win64\driver_aapvr.dll”
in that file pimax has coded the controller name “knuckles” into the code, position hex 21ff8 for pitools 132, just behind that position you find all the variables you see in the manifest file like /input/finger/pinky
the old driver just adds the path of the old driver to steam and then steam knows about a controller “knuckles” the pimax dll uses - at this moment steam has two controllers one named “indesxcontrollers” the other “knuckles”
if you can make it work by changing the controller name in the newer driver manifest file its a nice solution too but we should keep in mind that this “patched” manifest file will be overwritten without warning when steam vr is updated (that will not happen to the old driver - its not maintained anymore)
it might be a solution to copy the new driver to the driver of the old one and renaming the controller in the manifest there, at least that will not be overwritten and the new controller code is used


#95

from the video it looks like the right controller looses tracking, but that should change it you stand the other way around (turn 180°)
did you try to stand in a different spot?


#96

I spent like 8 hours to troubleshot this, believe me i did change positions… Figured out that if i connect the controller through wire the problem isn’t persist anymore. That must be the driver issue. Anyone knows how to do forced firmware update on knuckles?


#97

i’ve just tryed you method, it did not work for me, there might be a controller visible in the start enviroment but as soon as i started the home enviroment id did not see the hands as it should be (with the old driver) but i got images of the knuckles kontroller with a wheel in the plce of the touchpad and no buttons work (and naturally the fingers dont work)
also tried to copy it to the location of the old driver an change some more files (driver.vrresources, *.json, {indexcontroller} to {knuckles}) but did not work either, there would be much more to change
its much easier for now to use the old driver and wait a few days until new pitools come with a (valve approved) final solution for it


#98

did you update your firmware after unpacking? (i did with my vive)


#99

yes i did it with my vive as well


#100

I just tried with my vive again. Knuckles work without a single problem, the tracking is perfect. Switched to pimax and was awful as before. Tried base stations 2.0 and 1.0 - same result. One of the controllers just isn’t tracked well. It’s definitely a software issue between pimax and steamvr…


#101

Have you used mmorselli’s fix in its entirety? That seems to offer full functionality to anyone who uses it.