Index Controller (Knuckles) - Easy Working Solution!

fix-guide

#102

Yes, i did exactly same thing. That’s not a problem. The issue is somewhere else. I have done everything what i could for 8 hours of reinstalling and tweaking stuff. Absolutely no clue what’s going on. Noticed also that if controllers are connected with usb cable the issue doesn’t appear. It’s very odd and it seems very isolated issue.


#103

Ah, that’s unfortunate!


#104

Sorry to hear that folks

Aside, Lone Echo is amazing with the Index controllers. The group function is perfect and the other buttons are easier to use now. For example, boost and communication menu is on a button and not the Vive Wand track pads


#105

Very strange usually i would redo roomscale on pitool and steam. Im assuming these method were already done by you. Try deleting the lighthouse folder for pitool.


#106

Valve has not made enough mention about the profile workshop for Index Controllers. For Lone Echo there is an excellent profile created by Brian Lindenhof, Climbey’s dev.


#107

Lone Echo : Works only with Parallel Projections turned on and normal field of view . Getting 55-65 fps using pimax xr , Pi too rendering @ 1.0 , rtx 2080 ti @ 2ghz and i9 9900k -.- … I bet valve index Vr headset would have more fps due to not using parallel projection…


#108

Valve index does use a PP. Was posted where it is in steamvr settings file. Though should use less resources than pimax due to less canting & FoV.


#109

What about Star Vr One and Xtal ?


#110

Since Valve has even implemented a pp correction for minor canting. StarVR & Xtal having Canted displays will have some kind of pp correction (just likely hidden).

See Journey to Infinite blog from Sept’s Berlin Meetup. He explains why render correction needed for non parallel screens. And talks about Oculus Half Dome will require Rendering corrections for programs not made for curved screens. (Why Oculus Half Dome shelved for now)


#111

After we update them, is it normal to see the generic C icon, or should we be seeing the Index icons when we’re playing?


#112

You will see the C still


#113

if you look closely, that’s the description on how to do a firmware update (without using a vive), fw update does not work when indexcontroller is connected by the pimax headset (and its not shown as indexcontroller, just a C for controller)
maybe that will be better with the new beta that was announced, fixing index support (in a valve approved way) was announced


#114

btw. i counted 23 LH sonsors on a index controller


#115

Yeah, the profile workshop is already full of great profiles, with more coming all the time.


#116

How do you rebind controls for Oculus games?


#117

I tried only Lone Echo several months ago, I simply loaded the Brian Lindenhof profile, nothing else, and it worked fine

Now SteamVR Input also has the option to emulate an Oculus Touch, but I’ve never tried it, I’m not a Facebook and Exclusive titles big fan


#118

I have this same issue. Just using Pitool, my Vive w/knuckles works fine. It’s mostly my left controller… and it’s really frustrating trying to play Onward when i can’t grip the gun consistently.


#119

Did anyone use this technique with success, then update to the new Pitool Beta that “fixes” index controller support?

I’m trying to figure out how/if I should undo what this fix did in order to use the new Pitool. Because I have the new Pitool, and now nothing’s working. It just shows controllers are disconnected, even after pairing them.


#120

i did, i’ve just deleted the content of the additional (old) driver folder and installed new pitools (should not be importend when the old driver is deleted, has nothing to do with pitools, its a stream thing and even if steam was started it should be possible to close it, delete the contend of the folder and start steam again)
had no problwms, the controller where still paired in pitools after the update and steam vr started with the proper mini icons of the controller (only generic “C” for the old driver with the old pitools)


#121

Just to say that if you have it all working (via latest pitool and latest index firmware) then what I’ve found is two obvious things to say “yes, it’s fully working now” :slight_smile:

  1. you get the actual index controller images in steam vr (but normal ones in pitools) and not the Cs

  2. My index point finger no longer has to actual press down on the gun trigger to close. It now closes far more naturally away from the gun trigger point (maybe this is after playing for 2 days though calibration). I can even “pinch” my index and middle finger together for “dainty pickup” of items :slight_smile:

Hope you guys get to this point too!