Index Controller Use With Pimax Discussion

issue
pitool

#241

This sounds like a “blind spot” to me. Are you using a sync cable between the base stations?

Im not sure if this is corrent, but here is my theory based on some testings done in the past. If you dont use a sync cable, the base stations needs to see eachother at all time. If they dont see eachother for a moment, then only the first “A” basestation will track the controllers. Lets say your base station “A” is in front, it will not see your controller behind your back, and it will stop to track it (it disappears).

This problem could happen in case your base stations are positioned too low or incorrectly, and in some cases your head (or lets say a ceiling lamp or something between) disrupts the “free sight” between the base stations.

Using a sync cable, the base stations are always paired and working together, no matter if they see eachother or not. This is why I ended up using a sync cable already 2 years ago, and never stopped doing so. I got much more reliable tracking using a sync cable.

Another theory could be if you have any mirror/window in your room, that creates reflections and causes “blind spots” for the base station(s).

Anyhow, try using a sync cable and see if it helps @yxcxcv !


#242

I had a similar problem with my index controllers. Turned out it was sunlight from the window. Try shutting your curtains/blinds.


#243

Yep Steam Tracking like psvr & constellation tracking do not like sunlight.


#244

I just found some index controllers on EBay. They would cost over $800 au delivered . Is that a bargain or what :upside_down_face::+1::upside_down_face::upside_down_face::upside_down_face::upside_down_face::upside_down_face:


#245

Find a friend in Eu or Us that buy it for you and send ti to you as gift.


#246

Yeah that’s a good idea .


#247

I’ve been using the Index hmd and knuckles until today.

So I installed the new Pitool to get back into the 5k+.
In steamvr home environment I see my fingers move as they should with the knuckles.

I fired up Skyrim and I could walk around and turn with the joysticks but that famous A-button problem was there. I already run the Nexus mod for that so I just thought I’d check the controller bindings in steam settings. Nope! That didn’t work. Opted out of steamvr beta and tried again - nope!
Fudge.

Is there a fix, dear peeps?

I searched this forum and googled but couldn’t find anything.


#248

Have not paired my index controllers to the 5k+, but in general (with the index) I do not need any “fix” - I just launch the game from desktop, and never go into the SteamVR dashboard during the game, and everything works as intended.


#249

So no A-button fix in Skyrim for you?


#250

Nope - A button works just fine, as long as I leave that system button alone; But as I said: I haven’t tried it with my p5k+ - only the index.


#251

You need to do it like him, start SkyrimVR from the 2D Desktop. Don’t go into Steam Home and start it from there or anything. I don’t know if the SkyrimVR devs are aware of this or even care, there is heated discussion going on between the Index Controller users. I got them as well. I checked many of the third party “fixes”, none reliably worked so far. Got to see.


#252

Npt sure about a fix but im using index controllers fine with Pimax in Skyrim. Its with the VRIK (which i heartily recommend anyhow) verson of the A button fix.

You’ve got to make sure the controllers are on and detected BEFORE you boot Skyrim though or only the triggers work.


#253

It’s when you trigger the Steam overlay that the bug comes. Whever you are using index or Pimax or whatever.

One work around that ppl use is to disable Steam Dashboard and Home. Which is a variation of what you are doing. Otherwise they use the A button fix.


#254

Yes I was using the sync cable in the first configuration. The base stations are positioned right and saw each other in b and c mode without any drops. I also covered all tvs and monitors, even the windows. no luck. Valve support instructed me a few steps and came to the same conclusion, rma. so I will reply in a few weeks if the issue is solved. Thank you Swe! Next thing is, that I am not happy with my performance on a x99 rog with 2400 mhz ram, a 6950k and a 1080ti. but thats another issue :slight_smile:


#255

just to be sure, cable mode is A&B


#256

VRIK, noted, thank you mate. Will try it


#257

i know this is an ubsurdly late reply but, THIS is what ive been saying for months now. I feel like some how the fact that pimax works at all with steamVR feels about as official as ALVR or Virtual Desktop creating fake hmds for purposes of streaming.

I dont think there is a line of code in steamVR recognizing the pimax or FOV wider than 130 deg (diagonal)
the fact that steam VR home has objects disappearing from view past 110 deg is proof of this.

SteamVR home is made by valve and thats before you even launch into a game. How hard would it be for steamVR to issue an update to their own application to recognize if fov = pimax dont hide objects in peripheral.

It feels like Pimax doesnt exist to them.


#258

Check out Risa Hmdq tool. It confirms OpenVR(SteamVR) is indeed seeing the FoV requested fine. Doc-Ok even confirmed it in early days. Just means Valve hasn’t optimized there “Cliff House” copy(Steam Home) for Wide FoV.

TbH Steam Home is ok; but user Workshop enviroments imho is generally better.


#259

Has it to be in A + B mode? I did B + C because thats the only mode where both stations shutdown, when I power off just the one in B mode.


#260

Yes: